Fedora Linux Support Community & Resources Center
  #1  
Old 13th March 2005, 06:57 PM
VlacDebil Offline
Registered User
 
Join Date: Mar 2005
Posts: 46
Unhappy FC3 and Wireless Intel Pro 2200 GB

Hi, I have the following prb. I just bought a Laptop (Toshiba Satellite M45-S331)
And i am trying to make the wireless connection work.

What I did :
=> reinstalled FC Core 3 2.6.9 1.667

=> rpm-ed the kernel update : kernel 2.6.10-1.770.i686...

=> rebooted : a new device is detected (my wireless card, I thought : Wonderfull, and
checked the automatic setting with dpchpcph i dont remember what)

=> then there was a problem with the firmware, so i
rmped :

ipw2200-mkdl-2.6.10-1.770_FC3.rhfc3.at.i686.rpm
ipw2200-firmware-2.2..at.norarch.rpm
ipw2200-1.0.0-23.rhfc3.at.i386.rpm

(with rpm -Uvh, alltogether)

=>rebooted ....

=======>Then comes my problem

The wireless card is seen by the hardware manager, but not by the internet wizard....
and a dmesg gives:

[root@localhost ~]# dmesg | grep w2200
ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.0.0
ipw2200: Copyright(c) 2003-2004 Intel Corporation
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
ipw2200: failed to send TX_POWER command
ipw2200: failed to send TX_POWER command
ipw2200: failed to send TX_POWER command
ipw2200: failed to send TX_POWER command
ipw2200: failed to send TX_POWER command
ipw2200: Unable to initialize device after 5 attempts.
ipw2200: failed to register network device
ipw2200: probe of 0000:05:04.0 failed with error -5



Anybody has a piece of advice ???

Thanks !!

Mathias
Reply With Quote
  #2  
Old 13th March 2005, 07:51 PM
VlacDebil Offline
Registered User
 
Join Date: Mar 2005
Posts: 46
Well some further details :

lsmod gives me that the modules ipw2200, ieee80211 and ieee80211_crypt are correctly loaded

in /etc/modprobe.conf there is alias ipw2200 eth0 (I have no other card...)

but /sbin/service network restart ends up with :
Bringing up interface eth0: ipw2200 device eth0 does not seem to be present, delaying initialization

I really don't know what to do next....
Reply With Quote
  #3  
Old 13th March 2005, 08:23 PM
Jezster Offline
Registered User
 
Join Date: Jul 2004
Age: 44
Posts: 28
Well I would use the following tools (via root seems to work)....

# iwlist eth[n] scan

This will should the available networks (even the hidden SSID stuff), next...

# iwconfig eth[n] mode managed essid [ssidname]

At this point I used 'ifconfig eth0 down' to close my ethernet port, and then re-installed the default route for external access using 'route add default gw nnn.nnnn.nnn.nnn'.

Not sure about WEP Keys so you'll need to check them out elsewhere.

Cheers,

Jez.
Reply With Quote
  #4  
Old 13th March 2005, 08:32 PM
VlacDebil Offline
Registered User
 
Join Date: Mar 2005
Posts: 46
Well the problem is that the interface is not even brought up....
So in /sbin/ifconfig -a it does not appear and therefore neither in iwconfig nor iwlist
Reply With Quote
  #5  
Old 13th March 2005, 11:57 PM
VlacDebil Offline
Registered User
 
Join Date: Mar 2005
Posts: 46
Angry Wireless 2200 Help !!

Well I re-did everything but using the tar ball rather than rpms

->reinstalled fedora
->upgraded to 1.770
->extracted the firware in /lib/firmware
->make and make install of the driver

-> reboot

now a dmesg | grep w2200
gives me :

ipw2200_boot.fw load failed
unable to load firmware....


On the sourceforge page of the driver it says that it is due to a firmeware_class problem

I thus tried :

$ modprobe firmware_class

wich results in : FATAL: Module firmware_class not found....


What should I do ???

Thanks !

Last edited by VlacDebil; 13th March 2005 at 11:58 PM. Reason: mistake
Reply With Quote
Reply

Tags
2200, fc3, intel, pro, wireless

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help :-( Wireless Intel 2200 ad Fc 3 1.770 VlacDebil Servers & Networking 18 19th April 2005 03:55 PM
Intel PRO/Wireless 2200 card TenorMan3 Servers & Networking 1 16th March 2005 01:03 AM
Wireless Intel 2200 BG Pro VlacDebil Servers & Networking 6 13th March 2005 07:01 PM
Intel PRO/Wireless 2200 not working doza Servers & Networking 1 2nd March 2005 08:53 PM
Intel Pro Wireless 2200 BG Help jellyfish Installation, Upgrades and Live Media 5 22nd July 2004 01:31 PM


Current GMT-time: 15:10 (Thursday, 30-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Dschang - Lhokseumawe Photos - Midvale Photos on Instagram