Fedora Linux Support Community & Resources Center
  #1  
Old 21st February 2005, 12:32 AM
Lee134 Offline
Registered User
 
Join Date: Feb 2005
Posts: 62
Nvidia and GLX problem

Hi all, I am new here. I seem to be having problems with installing my nvidia drivers and the assistance I have found via the forum search function hasnt really helpedme to resolve te problem. I have tried both the method that Mike suggests here, and also installing via yum and both cases result in the same problem. When I try to run glxgears I get the following:

Code:
[root@server ~]# glxgears
Xlib:  extension "GLX" missing on display ":0.0".
glxgears: Error: couldn't get an RGB, Double-buffered visual.
[root@server ~]#
Now I have commented out all the DRI stuff in xorg.conf and added nvidia as per the instructions but so far, no joy. Here is my xorg.conf file:

Code:
# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database.  Note, this is the name of the 
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
	RgbPath      "/usr/X11R6/lib/X11/rgb"
	ModulePath   "/usr/X11R6/lib/modules/extensions/nvidia"
	ModulePath   "/usr/X11R6/lib/modules"
	FontPath     "unix/:7100"
EndSection

Section "Module"
	Load  "dbe"
	Load  "extmod"
	Load  "fbdevhw"
	Load  "record"
	Load  "freetype"
	Load  "type1"
	Load  "glx"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#	Option	"Xleds"		"1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#	Option	"XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#	Option	"XkbModel"	"pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#	Option	"XkbModel"	"microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#	Option	"XkbLayout"	"de"
# or:
#	Option	"XkbLayout"	"de"
#	Option	"XkbVariant"	"nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#	Option	"XkbOptions"	"ctrl:swapcaps"
# Or if you just want both to be control, use:
#	Option	"XkbOptions"	"ctrl:nocaps"
#
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "ADI 5P"
	DisplaySize  300	230
	HorizSync    30.0 - 69.0
	VertRefresh  50.0 - 120.0
	Option	    "dpms"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nvidia"
	VendorName  "Videocard vendor"
	BoardName   "NVIDIA GeForce 2 MX (generic)"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     16
		Modes    "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

# Section "DRI"
# 	Group        0
# 	Mode         0666
# EndSection
I am kind of a Linux newbie so anypointers would be very much appreciated. By the way, I am running Fedora Core 3 kernel 2.6.10-1.766_FC3. The graphics card is an old Geforce 2 MX

Many thanks
Reply With Quote
  #2  
Old 21st February 2005, 01:12 AM
Woad_Warrior Offline
Registered User
 
Join Date: Dec 2004
Location: Harmony, PA
Posts: 457
did you also do these steps?

# modprobe nvidia
# cp -a /dev/nvidia* /etc/udev/devices
# chown root:root /etc/udev/devices/nvidia*
# chmod 0666 /etc/udev/devices/nvidia*
reboot

following the reboot, you should get the nvidia splash screen.
__________________
registered Linux user number 372931
(okay, so i waited a few years before registering)

I am the answer to life, the universe and everything. (at least until august)

Did someone's answer help you? add to their reputation

various useful links ---> http://www.fedoraforum.org/forum/sho...011#post207011
Reply With Quote
  #3  
Old 21st February 2005, 09:23 AM
Lee134 Offline
Registered User
 
Join Date: Feb 2005
Posts: 62
You know, its the damndest thing. I played around with it for hours last night and got no where. I shut it down and went to bed. When I went to play around with it where I left off again this morning, glxgears worked fine. Wierd. I assume it had something to do with some of the settings I was trying last night but I am in the dark about it really. Ahh well, such is life.

I do have a related question though. Is there any way to turn off the nvidia splash screen? It keeps flicking on and off at various points of the system bootup and its making my nice fedora boot screens look pants.

Many thanks and sorry for wasting your time.
Reply With Quote
  #4  
Old 21st February 2005, 09:56 AM
imdeemvp Offline
Registered User
 
Join Date: Feb 2004
Age: 45
Posts: 8,256
I think you probably forgot to reboot after installing the drivers.....
__________________
HELP with JAVA, MP3's, Wireless, Repo's, YUM, Partitions, System Monitors, Nvidia, ATI drivers, LIMEWIRE PRO & MORE!.

Easiest and most friendly desktop ever is PCLinuxOS! Includes all this apps. Just try it.

"The greater the struggle THE greater the achievment."

Do you know HIM?

If you are an idiot click here. NThis will test you linux skills :D
Reply With Quote
  #5  
Old 21st February 2005, 11:00 AM
ocram Offline
Registered User
 
Join Date: Feb 2005
Posts: 10
Hi,
I have also many problems with installing my nvidia drivers.
logo invidia always stays on the screen and nothing works.
If I write in device session NoLogo "false" in xorg.conf then the screen
is black.
If I write "NvAGP" "1" in device session it works but gnome 2.8 windows then
dosn't work well.
I updated xorg-x11 but unnecessarily.
what can I do yet?
thank, and excuse me for my English.
Reply With Quote
  #6  
Old 21st February 2005, 11:34 AM
Lee134 Offline
Registered User
 
Join Date: Feb 2005
Posts: 62
Well I didnt stray too far from the fedora faq about installing the nvidia drivers via yum and it seems it worked fine using the following:

Code:
yum install nvidia-glx kernel-module-nvidia-`(uname -r)`
I think the chap above is probably right about me forgetting to reboot (what a n00b mistake )

ocram, what video card are you running? On my various searches I have seen people asking about similar problems to you but I didnt pay much attention to what causes it as I wasnt suffering from the same problem. Try searching the forum for nvidia for some tips

Last edited by Lee134; 21st February 2005 at 11:37 AM.
Reply With Quote
  #7  
Old 21st February 2005, 03:46 PM
ocram Offline
Registered User
 
Join Date: Feb 2005
Posts: 10
thaks Lee134, but in the forum I didn't find anything.
My video card is geforce MX440SE
You wrote 'yum install nvidia-glx kernel-module-nvidia-`(uname -r)`'
where did you take nvidia-glx and kernel-module-nvidia?
Reply With Quote
  #8  
Old 21st February 2005, 03:57 PM
kluq Offline
Registered User
 
Join Date: Feb 2005
Posts: 2
hello

I' am using Fedora Core 3 with NVIDIA FX5200 and openGL support is running perfectly.

For instalation I used this HOWTO:

http://www.fedorafaq.org/#nvidia

it worked great and the yum.conf wich is provided there is good to.

Reply With Quote
  #9  
Old 21st February 2005, 04:12 PM
Lee134 Offline
Registered User
 
Join Date: Feb 2005
Posts: 62
ocram, I am not sure if I am understanding your question correctly. If I have misunderstood then sorry but if you are asking what I think you are asking, provided you have an internet connection and you have yum setup correctly then that command will download the correct rpm's for nvidia-glx and kernel-module-nvidia automatically and install them for you. Running that command will also update your xorg.conf file (well it did mine anyway) though it would be best to check that afterwards to ensure the correct options are set (such as "nvidia" instead of "nv" and ensure dri is commented out. Check out the fedora faq's linked at the top of this page and look for the sections on yum and the section on installing the nvidia drivers.

I think yours should work exactly the same as mine since the MX400 and 440 are almost the identical to my Geforce 2 MX. Let me know if you are struggling and I will help further if I can (with my limited knowledge and complete noobyness )

Last edited by Lee134; 21st February 2005 at 04:14 PM.
Reply With Quote
  #10  
Old 22nd February 2005, 10:23 AM
ocram Offline
Registered User
 
Join Date: Feb 2005
Posts: 10
Hi Lee134,
in the terminal with the command:
yum install nvidia-glx kernel-module-nvidia-`(uname -r)`
you can see

Setting up Install Process
Setting up Repo: base
repomd.xml 100% |=========================| 1.1 kB 00:00
Setting up Repo: updates-released
repomd.xml 100% |=========================| 951 B 00:00
Reading repository metadata in from local files
base : ################################################## 2622/2622
updates-re: ################################################## 676/676
No Match for argument nvidia-glx
No Match for argument kernel-module-nvidia-2.6.9-1.667
Nothing to do


Now, what can I do?
I don't understand.
Reply With Quote
  #11  
Old 22nd February 2005, 12:10 PM
Clunixchit Offline
Registered User
 
Join Date: Feb 2005
Location: Strasbourg
Age: 30
Posts: 720
Quote:
Originally Posted by ocram
Hi Lee134,
in the terminal with the command:
yum install nvidia-glx kernel-module-nvidia-`(uname -r)`
you can see

Setting up Install Process
Setting up Repo: base
repomd.xml 100% |=========================| 1.1 kB 00:00
Setting up Repo: updates-released
repomd.xml 100% |=========================| 951 B 00:00
Reading repository metadata in from local files
base : ################################################## 2622/2622
updates-re: ################################################## 676/676
No Match for argument nvidia-glx
No Match for argument kernel-module-nvidia-2.6.9-1.667
Nothing to do
Now, what can I do?
I don't understand.
hav you changerd your yum.conf as said in www.fedorafaq.org/#nvidia?
if not follow the instructions in www.fedorafaq.org/#yumconf
Reply With Quote
  #12  
Old 22nd February 2005, 12:11 PM
Clunixchit Offline
Registered User
 
Join Date: Feb 2005
Location: Strasbourg
Age: 30
Posts: 720
Quote:
Installing: nvidia-glx 100 % done 1/2
/sbin/ldconfig: File /usr/lib/libk3bproject.so.2.0.0.#prelink#.YYL5k8 is empty, not checked.
Installing: kernel-module-nvidia-2.6.10-1.766_FC3 100 % done 2/2
Installed: kernel-module-nvidia-2.6.10-1.766_FC3.i686 0:1.0.6629-0.lvn.6.3 nvidia-glx.i686 0:1.0.6629-0.lvn.6.3
Complete!
Should i care about the bold line?
installation went fine though as i quoted before. glxgears is working fine

Last edited by Clunixchit; 4th March 2005 at 03:44 PM.
Reply With Quote
  #13  
Old 22nd February 2005, 09:47 PM
Lee134 Offline
Registered User
 
Join Date: Feb 2005
Posts: 62
Hi ocram,

like the previous poster said, download the new yum.conf located right at the top of the following page (do all the following as root):

http://www.fedorafaq.org/#installsoftware

Then move the new yum.conf into /etc as stated in the faq and overwrite the one in there.

Then run though all the commands on this page:

http://www.fedorafaq.org/#gpgsig

This installs the gpg keys required for each of the repositories in your new yum.conf.

Finally re-run the command I posted earlier

Code:
yum install nvidia-glx kernel-module-nvidia-`(uname -r)`
After doing all the above, all should be well.


Clunixchit, I am not familiar enough with Linux to answer that but being as the install completed I would imagine it should be ok. Reboot and then try the following command:

Code:
glxgears
You should get an animation of a couple of small gears spinning and you will get your fps in your open terminal window. If you get this then its working fine so you should be able to disregard the warning

Last edited by Lee134; 22nd February 2005 at 09:52 PM.
Reply With Quote
  #14  
Old 22nd February 2005, 10:19 PM
Clunixchit Offline
Registered User
 
Join Date: Feb 2005
Location: Strasbourg
Age: 30
Posts: 720
installation went fine though as i quoted before. glxgears is working fine
Reply With Quote
  #15  
Old 22nd February 2005, 10:44 PM
Woad_Warrior Offline
Registered User
 
Join Date: Dec 2004
Location: Harmony, PA
Posts: 457
Clunix; i wouldn't worry too much about that highlighted message unless you experience a problem with K3b (since that was the app that the highlighted message was about)
ocram; the packages you requested were not in the yum repositories that you have configured. (different repositories might have different naming/numbering conventions for some things)
__________________
registered Linux user number 372931
(okay, so i waited a few years before registering)

I am the answer to life, the universe and everything. (at least until august)

Did someone's answer help you? add to their reputation

various useful links ---> http://www.fedoraforum.org/forum/sho...011#post207011

Last edited by Woad_Warrior; 22nd February 2005 at 10:51 PM.
Reply With Quote
Reply

Tags
glx, nvidia, problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 7 install problem (nVidia SATA raid problem?) jdmclemore Installation, Upgrades and Live Media 12 23rd July 2007 04:03 PM
nvidia/ 64 bit problem Boris Cat Hardware & Laptops 4 27th May 2007 02:40 PM
yet another Nvidia problem JN4OldSchool Using Fedora 3 11th April 2006 12:52 PM
nvidia problem raghavendra Using Fedora 3 29th June 2005 08:15 PM


Current GMT-time: 12:15 (Saturday, 30-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat