Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Security and Privacy
FedoraForum Search

Forgot Password? Join Us!

Security and Privacy Sadly, malware, spyware, hackers and privacy threats abound in today's world. Let's be paranoid and secure our penguins, and slam the doors on privacy exploits.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 8th February 2005, 06:55 PM
CherryCloche Offline
Registered User
 
Join Date: Feb 2005
Posts: 3
Question Server Refused Public Key (ssh)

I've been trying to fix this problem all morning, and I'm not getting anywhere. I'm hoping someone can help.

1) I used puttygen to generate an SSH2/RSA public-private key pair.
2) I copied the contents of the generated key to /home/cifftp/.ssh/authorized_keys
3) I am running pageant.exe, and I loaded my private key into it.
4) I also changed my Putty session to use my private key for authentication, although it's probably not necessary if I'm also running pageant.
5) I verified the permissions on my /home/cifftp/.ssh/authorized_keys file, and they are '-rw-r--r--'
My /home/cifftp/.ssh directory is 'drwxr-xr-x'

When I connect with putty or with pscp, it tells me that the server refused the public key.

My putty log is telling me the following:
Reading d:\ssh-private.ppk
Offered public key
Server refused public key


Here's what my sshd.config file looks like:
Port 22
#Protocol 2,1
ListenAddress 132.10.10.99
#ListenAddress ::

# HostKey for protocol version 1
#HostKey /etc/ssh/ssh_host_key
# HostKeys for protocol version 2
#HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_dsa_key
# Lifetime and size of ephemeral version 1 server key
#KeyRegenerationInterval 1h
ServerKeyBits 1024

# Logging
#obsoletes QuietMode and FascistLogging
#SyslogFacility AUTH
SyslogFacility AUTHPRIV
#LogLevel INFO

# Authentication:

#LoginGraceTime 2m
PermitRootLogin no
#StrictModes yes
#MaxAuthTries 6

RSAAuthentication yes
PubkeyAuthentication yes
AuthorizedKeysFile .ssh/authorized_keys

# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# RhostsRSAAuthentication and HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes

# To disable tunneled clear text passwords, change to no here!
#PasswordAuthentication yes
AllowUsers cifftp laura_b

# Change to no to disable s/key passwords
#ChallengeResponseAuthentication yes
ChallengeResponseAuthentication no

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes
#KerberosGetAFSToken no

# GSSAPI options
#GSSAPIAuthentication no
GSSAPIAuthentication yes
#GSSAPICleanupCredentials yes
GSSAPICleanupCredentials yes

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication mechanism.
# Depending on your PAM configuration, this may bypass the setting of
# PasswordAuthentication, PermitEmptyPasswords, and
# "PermitRootLogin without-password". If you just want the PAM account and
# session checks to run without PAM authentication, then enable this but set
# ChallengeResponseAuthentication=no
#UsePAM no
UsePAM yes

#AllowTcpForwarding yes
#GatewayPorts no
#X11Forwarding no
X11Forwarding yes
#X11DisplayOffset 10
#X11UseLocalhost yes
#PrintMotd yes
#PrintLastLog yes
#TCPKeepAlive yes
#UseLogin no
#UsePrivilegeSeparation yes
#PermitUserEnvironment no
#Compression yes
#ClientAliveInterval 0
#ClientAliveCountMax 3
#UseDNS yes
#PidFile /var/run/sshd.pid
#MaxStartups 10

# no default banner path
Banner /etc/ssh/banner

# override default of no subsystems
Subsystem sftp /usr/libexec/openssh/sftp-server
Reply With Quote
  #2  
Old 9th February 2005, 05:49 AM
Jman Offline
Registered User
 
Join Date: Mar 2004
Location: Minnesota, USA
Age: 28
Posts: 7,909
Check out this troubleshooter.

Also check the event log for diagnostics.
Reply With Quote
Reply

Tags
key, public, refused, server, ssh

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
/dev folder missing ... Server refused to allocate pty fed.linuxgossip Using Fedora 2 7th June 2007 05:15 PM
** server can't find www.yahoo.com: REFUSED fire-fly Servers & Networking 1 21st February 2006 10:14 PM
** server can't find www.yahoo.com: REFUSED fire-fly Servers & Networking 1 21st February 2006 09:09 AM
public email server traz Servers & Networking 3 21st June 2005 01:52 AM
Apache Server Connection Refused blckleprd Servers & Networking 3 3rd March 2005 03:06 AM


Current GMT-time: 08:31 (Sunday, 26-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Narail Photos on Instagram - Vespasiano - Koforidua Photos