Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora Resources > Guides & Solutions (No Questions)
FedoraForum Search

Forgot Password? Join Us!

Guides & Solutions (No Questions) Post your guides here (No links to Blogs accepted). You can also append your comments/questions to a guide, but don't start a new thread to ask a question. Use another forum for that.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 7th January 2005, 09:26 PM
Ug Offline
Retired Community Manager
 
Join Date: Feb 2004
Posts: 2,999
Configuring Yum For A Proxy

Got yourself a shiny copy of Fedora Core 3? Want to update it to the latest packages available? Yet feel let down by Fedora's inability to change the settings for the proxy server system wide via the "Preferences -> Network Proxy" dialogue? Then step inside...

First of all get your network proxy settings to hand. And keep them somewhere where you can see them. Then load up your favourite terminal of choice and execute:
Code:
su -
cd /etc
cp wgetrc wgetrc.backup
gedit wgetrc &
This will load up a config file for Wget after making a backup copy of it. Search through the config file until you find the area:
Quote:
# You can set the default proxies for Wget to use for http and ftp.
# They will override the value in the environment.
#http_proxy = http://proxy.yoyodyne.com:18023/
#ftp_proxy = http://proxy.yoyodyne.com:18023/

# If you do not want to use proxy at all, set this to off.
#use_proxy = on
Now edit this section to insert your proxy information. Remembering to remove the '#' signs infront of http_proxy, ftp_proxy and use_proxy. It should now look something like this:
Quote:
# You can set the default proxies for Wget to use for http and ftp.
# They will override the value in the environment.
http_proxy = http://wwwcache.nottingham.ac.uk:3128/
ftp_proxy = http://wwwcache.nottingham.ac.uk:3128/

# If you do not want to use proxy at all, set this to off.
use_proxy = on
With that done save the file and then close gedit, and execute the following on the command line:
Code:
gedit /root/.bash_profile &
At the bottom of the config file insert the following, where "yourproxyaddress:portnumber" is your proxy server information.
Quote:
http_proxy=yourproxyaddress:portnumber
export http_proxy
Save the file and close gedit. Whilst we're at it we may as well edit your user profile to incorprate the proxy settings. From the command line execute:
Code:
gedit /home/<username>/.bashrc_profile &
Then simlpy insert the same details as you did for root. Save the file and then close gedit. Yum should now be configured for your proxy server. To test simply use Yum as you normally would, for instance updating the system:
Code:
yum update
If you are unsure about how to use yum check out the FedoraFAQ and read the help provided with yum. This help can be accessed by issuing the following command in the terminal:
Code:
yum help
I hope that helps some folks!
__________________
gareth@fedoraforum.org
Registered Linux User # 301555
garethrussell.net


Please adhere to the FedoraForum Guidelines.
Reply With Quote
  #2  
Old 23rd January 2005, 12:11 PM
Ug Offline
Retired Community Manager
 
Join Date: Feb 2004
Posts: 2,999
This is related.
__________________
gareth@fedoraforum.org
Registered Linux User # 301555
garethrussell.net


Please adhere to the FedoraForum Guidelines.
Reply With Quote
  #3  
Old 3rd February 2005, 12:51 PM
edwardblum Offline
Registered User
 
Join Date: Dec 2004
Posts: 7
more options for connecting yum through proxy

unfortunately the above pointeres didnt work for me (yum just hung for a infinate time, whether its to do with how the proxy is set up i dont know, but to access the internet through the proxy so yum would work,

i had to edit only /etc/profile

adding the lines at the bottom


export http_proxy=http://username:password@wwwcache.bangor.ac.uk:8080
export ftp_proxy=http://username:password@wwwcache.bangor.ac.uk:8080
export gopher_proxy=http://username:password@wwwcache.bangor.ac.uk:8080

works perfectly now, let me know if this helps, im a linux newbie!
Reply With Quote
  #4  
Old 13th February 2009, 05:59 PM
vismay Offline
Registered User
 
Join Date: Feb 2009
Posts: 1
on typing the below mentioned command
gedit /home/<username>/.bashrc_profile &


i get the following result
[1] 4897
[root@localhost ~]# bash: username: No such file or directory

[1]+ Exit 1 gedit /home/ < username > /.bashrc_profile


could you plz help me out with it..
THanks
Reply With Quote
  #5  
Old 21st April 2009, 10:52 AM
shaamil Offline
Registered User
 
Join Date: May 2005
Posts: 1
Dear vismay,
You have taken this syntax wronf. Here < username > is your linux user name for example if your logon user name is vismay then the syntax will be :

gedit /home/vismay/.bashrc_profile &

I hope I have made you clear.

All the best..
Reply With Quote
Reply

Tags
configuring, proxy, yum

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Configuring Gnome to use an intercepting proxy mpolo Using Fedora 1 22nd June 2009 04:53 PM
problem configuring proxy server popey Servers & Networking 5 18th March 2008 05:52 PM
Problem of configuring to connect through proxy pingpong Servers & Networking 1 5th August 2007 08:57 AM
configuring outlook express behind squid proxy srinivas1980 Fedora Core 5 - Dev 3 18th April 2007 03:26 PM
Configuring Giam while using proxy server in network vijayrom Fedora Core 5 - Dev 0 18th November 2006 04:04 AM


Current GMT-time: 09:45 (Sunday, 23-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin Copyright 2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Hongwon Photos on Instagram - Eloy - Handan