OK, something is definitely fubar. This is what I see in /var/log/messages at bootup time:
Code:
Dec 23 17:57:16 localhost systemd: Failed at step EXEC spawning /usr/sbin/xrdp-sesman: Permission denied
Dec 23 17:57:16 localhost systemd: Failed at step EXEC spawning /usr/sbin/xrdp: Permission denied
Dec 23 17:57:16 localhost abrtd: Can't open file '/var/tmp/abrt/ccpp-2013-01-05-20:43:26-659/type': No such file or directory
Dec 23 17:57:16 localhost abrtd: Can't open file '/var/tmp/abrt/ccpp-2013-01-05-20:43:26-659/type': No such file or directory
Dec 23 17:57:16 localhost abrtd: '/var/tmp/abrt/ccpp-2013-01-05-20:43:26-659' is not a problem directory
Dec 23 17:57:16 localhost systemd: xrdp-sesman.service: main process exited, code=exited, status=203/EXEC
Dec 23 17:57:16 localhost systemd: Unit xrdp-sesman.service entered failed state.
Dec 23 17:57:16 localhost systemd: xrdp-sesman.service failed.
Dec 23 17:57:16 localhost systemd: xrdp.service: main process exited, code=exited, status=203/EXEC
Dec 23 17:57:16 localhost systemd: Unit xrdp.service entered failed state.
Dec 23 17:57:16 localhost systemd: xrdp.service failed.
Actually that shows two issues: xrdp processes did not start and there is some kind of problem with abrtd not finding /var/tmp/abrt/ccpp-2013-01-05-20:43:26-659/type. The directory /var/tmp/abrt/ccpp-2013-01-05-20:43:26-659 does exist. The content of /var/tmp/abrt/ is:
Code:
[jim@localhost xrdpbackup]$ cd /var/tmp/abrt
[jim@localhost abrt]$ ls -l
total 60
drwxrwx---. 2 root abrt 4096 Dec 23 17:57 ccpp-2013-01-05-20:43:26-659
drwxrwx---. 2 root abrt 4096 Dec 23 17:57 ccpp-2013-03-31-13:43:09-865
drwxrwx---. 2 jim abrt 4096 Dec 23 17:57 ccpp-2013-07-07-11:45:35-8260
drwxrwx---. 2 jim abrt 4096 Dec 23 17:57 ccpp-2014-01-03-14:27:19-1222
drwxrwx---. 2 jim abrt 4096 Dec 23 17:57 ccpp-2014-01-30-12:50:54-1170
drwxrwx---. 2 jim abrt 4096 Dec 23 17:57 ccpp-2014-04-02-15:38:27-1299
drwxrwx---. 2 jim abrt 4096 Dec 23 17:57 ccpp-2014-04-09-08:08:47-1232
drwxrwx---. 2 jim abrt 4096 Dec 23 17:57 ccpp-2014-04-24-12:56:37-1266
drwxrwx---. 2 jim abrt 4096 Dec 23 17:57 ccpp-2014-04-30-22:52:39-1246
drwxrwx---. 2 jim abrt 4096 Dec 23 17:57 ccpp-2014-11-23-22:09:14-1250
drwxrwx---. 2 jim abrt 4096 Dec 23 17:57 ccpp-2014-11-28-19:02:40-1259
drwxrwx---. 2 jim abrt 4096 Dec 23 17:57 ccpp-2014-12-21-14:19:56-1257
drwxrwx---. 2 jim abrt 4096 Dec 23 17:57 ccpp-2014-12-22-22:10:47-1754
drwxrwx---. 2 jim abrt 4096 Dec 23 17:57 ccpp-2014-12-23-17:48:44-1808
-rw-------. 1 root root 19 Dec 23 17:48 last-ccpp
[jim@localhost abrt]$
Some of those directories have a file name type in them.
Returning to the xrdp issue: the xrdp.service file contains:
Code:
[Unit]
Description=xrdp daemon
Requires=xrdp-sesman.service
After=syslog.target network.target xrdp-sesman.service
[Service]
EnvironmentFile=/etc/sysconfig/xrdp
ExecStart=/usr/sbin/xrdp $XRDP_OPTIONS --nodaemon
[Install]
WantedBy=multi-user.target
And the xrdp-sesman.service file contains:
Code:
[Unit]
Description=xrdp session manager
BindTo=xrdp.service
After=syslog.target network.target
StopWhenUnneeded=true
[Service]
EnvironmentFile=/etc/sysconfig/xrdp
ExecStart=/usr/sbin/xrdp-sesman $SESMAN_OPTIONS --nodaemon
[Install]
WantedBy=multi-user.target
I am curious about the --nodaemon option. That does not make sense to me and that is not the way /etc/xrdp/xrdp.sh starts the processes. So I removed the option and tried again with the same result.
So systemd is trying to start xrdp but can't. But I can.
Time to write a bug report? Any other ideas?
Thanks Jim