Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora Resources > Guides & Solutions (No Questions)
FedoraForum Search

Forgot Password? Join Us!

Guides & Solutions (No Questions) Post your guides here (No links to Blogs accepted). You can also append your comments/questions to a guide, but don't start a new thread to ask a question. Use another forum for that.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 15th December 2004, 06:19 AM
Darkmage Offline
Registered User
 
Join Date: Mar 2004
Posts: 462
How to ndiswrapper in Fedora

I originally had a write up on linuxquestions.org at Broadcom but after some time, I found an easy way of making things work

If you want ndiswrapper from cvs then use the above link else download the stable version from
ndiswrapper

or
Please make sure kernel-devel is installed to make the install easy and painless
If you have FC4 and have /etc/yum.repo.d/livna.repo configured
Code:
[livna-stable]
name=Livna.org Fedora Compatible Packages (stable)
baseurl=http://rpm.livna.org/fedora/$releasever/$basearch/RPMS.lvn
enabled=0
gpgcheck=1
Code:
 
# yum --enablerepo=livna-stable install ndiswrapper kernel-module-ndiswrapper-$(uname -r)
or for FC5 do this

Code:
 # yum -y install kmod-ndiswrapper
For my case, I have a Broadcom BCM9306 chipset and the windows driver needed is bcmwl5.inf and bcmwl5.sys. Move both files to a folder in your home directory called bcmwl. I hope you know you first have to creat the folder bcmwl
Code:
mkdir bcmwl
Do the "make install" only if you have the source file. I will strongly recommend the rpm file from livna
Open a terminal and uncompress ndiswrapper.

Go to the ndiswrapper folder and as root
Code:
 
#make install    --do this if you downloaded the source file or skip this if you used the livna rpm
Code:
# /usr/sbin/ndiswrapper -i <your home directory>/bcmwl/bcmwl5.inf   
         ...this command will create a folder in /etc/ndiswrapper/bcmwl5/bcmwl5.inf
# /usr/sbin/ndiswrapper -l
         -- make sure it says "bcmwl5 present" 
# /sbin/depmod -a
#/sbin/modprobe ndiswrapper
# dmesg 
         --you will see a log about the driver been loaded if you do then
# /usr/sbin/ndiswrapper -m
        --create an alias in /etc/modprobe.conf
Here comes the easy part
close terminal and point your cursor to Desktop -->System Settings -->Network Configuration and type in the root's password when prompted.
In Network Configuration, click on New and then "Select Device type box" shows, highlight Wireless connection and click on "Forward".
This brings up the "Select Wireless Device box" window, which has ndiswrapper(wlan0) highlighted, then click "Forward".
This bring up the "Configure Wireless Connection box" which allows you to set the mode, ssid, channel, rate and hex key. After you are done, click "Forward"
This brings up the "Configure Network Settings box" which allows you to set the dhcp, dns and ip address. When you are done, then click forward.
The next box "Create Wireless Device box" has all you settings for you to double check before hitting apply.
When you hit apply, it should take you back to Network Configuration, highlight the created wlan0 and click "Edit" which allows you to fine tune the configuration, like if you want all users to be able to enable wlan0, if you want wlan0 to start on boot etc. Go though the tabs and check everything and make sure it is up to your specification, then click "Ok" and then the final thing
on "Network Configuration", click on "File" and then "Save"

If every is correct, you can then click on activate to activate wlan0

If you have any constructive comments please post

Below are screenshots and broadcom drivers and on page 13, I have posted the newer driver
Attached Thumbnails
Click image for larger version

Name:	wireless1.png
Views:	9109
Size:	629.8 KB
ID:	7408   Click image for larger version

Name:	wireless2.png
Views:	5607
Size:	639.1 KB
ID:	7411   Click image for larger version

Name:	wireless3.png
Views:	4507
Size:	817.5 KB
ID:	7412   Click image for larger version

Name:	wireless4.png
Views:	4874
Size:	580.1 KB
ID:	7413  
Attached Files
File Type: zip bcmwl5.zip (265.0 KB, 5052 views)

Last edited by Darkmage; 12th September 2006 at 10:21 PM.
Reply With Quote
  #2  
Old 15th December 2004, 06:31 AM
SQFreak Offline
Registered User
 
Join Date: Dec 2004
Posts: 1
My wireless card (Dell TrueMobile 1350 I think) requires bcmwl5a. It works fine when I use the commandline utilities to work with it (iwconfig, iwscan, dhcpd, ifconfig, etc.), but the Network utility won't see the card.

Code:
ndiswrapper version 0.12 loaded (preempt=no,smp=no)
usbcore: registered new driver dellomci
ndiswrapper: driver dellomci () added
ACPI: PCI interrupt 0000:01:03.0[A] -> GSI 7 (level, low) -> IRQ 7
ndiswrapper: using irq 7
divert: allocating divert_blk for wlan0
wlan0: ndiswrapper ethernet device 00:90:96:bb:f6:69 using driver bcmwl5a
wlan0: encryption modes supported: WEP, WPA with TKIP, WPA with AES/CCMP
ndiswrapper: driver bcmwl5a (Broadcom,02/17/2004, 3.40.65.0) added
ndiswrapper: driver bcmwl5 (Broadcom,02/17/2004, 3.40.65.0) added
Any suggestions?
Reply With Quote
  #3  
Old 15th December 2004, 06:42 AM
Darkmage Offline
Registered User
 
Join Date: Mar 2004
Posts: 462
What is the output of /etc/modprobe.conf
Reply With Quote
  #4  
Old 16th December 2004, 08:52 AM
Shadow Skill Offline
Registered User
 
Join Date: Aug 2004
Posts: 1,317
Gah I finally got my card to work again after reading this, I forgot about the -m flag that creates the appropriate alias for ndiswrapper. I was starting to loose hope until I read this, thanks for posting it.
__________________
Ware wa mutekinari.
Wa ga kage waza ni kanau mono nashi.
Wa ga ichigeki wa mutekinari.



Please vote for this bug and help me make GAYT [Go As You Type ]a standard option in Firefox.
Reply With Quote
  #5  
Old 16th December 2004, 08:57 AM
Darkmage Offline
Registered User
 
Join Date: Mar 2004
Posts: 462
Thumbs up

I am glad this helped and yes you are right the key to ndiswrapper in Fedora is
Code:
ndiswrapper -m
I think this allows the Network Configuration to detect it and can then be configured with the gui tool
Reply With Quote
  #6  
Old 16th December 2004, 10:01 AM
Shadow Skill Offline
Registered User
 
Join Date: Aug 2004
Posts: 1,317
that creates the alias the gui tool needs in modprobe.conf...elusive thing it is.
__________________
Ware wa mutekinari.
Wa ga kage waza ni kanau mono nashi.
Wa ga ichigeki wa mutekinari.



Please vote for this bug and help me make GAYT [Go As You Type ]a standard option in Firefox.
Reply With Quote
  #7  
Old 4th April 2005, 09:49 PM
andywhitehurst Offline
Registered User
 
Join Date: Apr 2005
Posts: 7
hi there...

i followed this guide and it seems to have worked without any problems... having manually set the ip details for my dlink dwl-g520+ card from my router's ip management details i can activate the wireless connection...

i'm pretty green when it comes to linux however and i was wondering what else i need to do to actually get the internet working; i get a 'google.co.uk could not be found' type error when i run firefox... am i missing something really obvious?
Reply With Quote
  #8  
Old 5th April 2005, 05:41 AM
Darkmage Offline
Registered User
 
Join Date: Mar 2004
Posts: 462
Quote:
Originally Posted by andywhitehurst
hi there...

i followed this guide and it seems to have worked without any problems... having manually set the ip details for my dlink dwl-g520+ card from my router's ip management details i can activate the wireless connection...

i'm pretty green when it comes to linux however and i was wondering what else i need to do to actually get the internet working; i get a 'google.co.uk could not be found' type error when i run firefox... am i missing something really obvious?
Since you can activate your wireless connection, post the output of
Code:
/sbin/iwconfig
Reply With Quote
  #9  
Old 5th April 2005, 11:29 PM
solidsnake Offline
Registered User
 
Join Date: Apr 2005
Posts: 21
Beautiful, hopefully this is the solution to my problem. :P

EDIT: Do I still have to make a symlink for the modules folder? That seems to be my main area of frustration.

Last edited by solidsnake; 5th April 2005 at 11:52 PM.
Reply With Quote
  #10  
Old 6th April 2005, 02:15 AM
Darkmage Offline
Registered User
 
Join Date: Mar 2004
Posts: 462
Quote:
Originally Posted by solidsnake
Beautiful, hopefully this is the solution to my problem. :P

EDIT: Do I still have to make a symlink for the modules folder? That seems to be my main area of frustration.
Please specify what modules you want to make a symlink to. I am trying to understand your question.
Reply With Quote
  #11  
Old 6th April 2005, 05:32 AM
solidsnake Offline
Registered User
 
Join Date: Apr 2005
Posts: 21
Quote:
Originally Posted by Darkmage
Please specify what modules you want to make a symlink to. I am trying to understand your question.
It seems I resolved that problem, ndiswrapper works fine, however, now i get this error when trying to install the .inf file:

Code:
Installing mrv8k51
Parse error in inf. Unable to find section W8100PCI.zerocfg
Parse error in inf. Unable to find section W8100PCI.zerocfg
Parse error in inf. Unable to find section W8100PCI.zerocfg
Wireless card is a DWL-G510, driver was downloaded from dlink for the revA version. I'm stuck at this point, because ndiswrapper says it is installed even though i get the above error, but it will not work.
Reply With Quote
  #12  
Old 7th April 2005, 11:32 AM
Darkmage Offline
Registered User
 
Join Date: Mar 2004
Posts: 462
Quote:
Originally Posted by solidsnake
It seems I resolved that problem, ndiswrapper works fine, however, now i get this error when trying to install the .inf file:

Code:
Installing mrv8k51
Parse error in inf. Unable to find section W8100PCI.zerocfg
Parse error in inf. Unable to find section W8100PCI.zerocfg
Parse error in inf. Unable to find section W8100PCI.zerocfg
Wireless card is a DWL-G510, driver was downloaded from dlink for the revA version. I'm stuck at this point, because ndiswrapper says it is installed even though i get the above error, but it will not work.
My suggestion as root, delete /etc/ndiswrapper with
Code:
rm -fr /etc/ndiswrapper
then install your *.inf file again with
Code:
ndiswrapper -i <this contains the location of your .inf file
After the above, try to bring up your wireless connection
Reply With Quote
  #13  
Old 7th April 2005, 03:29 PM
solidsnake Offline
Registered User
 
Join Date: Apr 2005
Posts: 21
Darkmage,

I believe I was using an incorrect driver, or I completed one of the steps out of place. Everything works now! Your guide was a big help, thanks again mate

My installation of a DWL-G510 RevB:

Before I begin, I want to say that you need to update your kernel to a 16k stack size first and foremost: http://ndiswrapper.sourceforge.net/p...dex.php/Fedora

I copied the drivers from the install CD included with my wireless PCI card directly to my home folder.

After running # make install, I had to run "# bash -l" in order for it to recognize the ndiswrapper command.

All other installation was just as Darkmage described, hopefully you are all familiar enough with routers to get the IP information set correctly for the wireless card. For some reason, the software made it default to Channel 1, and I cannot seem to change this option, so I set my router to broadcast 802.11g on Channel 1 instead of 9.

I was running WEP and a MAC filter on my wireless network prior to this, but I had to disable all of them in order to troubleshoot this card. Now, I guess I will gradually turn those options back on and see if I can get them to work properly.

All I can say is patience and perseverence will get you up and running 8)

Last edited by solidsnake; 7th April 2005 at 06:35 PM.
Reply With Quote
  #14  
Old 8th April 2005, 12:30 AM
Darkmage Offline
Registered User
 
Join Date: Mar 2004
Posts: 462
@solidsnake
I am glad you got it working. The 16k stack is recommended but not required because I am using the development kernel.
For the Channel, the default is 1 but, you can change it.
Code:
 Click on System settings, 
then highlight and click on Network, 
type in the root password, 
hightlight your wireless connection
Click Edit on the Top menu
Go to the tab that says Wireless Settings
Here you can change the Channel, add the WEP key 0x before the hex numbers, transmit rate, ssid and Mode.

I am using Mac filtering and WEP encryption as I type this response

Last edited by Darkmage; 8th April 2005 at 04:29 AM.
Reply With Quote
  #15  
Old 8th April 2005, 12:44 AM
solidsnake Offline
Registered User
 
Join Date: Apr 2005
Posts: 21
That is good to know!

One more question: It seems that it takes my computer about 2-5 minutes to establish a conneciton after being idle.

Example: I launch Firefox, it states that is it "looking up <website>" for a few minutes, then it works fine from then on. Is there a service that I should be running to stop that?
Reply With Quote
Reply

Tags
fedora, ndiswrapper

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ndiswrapper on fedora 10 demonmail Hardware & Laptops 10 4th January 2009 08:48 PM
ndiswrapper + Fedora 9 BlackWolf Servers & Networking 6 30th August 2008 12:40 AM
Ndiswrapper Fedora 8 boromlamtoro Servers & Networking 327 3rd June 2008 06:49 AM
Fedora 8, ndiswrapper, WPA KirkD Servers & Networking 7 25th February 2008 11:06 PM
Ndiswrapper for Fedora 8! keatonvictor Hardware & Laptops 4 30th November 2007 02:18 AM


Current GMT-time: 11:26 (Tuesday, 16-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat