Fedora Linux Support Community & Resources Center
  #1  
Old 13th December 2004, 09:34 PM
Omega430 Offline
Registered User
 
Join Date: Dec 2004
Posts: 11
error: C compiler cannot create executables

I have been having trouble compiling ANYTHING. Anytime I run ./configure for any installation I get the error 'error: C compiler cannot create executables'.
I ran which gcc and what not and it's installed. I am NEW to the Linux World. I am running Fedora Core 1. Is there an environmental variable I need to set? Can I refer to GCC in the path of ./configure?
This is the error log from ProFTPd.

Any help would be greatly appreciated!!! Thanks Guys.


This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by configure, which was
generated by GNU Autoconf 2.57. Invocation command line was

$ ./configure

## --------- ##
## Platform. ##
## --------- ##

hostname = test.dualtemp.com
uname -m = i686
uname -r = 2.4.22-1.2115.nptl
uname -s = Linux
uname -v = #1 Wed Oct 29 15:31:21 EST 2003

/usr/bin/uname -p = unknown
/bin/uname -X = unknown

/bin/arch = i686
/usr/bin/arch -k = unknown
/usr/convex/getsysinfo = unknown
hostinfo = unknown
/bin/machine = unknown
/usr/bin/oslevel = unknown
/bin/universe = unknown

PATH: /usr/kerberos/sbin
PATH: /usr/kerberos/bin
PATH: /usr/local/sbin
PATH: /usr/local/bin
PATH: /sbin
PATH: /bin
PATH: /usr/sbin
PATH: /usr/bin
PATH: /usr/X11R6/bin
PATH: /root/bin


## ----------- ##
## Core tests. ##
## ----------- ##

configure:1397: checking build system type
configure:1415: result: i686-pc-linux-gnulibc1
configure:1423: checking host system type
configure:1437: result: i686-pc-linux-gnulibc1
configure:1445: checking target system type
configure:1459: result: i686-pc-linux-gnulibc1
configure:1533: checking for gcc
configure:1559: result: gcc
configure:1803: checking for C compiler version
configure:1806: gcc --version </dev/null >&5
gcc (GCC) 3.3.2 20031022 (Red Hat Linux 3.3.2-1)
Copyright (C) 2003 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:1809: $? = 0
configure:1811: gcc -v </dev/null >&5
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/3.3.2/specs
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-threads=posix --disable-checking --with-system-zlib --enable-__cxa_atexit --host=i386-redhat-linux
Thread model: posix
gcc version 3.3.2 20031022 (Red Hat Linux 3.3.2-1)
configure:1814: $? = 0
configure:1816: gcc -V </dev/null >&5
gcc: `-V' option must have argument
configure:1819: $? = 1
configure:1843: checking for C compiler default output
configure:1846: gcc conftest.c >&5
/usr/bin/ld: cannot open crt1.o: No such file or directory
collect2: ld returned 1 exit status
configure:1849: $? = 1
configure: failed program was:
| #line 1822 "configure"
| /* confdefs.h. */
|
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE_BUGREPORT ""
| /* end confdefs.h. */
|
| int
| main ()
| {
|
| ;
| return 0;
| }
configure:1888: error: C compiler cannot create executables
See `config.log' for more details.

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_build=i686-pc-linux-gnulibc1
ac_cv_build_alias=i686-pc-linux-gnulibc1
ac_cv_env_CC_set=set
ac_cv_env_CC_value=gcc
ac_cv_env_CFLAGS_set=
ac_cv_env_CFLAGS_value=
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_LIBS_set=
ac_cv_env_LIBS_value=
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_host=i686-pc-linux-gnulibc1
ac_cv_host_alias=i686-pc-linux-gnulibc1
ac_cv_prog_ac_ct_CC=gcc
ac_cv_target=i686-pc-linux-gnulibc1
ac_cv_target_alias=i686-pc-linux-gnulibc1

## ----------------- ##
## Output variables. ##
## ----------------- ##

ADDL_DIRS=''
ALLOCA=''
BINDIR=''
BUILD_MODULE_OBJS=''
CC='gcc'
CFLAGS=''
CPP=''
CPPFLAGS=''
CURSES_LIBS=''
DEFS=''
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EGREP=''
EXEEXT=''
INCLUDES=''
INSTALL_DATA=''
INSTALL_PROGRAM=''
INSTALL_SCRIPT=''
INSTALL_STRIP=''
LDFLAGS=''
LIBOBJS=''
LIBRARIES=''
LIBS=''
LIB_OBJS=''
LOCALSTATEDIR=''
LTLIBOBJS=''
MODULE_OBJS=''
OBJEXT=''
OSREL='-DLINUX'
OSTYPE=''
PACKAGE_BUGREPORT=''
PACKAGE_NAME=''
PACKAGE_STRING=''
PACKAGE_TARNAME=''
PACKAGE_VERSION=''
PATH_SEPARATOR=':'
RANLIB=''
SBINDIR=''
SET_MAKE=''
SHELL='/bin/sh'
SYSCONFDIR=''
VERSION=''
ac_ct_CC='gcc'
ac_ct_RANLIB=''
bindir='${exec_prefix}/bin'
build='i686-pc-linux-gnulibc1'
build_alias=''
build_cpu='i686'
build_os='linux-gnulibc1'
build_vendor='pc'
datadir='${prefix}/share'
exec_prefix='NONE'
host='i686-pc-linux-gnulibc1'
host_alias=''
host_cpu='i686'
host_os='linux-gnulibc1'
host_vendor='pc'
includedir='${prefix}/include'
infodir='${prefix}/info'
install_group=''
install_user=''
libdir='${exec_prefix}/lib'
libexecdir='${exec_prefix}/libexec'
localstatedir='${prefix}/var'
mandir='${prefix}/man'
oldincludedir='/usr/include'
prefix='NONE'
program_transform_name='s,x,x,'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
sysconfdir='${prefix}/etc'
target='i686-pc-linux-gnulibc1'
target_alias=''
target_cpu='i686'
target_os='linux-gnulibc1'
target_vendor='pc'

## ----------- ##
## confdefs.h. ##
## ----------- ##

#define PACKAGE_BUGREPORT ""
#define PACKAGE_NAME ""
#define PACKAGE_STRING ""
#define PACKAGE_TARNAME ""
#define PACKAGE_VERSION ""

configure: exit 77
Reply With Quote
  #2  
Old 13th December 2004, 10:11 PM
Artemis Offline
Registered User
 
Join Date: Oct 2004
Location: The Netherlands
Age: 30
Posts: 220
Yes you've to install the development tools, you can do this in the package management. In the menu->System Settings->Add/Remove Applications
__________________
"Lead the troops into battle like a monkey into space, your unneeded wars will be the death of our race. Not black, not white, no single ethnicity, I mean the death of the race called humanity..." Linux user 372264

Everybody is free to add me on msn or yahoo.
Reply With Quote
  #3  
Old 14th December 2004, 03:16 AM
Jman Offline
Registered User
 
Join Date: Mar 2004
Location: Minnesota, USA
Age: 28
Posts: 7,909
Or you could get an already compiled Fedora rpm package.
Reply With Quote
  #4  
Old 14th December 2004, 03:43 PM
Omega430 Offline
Registered User
 
Join Date: Dec 2004
Posts: 11
I have them installed. When I run 'which gcc' I get the response '/usr/bin/gcc' ande when I run which CC I get 'usr/bin/cc'.

Do I need to add a variable that references that? This is really starting to tweak me. HULK MAD!


Thanks Guys!!
Chris
Reply With Quote
  #5  
Old 15th December 2004, 12:47 AM
Jman Offline
Registered User
 
Join Date: Mar 2004
Location: Minnesota, USA
Age: 28
Posts: 7,909
I highly recommend setting up yum.conf like in the FAQ, removing the # in front of the dag entry, and running
Code:
yum install proftpd
If you want to compile, I see gcc being found, so that is not a problem.

Attach the part of the config.log file, in the directory that you ran ./configure, that shows the error.

Last edited by Jman; 15th December 2004 at 12:53 AM.
Reply With Quote
  #6  
Old 15th December 2004, 02:03 AM
Omega430 Offline
Registered User
 
Join Date: Dec 2004
Posts: 11
I have the whole error log listed above in my original message.
Reply With Quote
  #7  
Old 15th December 2004, 05:44 PM
Jman Offline
Registered User
 
Join Date: Mar 2004
Location: Minnesota, USA
Age: 28
Posts: 7,909
Have you tried the "yum install" method I mentioned? RPMs may be easier than compiling.
Reply With Quote
  #8  
Old 15th December 2004, 06:19 PM
Artemis Offline
Registered User
 
Join Date: Oct 2004
Location: The Netherlands
Age: 30
Posts: 220
Quote:
Originally Posted by Omega430
/usr/bin/ld: cannot open crt1.o: No such file or directory
I think I found the problem, you need the file crt1.o. I located that file on my machine and I figured out what package you need to install:
Code:
rpm -qf /usr/lib/crt1.o
glibc-devel-2.3.3-74
Here's the rpm link, try it and let me know if it worked!!!
__________________
"Lead the troops into battle like a monkey into space, your unneeded wars will be the death of our race. Not black, not white, no single ethnicity, I mean the death of the race called humanity..." Linux user 372264

Everybody is free to add me on msn or yahoo.
Reply With Quote
  #9  
Old 15th December 2004, 06:26 PM
riyakku Offline
Registered User
 
Join Date: Sep 2004
Posts: 16
I have come across this problem of "error: C compiler cannot create executables". Later I found that I was compiling as a user and not as a super user. Compiling as a super user did the trick.

HTH

Riyakku
Reply With Quote
Reply

Tags
compiler, create, error, executables

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
C compiler cannot create executables knoppix21 Using Fedora 4 19th June 2009 07:59 AM
C compiler cannot create executables.... zacharysturgeon Using Fedora 1 8th June 2008 01:11 AM
configure: error: C compiler cannot create executables skrv Hardware & Laptops 4 23rd March 2008 04:22 PM
Compiler cannot create executables darkhut Using Fedora 26 28th June 2007 11:45 PM
C compiler cannot create executables ypswes Using Fedora 3 17th March 2004 02:21 PM


Current GMT-time: 13:20 (Friday, 28-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Canillo - Paris Shato Ledo - Condado Lagoon Villas At Hilton Photos - Boeing Air and Space Museum