Fedora Linux Support Community & Resources Center
  #1  
Old 4th September 2013, 03:21 PM
fnordmorph Offline
Registered User
 
Join Date: Jul 2013
Location: Colorado USA
Posts: 3
linuxchrome
F19 Graphics Driver Problem Dell XPS12 with Intel HD4000

Beating my head against this problem since F19 was released. This is a rotating touch screen XPS-12 running a fresh install of Fedora 19 from install media (not live media), yum updated as of this morning including testing releases. Haven't been able to get it to boot with graphics acceleration. Boots OK with nomodeset kernel parameter, but suspend doesnt work (just locks it up).

Tried installing rpm-fusion and mesa-dri-drivers:

$ yum list installed | grep mesa
mesa-dri-drivers.x86_64 9.2-1.20130902.fc19 @updates-testing
mesa-filesystem.x86_64 9.2-1.20130902.fc19 @updates-testing
mesa-libEGL.x86_64 9.2-1.20130902.fc19 @updates-testing
mesa-libGL.x86_64 9.2-1.20130902.fc19 @updates-testing
mesa-libGLU.x86_64 9.0.0-2.fc19 @fedora
mesa-libgbm.x86_64 9.2-1.20130902.fc19 @updates-testing
mesa-libglapi.x86_64 9.2-1.20130902.fc19 @updates-testing
mesa-libxatracker.x86_64 9.2-1.20130902.fc19 @updates-testing

but after installing those, it still requires nomodeset to boot.

Based on this bug report: https://bugzilla.redhat.com/show_bug.cgi?id=991707 I tried taking out nomodeset and putting in i915.modeset=1 (doesn't boot), then acpi_osi=Linux and acpi_backlight=vendor -- this last changes things: I get a correct resolution encryption password screen and the 'f bubble' icon looks right (instead of stretched out like it's using a default 1024x768 or something) -- but it crashes right after the 'f' fills up: if I 'esc' to see the boot messages (in time), I see that it is stalling after 'starting udev wait for complete device initilization', then locks up after three system-udevd messages, ending in 'cpu3 killed', 'wlan0 killed', and 'controlC0 killed'.

graphics hardware:
$ sudo lspci -s 00:02.0 -vv -nn
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
Subsystem: Dell Device [1028:0589]
Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Interrupt: pin A routed to IRQ 16
Region 0: Memory at c0000000 (64-bit, non-prefetchable) [size=4M]
Region 2: Memory at b0000000 (64-bit, prefetchable) [size=256M]
Region 4: I/O ports at 2000 [size=64]
Expansion ROM at <unassigned> [disabled]
Capabilities: [90] MSI: Enable- Count=1/1 Maskable- 64bit-
Address: 00000000 Data: 0000
Capabilities: [d0] Power Management version 2
Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [a4] PCI Advanced Features
AFCap: TP+ FLR+
AFCtrl: FLR-
AFStatus: TP-

update; same results with kernel 3.11.0-3.fc20.x86_64

Anyone got any ideas? Sure would like to get this working!

Last edited by fnordmorph; 5th September 2013 at 03:20 PM. Reason: new info
Reply With Quote
  #2  
Old 26th September 2013, 11:40 PM
fnordmorph Offline
Registered User
 
Join Date: Jul 2013
Location: Colorado USA
Posts: 3
linuxchrome
Re: F19 Graphics Driver Problem Dell XPS12 with Intel HD4000

Cricktets.
Reply With Quote
Reply

Tags
dell, driver, f19, graphics, hd4000, intel, intel hd4000, problem, xps 12, xps12

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thinkpad with Intel HD4000 graphics board fedorus Hardware & Laptops 14 28th November 2013 05:58 PM
Dell E6510 with Intel Integrated graphics: I get 800x600 instead of 1920x1080 vincegata Installation, Upgrades and Live Media 0 5th May 2011 02:02 AM
Dual Head on Dell E6410 (Intel Graphics) fborden Hardware & Laptops 1 5th September 2010 01:24 PM
Dell D620 - Intel 945GM Graphics Problem Boysey Hardware & Laptops 6 15th April 2009 08:49 PM
F10 Intel i810 driver workaround (For people with intel integrated graphics, must rea Tuxic Hardware & Laptops 0 17th March 2009 12:38 AM


Current GMT-time: 09:50 (Friday, 01-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat