Fedora Linux Support Community & Resources Center
  #1  
Old 6th December 2004, 04:08 PM
scoob8000 Offline
Registered User
 
Join Date: Nov 2004
Posts: 19
FC3: Screensavers don't work in KDE

In Fedora Core 3, only the "random" screensaver will work.
Selecting any others result in a blank screen when they load.

Notes:
  • I have tried with power managment on and off with no effect.
  • I've only tried this in KDE since thats all I use.
  • The screensavers will run if I run them from commandline.
  • Screensaver will not run from command line if root option is used! - This one has me thinking...
  • Configuring with xscreensaver-demo will make savers work until next reboot. This breaks the lock desktop button. The screen locks, but does not blank. This leads me to believe this may be a KDE issue.

In case you're wondering, this is where I am trying to get the savers working from.
Reply With Quote
  #2  
Old 9th December 2004, 08:43 PM
dunleav1 Offline
Registered User
 
Join Date: Dec 2004
Posts: 4
KDE screensaver

I have the same issues with the screensaver. The screensaver runs from configure desktop and I pick test screensaver. However, when I lock the screen all I get is a blank screen.
Reply With Quote
  #3  
Old 9th December 2004, 11:49 PM
blimbo Offline
Registered User
 
Join Date: Oct 2004
Posts: 33
I have the same problem. Not sure if they're factors but I have a Radeon 9000 (on FC3) and thus don't have the latest ATI drivers. Also got dual head xinerama set up. All the screensavers come up when I hit 'test' but otherwise I just get a black screen
Reply With Quote
  #4  
Old 10th December 2004, 06:05 AM
cascadefx Offline
Registered User
 
Join Date: Dec 2004
Posts: 2
Been tracking this one down myself

It appears that not all of the screensavers under KDE are "broken".

Try the "Solar Winds" screensaver under the Open GL group. If it works, try the following:

Change to root:

Code:
su
Make sure your locate file cache is up to date... speed it up with nice:

Code:
nice -19 updatedb&
When it is all done, look for KDE only screensavers (*.kss files):

Code:
locate *.kss
Now try each of these. I bet they all work. At least they did for me.

The problem seems to be those screensavers that are controlled by xscreensaver (the ones that work under gnome) and are probably linked to a problem with the xscreensaver.kss file (which I guess handles launching the xscreensavers under KDE).

Just some guessing, but I think it is going in the right direction.

Any chance that developers read these forums?
Reply With Quote
  #5  
Old 11th December 2004, 07:50 PM
numb Offline
Registered User
 
Join Date: Dec 2004
Location: Rome, ITALY (EU)
Posts: 36
same problem for me too .. any new idea?
Reply With Quote
  #6  
Old 13th December 2004, 08:34 PM
cascadefx Offline
Registered User
 
Join Date: Dec 2004
Posts: 2
A fix... hopefully this will really be fixed.

It looks like there is a fix, which is basically to downgrade to the FC2 packages of xscreensaver... More at http://www.fedoraforum.org/forum/sho...41&postcount=3

Surely this will be fixed with a patch on FC3, won't it?

Does anybody have a bug filed with FC3 that we can append this info too?

Last edited by cascadefx; 13th December 2004 at 08:35 PM. Reason: Added a line
Reply With Quote
  #7  
Old 14th December 2004, 12:12 AM
Dr Caleb Offline
Registered User
 
Join Date: Jul 2004
Posts: 10
I've got a different question, but related.

It seems like different screensavers are installed between choosing "wokstation" and "server" during installation.

The one installed with "workstation" has the ability to remove certain plugins from the list of cycled screensavers, and can change the active screensaver after a pre-determined time. The one installed with the 'server' option does not.

Any ideas?
__________________
We are Pentium of Borg. Division is futile. You will be approximated.
Reply With Quote
  #8  
Old 14th December 2004, 05:46 PM
Dr Caleb Offline
Registered User
 
Join Date: Jul 2004
Posts: 10
Anyone? Throw a guy a bone?
__________________
We are Pentium of Borg. Division is futile. You will be approximated.
Reply With Quote
  #9  
Old 14th December 2004, 09:34 PM
scoob8000 Offline
Registered User
 
Join Date: Nov 2004
Posts: 19
Are you using KDE in both of the installs?

I've noticed the gnome config screen for screensavers is quite different then in KDE.


Has anyone else a machine with a different linux distro and KDE 3.3? Mandrake 10 maybe? I'm just wondering if this is a KDE 3.3 issue of a FC3 issue..


Intresting that reverting to an old version of Xscreensaver seems to fix it for some..

Quote:
The problem seems to be those screensavers that are controlled by xscreensaver (the ones that work under gnome) and are probably linked to a problem with the xscreensaver.kss file (which I guess handles launching the xscreensavers under KDE).
Yup, all the .kss savers work for me.

-scoob8000
Reply With Quote
  #10  
Old 15th December 2004, 09:24 PM
Dr Caleb Offline
Registered User
 
Join Date: Jul 2004
Posts: 10
<i>Are you using KDE in both of the installs?</i><p>
I'm an ID1oT.<p>
I was using KDE on both, but on the "Personal Desktop" option, I was not unchecking the default Gnome. I don't know why it auto checks Gnome when you install the personal workstation . . .but it does.<p>
I don't know why the default X server is XFCM ethier, unless you install Gnome. Haven't used that since I got my first Ydgrassil CD's on my 80386 That's bit me a couple times too .

Lessons Learned: FC3 "Personal Desktop" installs Gnome as the default X manager. All others use XFCM as the default.

Thanks for your responses!
__________________
We are Pentium of Borg. Division is futile. You will be approximated.
Reply With Quote
  #11  
Old 16th December 2004, 02:11 PM
scoob8000 Offline
Registered User
 
Join Date: Nov 2004
Posts: 19
Quote:
Originally Posted by Dr Caleb
<i>Are you using KDE in both of the installs?</i><p>
I'm an ID1oT.<p>
I was using KDE on both, but on the "Personal Desktop" option, I was not unchecking the default Gnome. I don't know why it auto checks Gnome when you install the personal workstation . . .but it does.<p>
I don't know why the default X server is XFCM ethier, unless you install Gnome. Haven't used that since I got my first Ydgrassil CD's on my 80386 That's bit me a couple times too .

Lessons Learned: FC3 "Personal Desktop" installs Gnome as the default X manager. All others use XFCM as the default.
I'm pretty confident that KDE has been crippled in FC3. Almost as if they tried too hard to make FC3 gnome centric.

All of my setups are from the same kickstart file, custom install, KDE only.

No matter what desktop you install from the install (except gnome) it will load XFCM because the /etc/sysconfig/desktop has
Code:
DESKTOP="GNOME"
in it no matter what you chose to be your default.

Kinda fishy.

Anyway, back to subject. I tried a few different xscreensaver packages.
  1. 4.18.x From the devel packages
  2. 4.14.5 From the FC2 packages

Results:
1. All the .kss savers worked, in preview and when triggered. The rest even failed to preview.

2. All the screensavers that were in FC2 work, the new additions to FC3 (pong, pacman, etc) are now broken.

-scoob8000
Reply With Quote
  #12  
Old 26th December 2004, 04:45 PM
marcelteun Offline
Registered User
 
Join Date: Dec 2004
Posts: 7
Lost my screensavers after downgrading

As suggested I downgraded my xscreensaver to 4.15-5. However, when I want to configure a screensaver in KDE now, I only see the options:

* blank screen
* random

Anybody seen that problem?

Now even after upgrading again, I do not see any other screensaver.
Reply With Quote
  #13  
Old 16th January 2005, 12:23 PM
marcelteun Offline
Registered User
 
Join Date: Dec 2004
Posts: 7
Solved my problem by installing kdeartwork and kdeartwork-icons
Reply With Quote
  #14  
Old 17th March 2005, 05:47 AM
Dr_Strangelove Offline
Registered User
 
Join Date: Mar 2005
Posts: 89
Gnome to KDE Broke Screensavers

Howdy folks,

I was running Gnome in FC3 with basicly no problems. I saw some of the cool desktops available in KDE and decided to check it out. After logging out and switching to KDE i looked around a bit and decided I did not need all the fancy stuff in KDE was happy with Gnome after all.

So I logged out and switched back to Gnome. Now none of my Gnome openGL screensavers (that were working fine) will work now.

What's the deal?? Any Ideas?

Last edited by Dr_Strangelove; 17th March 2005 at 06:16 AM.
Reply With Quote
Reply

Tags
fc3, kde, screensavers, work

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Screensavers LinuxHippy Using Fedora 2 20th June 2005 03:07 AM


Current GMT-time: 05:23 (Monday, 24-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Monaco - Chandauli Travel Photos on Instagram - Evora