Fedora Linux Support Community & Resources Center
  #1  
Old 20th September 2012, 09:01 PM
currobosch Offline
Registered User
 
Join Date: Sep 2012
Location: Madrid
Posts: 5
windows_7chrome
INSMOD error. Not Permitted operation

Hello,
I have Fedora 13 (2.6) I am trying to load a kernel module via 'insmod' command. And I get the following error for 'insmod' command:

"Error: inserting my_module: -1 Operation not permitted"

Has anyone any idea?

Thanks

PS. I tried it as root.
Reply With Quote
  #2  
Old 20th September 2012, 11:19 PM
jpollard Offline
Registered User
 
Join Date: Aug 2009
Location: Waldorf, Maryland
Posts: 6,870
linuxfirefox
Re: INSMOD error. Not Permitted operation

How did you get to root?

It also may be blocked due to improper security labels.
Reply With Quote
  #3  
Old 21st September 2012, 11:02 AM
currobosch Offline
Registered User
 
Join Date: Sep 2012
Location: Madrid
Posts: 5
windows_7chrome
Re: INSMOD error. Not Permitted operation

Hello,
I tried two way for getting the root, with the same result:

First one:
Code:
[genera@localhost ~]$ su
Password: 
[root@localhost genera]# cd xapp1022/
[root@localhost xapp1022]# ls
bitstreams  Linux_Driver  MET.exe  MET_GUI  readme.txt  WindowsXP_Driver
[root@localhost xapp1022]# cd Linux_Driver/
[root@localhost Linux_Driver]# ls
make_device  met      Module.markers  Module.symvers  xpcie.c   xpcie.mod.c  xpcie.o
Makefile     met.cpp  modules.order   README          xpcie.ko  xpcie.mod.o
[root@localhost Linux_Driver]# insmod xpcie.ko
insmod: error inserting 'xpcie.ko': -1 Operation not permitted
[root@localhost Linux_Driver]#
And the second one:
Code:
[genera@localhost ~]$ sudo su
[sudo] password for genera: 
genera is not in the sudoers file.  This incident will be reported.
[genera@localhost ~]$ ls
Desktop  Documents  Downloads  Music  Pictures  Public  Templates  Videos  xapp1022
[genera@localhost ~]$ cd xapp1022/
[genera@localhost xapp1022]$ ls
bitstreams  Linux_Driver  MET.exe  MET_GUI  readme.txt  WindowsXP_Driver
[genera@localhost xapp1022]$ cd Linux_Driver/
[genera@localhost Linux_Driver]$ ls
make_device  met      Module.markers  Module.symvers  xpcie.c   xpcie.mod.c  xpcie.o
Makefile     met.cpp  modules.order   README          xpcie.ko  xpcie.mod.o
[genera@localhost Linux_Driver]$ insmod xpcie.ko
insmod: error inserting 'xpcie.ko': -1 Operation not permitted
[genera@localhost Linux_Driver]$
Thanks for your fast answer!
CPB
Reply With Quote
  #4  
Old 21st September 2012, 02:59 PM
jpollard Offline
Registered User
 
Join Date: Aug 2009
Location: Waldorf, Maryland
Posts: 6,870
linuxfirefox
Re: INSMOD error. Not Permitted operation

Try using "su -" instead.

There are some security differences between the two, but I don't think that will affect the result... just something to try.
Reply With Quote
  #5  
Old 21st September 2012, 03:08 PM
currobosch Offline
Registered User
 
Join Date: Sep 2012
Location: Madrid
Posts: 5
windows_7chrome
Re: INSMOD error. Not Permitted operation

I try to load another module (hello_world.ko) ant this new one is correctly laoded.

Therefore, I think that I have some problem with referent to xpcie.ko module (it is a PCIe driver). How can I debug this problem?

In the /var/log/messages I get the following error after insmod command:

Code:
# insmod xpcie.ko
insmod: error inserting 'xpcie.ko': -1 Operation not permitted
log/messages:
Code:
kernel: [82249.079625] xpcie: Init: Hardware not found.
Thanks
CPB

PS. Of course, I tried with PCIe card inserted and turn ON properly.
Reply With Quote
  #6  
Old 21st September 2012, 03:40 PM
PabloTwo Offline
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 6,190
linuxchrome
Re: INSMOD error. Not Permitted operation

You should first copy or move the newly built kernel module (xpcie.ko) to a standard kernel module directory, such as:

/lib/modules/$(uname -r)/extra/xpcie/xpcie.ko

You'll need to create that directory first. After that, then you must run the depmod command:
Code:
# depmod -a
Then try loading the module, as root, using just the basename of the module, without the ".ko" extension. "insmod" is still supported but "modprobe" is the currently preferred command to use to install a kernel module, either should work.
Code:
# modprobe kpcie

Last edited by PabloTwo; 21st September 2012 at 03:44 PM.
Reply With Quote
  #7  
Old 21st September 2012, 06:39 PM
currobosch Offline
Registered User
 
Join Date: Sep 2012
Location: Madrid
Posts: 5
windows_7chrome
Re: INSMOD error. Not Permitted operation

Quote:
Originally Posted by PabloTwo View Post
You should first copy or move the newly built kernel module (xpcie.ko) to a standard kernel module directory, such as:

/lib/modules/$(uname -r)/extra/xpcie/xpcie.ko

You'll need to create that directory first. After that, then you must run the depmod command:
Code:
# depmod -a
Then try loading the module, as root, using just the basename of the module, without the ".ko" extension. "insmod" is still supported but "modprobe" is the currently preferred command to use to install a kernel module, either should work.
Code:
# modprobe kpcie
Hi PabloTwo,
I have done the following:

Code:
[root@localhost Linux_Driver]# mkdir /lib/modules/`uname -r`/extra/xpcie
[root@localhost Linux_Driver]# ls /lib/modules/`uname -r`/extra
xpcie
[root@localhost Linux_Driver]# cp xpcie.ko /lib/modules/`uname -r`/extra/xpcie/
[root@localhost Linux_Driver]# ls /lib/modules/`uname -r`/extra/xpcie/
xpcie.ko
[root@localhost Linux_Driver]# cd /lib/modules/`uname -r`/extra/xpcie/
[root@localhost xpcie]# ls
xpcie.ko
[root@localhost xpcie]# depmod -a
[root@localhost xpcie]# modprobe xpcie
FATAL: Error inserting xpcie (/lib/modules/2.6.34.9-69.fc13.i686/extra/xpcie/xpcie.ko): Operation not permitted
[root@localhost xpcie]#
...the same problem...
any idea?

Thank you so much!
CPB

---------- Post added at 05:39 PM ---------- Previous post was at 05:25 PM ----------

Hello again,

It is done!

The problem was in my xpcie.c file. it doesn't match the HW IDs...

Thank you to all you!

Best regards.

PS. Now I understand better Fedora, at least... it is the good thing for today. Always everyday you learn new one...
Reply With Quote
Reply

Tags
error, errornot, insmod, operation, permitted

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
insmod error "operation not permitted" as root Philmac Using Fedora 0 8th October 2010 06:12 PM
Error installing in /opt operation not permitted or permission denied AliFX Using Fedora 3 30th April 2010 08:42 PM
Operation not permitted error Wh0M3 Using Fedora 4 27th April 2006 10:05 PM
libGL error: open DRM failed (Operation not permitted)+I915GM mclaren_fan Fedora Core 5 - Dev 4 7th March 2006 02:21 AM


Current GMT-time: 00:12 (Friday, 31-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Nagamangala Travel Photos on Instagram - Tyoply Stan Photos - Anapa Photos on Instagram