Fedora Linux Support Community & Resources Center
  #1  
Old 14th August 2012, 03:57 PM
dhirajkhanna Offline
Registered User
 
Join Date: May 2005
Posts: 13
linuxubuntuchrome
Fedora 8 Improper Shutdown

Hello,
I have a lean mean version of Fedora 8 installed on a PXI based SBC P-III machine with 256 MB RAM. The problem is that on shutdown, the screen goes blank and there is no indication of when the system shuts down. In fact, I don't think it is shutting down at all. The "lean mean" part is essentially removal of a lot of packages and services. Is there anything particularly required for ensuring a proper shutdown?
Reply With Quote
  #2  
Old 14th August 2012, 05:15 PM
Gareth Jones Offline
Official Gnome 3 Sales Rep. (and Adminstrator)
 
Join Date: Jul 2011
Location: Birmingham, UK
Age: 32
Posts: 2,771
linuxfirefox
Re: Fedora 8 Improper Shutdown

Moved to EOL.
Reply With Quote
  #3  
Old 14th August 2012, 11:40 PM
stoat Offline
Registered User
 
Join Date: Jun 2006
Posts: 7,550
linuxfirefox
Re: Fedora 8 Improper Shutdown

Removing a lot of stuff to lighten the system can bust things. It happens all the time when people try that. Something to consider instead is to start out with a bare minimum system and build up. The "Minimum" package selection option went away in Anaconda for a while. I don't remember if Fedora 8 had it or not. If it doesn't have it, then a minimum system still can be installed by choosing "Customize now" on the Package Selection page of Anaconda and deselecting everything in there. The result is usually about two hundred packages being installed, it's over in a couple of minutes, and the system boots to a runlevel 3 command prompt. From there you can establish an Internet connection and install exactly what you need with yum (Fedora 8 has long been archived, so your repo config files will have to be manually adjusted for that). Or, you can set up the InstallMedia repo and install things from the DVD.

But if you want to soldier on with the existing system, maybe it's okay. I mean, if it turns off the hardware and then reboots satisfactorily, maybe you've disabled so many services that there isn't much work to do at shutdown. Fedora 8 was the last version to use plain old SysVinit. If you used chkconfig to disable services, that should be okay. If you manually adjusted the runlevel symlinks, then something could be amiss or out-of-order.

What packages were removed (see /var/log/yum.log)? What services are still enabled (see chkconfig --list)?
Reply With Quote
  #4  
Old 16th August 2012, 07:45 AM
dhirajkhanna Offline
Registered User
 
Join Date: May 2005
Posts: 13
linuxfedorafirefox
Re: Fedora 8 Improper Shutdown

I am unable to run acpi daemon. Could that be a problem? If so, can you please provide some help on how to make it run.
Thanks
Reply With Quote
  #5  
Old 16th August 2012, 08:47 AM
MauserM98 Offline
Registered User
 
Join Date: Mar 2009
Location: Norway
Posts: 134
linuxfirefox
Re: Fedora 8 Improper Shutdown

As root try

halt -p
Reply With Quote
  #6  
Old 16th August 2012, 11:47 AM
dhirajkhanna Offline
Registered User
 
Join Date: May 2005
Posts: 13
linuxfedorafirefox
Re: Fedora 8 Improper Shutdown

halt -p also gives the same result.....a blank screen with no indication of whether the system has halted/shutdown or not.
Any more suggestions?
Reply With Quote
  #7  
Old 16th August 2012, 06:04 PM
MauserM98 Offline
Registered User
 
Join Date: Mar 2009
Location: Norway
Posts: 134
windows_7firefox
Re: Fedora 8 Improper Shutdown

It is anyway safe to turn it off after that command. I guess your problem i BIOS related. Check BIOS settings. Or buy a new one. It is anyway an antique you are dealing with....
Reply With Quote
  #8  
Old 16th August 2012, 07:35 PM
stevea Offline
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 9,041
linuxfirefox
Re: Fedora 8 Improper Shutdown

I've see this type behavior a couple times in the past, but I don't have any great solution. If it's like what I've seen it's not BIOS related - it's something funked up in the system software.

I suggest you go to a virtual console <ctrl>+<alt>+<f3> and login as root, and try to watch the shutdown from there. You can get back to the gui console with <ctrl>+<alt>+<f1> or similar.

One issue Ive seen is that when a user logs-out from the gui console, some processes remain and these can cause the shutdown to hang. So logout of the gui con and then from the virtual con do a 'ps -aefl' and look for processes that belong to the users.

IIRC back in the FC8 days shutdown sent signals to init and then the iniitab has some entry to actually kick the power. You may want to trace that out.
__________________
None are more hopelessly enslaved than those who falsely believe they are free.
Johann Wolfgang von Goethe
Reply With Quote
Reply

Tags
fedora, improper, shutdown

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Kmod-nvidia package, improper installation CamoAnimal Using Fedora 3 28th December 2009 02:45 AM
Improper Shutdown, Restart, ect YaKillaCJ Using Fedora 5 4th January 2009 08:37 PM
Improper shutdown question... GreyGoose Using Fedora 4 1st June 2006 09:38 PM
no text console, improper video mode? Beomoss Using Fedora 3 27th May 2006 09:56 AM
Errors after improper shutdown galexy19 Using Fedora 1 13th November 2005 09:19 AM


Current GMT-time: 14:23 (Saturday, 20-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
...Creek Side - Stockholm-Arlanda Airport (ARN) Travel Photos on Instagram - Marina of Koper Travel Photos - Te Whiti Park Instagram Photos - Texas State Fair Photos on Instagram