Fedora Linux Support Community & Resources Center
  #1  
Old 5th August 2012, 05:56 PM
patrick Offline
Registered User
 
Join Date: Mar 2012
Location: Carrboro, NC, USA
Posts: 17
linuxchrome
Question How do you have bluetooth off at boot?

In F17 with Gnome3 my laptop boots with Bluetooth enabled. I would like to have bluetooth off when the computer is turned on, but still available for use if I want it.

A simple systemctl disable bluetooth.service does not stop bluetooth from starting and being on.

I notice there is a bluetooth.target as well, and reading http://fedoraproject.org/wiki/Systemd it is stated as an example under the definition of targets:

"bluetooth.target which is requested as soon as a bluetooth dongle becomes available and which simply pulls in bluetooth related services that otherwise would not need to be started: bluetoothd and obexd and suchlike"

It seems to me from reading the above that on boot this bluetooth.target is started when the system finds the bluetooth hardware? In /etc/systemd/system/bluetooth.target.wants there is a sym link to the bluetooth.service file in /usr/lib/systemd/system/.

So what I really want to do is disable bluetooth.target? systemctl disable bluetooth.target is not a thing.

I have a suspicion that if I blow away that symlink that it will stop the service from starting, but is that really the "right" way to go about this, and would that disable bluetooth for good (which I don't want to do)?


edit: Funny story. Bluetooth is disabled at boot, but the gnome bluetooth-applet starts with the icon lit and says it is enabled, when really there is nothing behind it.

Last edited by patrick; 5th August 2012 at 06:29 PM.
Reply With Quote
  #2  
Old 5th August 2012, 07:25 PM
marko Online
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 6,027
linuxfirefox
Re: How do you have bluetooth off at boot?

You can also use "mask" which is a stronger way of turning off a service
Quote:

systemctl mask bluetooth.service
from 'man systemctl'
Quote:
mask [NAME...]
Mask one or more unit files, as specified on the command line. This will link these units to /dev/null, making it impossible to
start them. This is a stronger version of disable, since it prohibits all kinds of activation of the unit, including manual
activation. Use this option with care.
Reply With Quote
  #3  
Old 5th August 2012, 07:59 PM
BillBauman Offline
Registered User
 
Join Date: Aug 2012
Location: USA
Posts: 12
linuxfirefox
Re: How do you have bluetooth off at boot?

Quote:
Originally Posted by marko View Post
You can also use "mask" which is a stronger way of turning off a service


from 'man systemctl'
I don't think that's the goal here. I'd also like to hear of a way to do this. Completely disabling (mask) the service isn't what most people want. Most of us want it to be available, but off by default (just like we've been able to do in Windows since XP). But, if BT is enabled in the BIOS, it doesn't matter what the previous setting was in Fedora, on reboot, it turns BT back on.

I'd like to see an option to persist BT off across reboots / power cycles. Then, if/when I want to use it, I can simply click it and turn it on. The first thing I do every time I reboot my laptop is click the BT icon and click Off. It's annoying.
Reply With Quote
  #4  
Old 5th August 2012, 08:13 PM
deanej Offline
Registered User
 
Join Date: Nov 2011
Posts: 229
linuxchrome
Re: How do you have bluetooth off at boot?

I ended up having to disable it in BIOS myself (probably shouldn't have gotten BT with the laptop at all since I never use it, but at the time it seemed like I might need it for college and we thought our cell phone BT would actually not be useless at the time). It's a shame that power management is something open source developers never seem to consider.
Reply With Quote
  #5  
Old 5th August 2012, 08:13 PM
patrick Offline
Registered User
 
Join Date: Mar 2012
Location: Carrboro, NC, USA
Posts: 17
linuxchrome
Re: How do you have bluetooth off at boot?

Quote:
Originally Posted by BillBauman View Post
I don't think that's the goal here. I'd also like to hear of a way to do this. Completely disabling (mask) the service isn't what most people want. Most of us want it to be available, but off by default (just like we've been able to do in Windows since XP). But, if BT is enabled in the BIOS, it doesn't matter what the previous setting was in Fedora, on reboot, it turns BT back on.

I'd like to see an option to persist BT off across reboots / power cycles. Then, if/when I want to use it, I can simply click it and turn it on. The first thing I do every time I reboot my laptop is click the BT icon and click Off. It's annoying.
As per my edit in the first post, it seems that the bluetooth.service does stay disabled, but that gnome bluetooth-applet starts as if bluetooth is enabled/available. So the bluetooth icon is "on" when you first log in to gnome. If you open the bluetooth control panel, it shows as disabled.

So maybe this is a bluetooth-applet bug?

I suppose the other issue is, that having disabled the bluetooth service, I doubt bluetooth-applet has the rights to turn it back on for us.

This would probably all be a lot easier if bluetooth-applet just remembered the last state bluetooth was in and set it off it was off on shutdown, etc.
Reply With Quote
  #6  
Old 3rd September 2012, 12:21 AM
thkang Offline
Registered User
 
Join Date: Sep 2012
Location: Seoul, KR
Posts: 25
linuxchrome
Re: How do you have bluetooth off at boot?

Same problem here. My Laptop is thinkpad X201 and I'm running FC17 Gnome with kernel 3.5.2

From my observations (my laptop has LED indicators for bluetooth being on/off and so..), disabling bluetooth services really doesn't help at all. The bluetooth service is stopped (from #service bluetooth status) but bluetooth hardware is on.

I think it is problem of Gnome 3 - their should be an option to turn bluetooth on or off on boot or gnome should remember its last status on shutdown/reboot and keep that status on boot.

Last edited by thkang; 3rd September 2012 at 12:24 AM.
Reply With Quote
  #7  
Old 7th September 2012, 02:25 PM
lighthouse Offline
Registered User
 
Join Date: Mar 2011
Age: 23
Posts: 98
linuxfirefox
Re: How do you have bluetooth off at boot?

I would like to remove bluetooth support forever. But when I did:
Code:
rpm -e --no-deps gnome-session-bluetooth
rpm -e --no-deps pulseaudio-module-bluetooth
it was fine, but when I did:
Code:
rpm -e --no-deps bluez
It removed gnome-session and gnome-panel and lots of things so I could not run a terminal to get them back. And so I'm now reinstalling the system. Weird.

I would wish to remove everything related to bluetooth forever or at least prevent it from booting.
Reply With Quote
  #8  
Old 7th September 2012, 03:10 PM
PabloTwo Offline
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 6,078
linuxchrome
Re: How do you have bluetooth off at boot?

"--no-deps" is NOT an option to the rpm command, so it was ignored. The rpm option you needed to use was "--nodeps".
Reply With Quote
  #9  
Old 7th September 2012, 03:17 PM
lighthouse Offline
Registered User
 
Join Date: Mar 2011
Age: 23
Posts: 98
linuxfirefox
Re: How do you have bluetooth off at boot?

Yes, I did it with '--nodeps'. Sorry, I misstyped. Otherwise it would say me "I do not understand what is --no-deps". Still the problem remains.

---------- Post added at 05:17 PM ---------- Previous post was at 05:16 PM ----------

I'm sorry, Seville is in Spain, not in USA.
Reply With Quote
Reply

Tags
bluetooth, boot, gnome, systemctl

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
bluetooth 3g access using bluetooth with fedora 14 X86_64 rpjogee Servers & Networking 3 2nd January 2011 06:03 AM
Bluetooth not reconnecting at boot ESC201 Servers & Networking 1 5th January 2009 01:12 AM
F8 bluetooth service must be restarted manually after boot mrmailer Using Fedora 3 18th February 2008 06:00 PM
Dual-Boot Bluetooth Pairing phane Using Fedora 0 7th September 2007 01:48 PM
Using KDE Bluetooth framework to send music files to Bluetooth enabled cellphone mndar Servers & Networking 0 15th April 2005 03:25 AM


Current GMT-time: 04:52 (Wednesday, 20-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat