Fedora Linux Support Community & Resources Center
  #1  
Old 31st July 2012, 03:57 PM
ppyvabw Offline
Registered User
 
Join Date: Dec 2008
Posts: 36
linuxchrome
Yet another yum update problem

Code:
Yum update -y
results in this little lot....

Code:
Error: Package: 1:kmod-nvidia-2.6.41.1-1.fc15.i686-280.13-2.fc15.9.i686 (installed)
           Requires: /sbin/depmod
           Removing: kmod-7-1.fc17.i686 (@anaconda-0)
               Not found
           Updated By: kmod-7-2.fc17.i686 (updates)
               Not found
           Available: module-init-tools-3.16-5.fc17.i686 (fedora)
               Not found
Error: Package: 1:kmod-nvidia-2.6.41.4-1.fc15.i686-280.13-4.fc15.i686 (installed)
           Requires: /sbin/depmod
           Removing: kmod-7-1.fc17.i686 (@anaconda-0)
               Not found
           Updated By: kmod-7-2.fc17.i686 (updates)
               Not found
           Available: module-init-tools-3.16-5.fc17.i686 (fedora)
               Not found
Error: Package: 1:kmod-nvidia-2.6.43.5-2.fc15.i686-280.13-4.fc15.5.i686 (@rpmfusion-nonfree-updates/15)
           Requires: /sbin/depmod
           Removing: kmod-7-1.fc17.i686 (@anaconda-0)
               Not found
           Updated By: kmod-7-2.fc17.i686 (updates)
               Not found
           Available: module-init-tools-3.16-5.fc17.i686 (fedora)
               Not found
 You could try using --skip-broken to work around the problem
** Found 8 pre-existing rpmdb problem(s), 'yum check' output follows:
compiz-0.9.5.92.1-0.1.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc15.i686 has missing requires of libboost_serialization-mt.so.1.46.0
compiz-gtk-0.9.5.92.1-0.1.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc15.i686 has missing requires of libboost_serialization-mt.so.1.46.0
compiz-plugins-main-0.9.5.92-1.fc15.i686 has missing requires of libboost_serialization-mt.so.1.46.0
1:kmod-nvidia-2.6.41.1-1.fc15.i686-280.13-2.fc15.9.i686 has missing requires of kernel-uname-r = ('0', '2.6.41.1', '1.fc15.i686')
1:kmod-nvidia-2.6.41.4-1.fc15.i686-280.13-4.fc15.i686 has missing requires of kernel-uname-r = ('0', '2.6.41.4', '1.fc15.i686')
1:kmod-nvidia-2.6.43.5-2.fc15.i686-280.13-4.fc15.5.i686 has missing requires of kernel-uname-r = ('0', '2.6.43.5', '2.fc15.i686')
libcompizconfig-0.9.5.92-1.fc15.i686 has missing requires of libboost_serialization-mt.so.1.46.0
libcompizconfig-0.9.5.92-1.fc15.i686 has missing requires of libprotobuf.so.6
Skip broken gets further, but then it comes up with a load of nonsense right at the end.

I'm having problems everytime I try to update after upgrading to 17.

Thanks in advance.
Reply With Quote
  #2  
Old 31st July 2012, 04:45 PM
glennzo Online
Un-Retired Administrator
 
Join Date: Mar 2004
Location: Salem, Mass USA
Age: 57
Posts: 14,697
windows_xp_2003firefox
Re: Yet another yum update problem

I wouldn't call it nonsense.

Information on how to deal with this type of error abounds in this forum.
__________________
Glenn
The Bassinator © ®

[SIGPIC][/SIGPIC]
Laptop: Toshiba Satellite / Intel Core 2 Duo 1.73 GHz / 2GB / 160GB / Intel Mobile 945GM/GMS/GME/943/940GML Integrated Graphics
Desktop: BioStar MCP6PB M2+ / AMD Phenom 9750 Quad Core / 4GB / 1TB SATA / 500GB SATA / EVGA GeForce 8400 GS 1GB
Reply With Quote
  #3  
Old 31st July 2012, 05:03 PM
ppyvabw Offline
Registered User
 
Join Date: Dec 2008
Posts: 36
linuxchrome
Re: Yet another yum update problem

It makes no sense to me - I'm not well versed in this stuff, and I do not know where to begin.

The result of
Code:
yum --skip-broken update -y
is

Code:
ERROR with transaction check vs depsolve:
kernel-uname-r = 2.6.41.1-1.fc15.i686 is needed by (installed) kmod-nvidia-2.6.41.1-1.fc15.i686-1:280.13-2.fc15.9.i686
kernel-uname-r = 2.6.41.4-1.fc15.i686 is needed by (installed) kmod-nvidia-2.6.41.4-1.fc15.i686-1:280.13-4.fc15.i686
kernel-uname-r = 2.6.43.5-2.fc15.i686 is needed by (installed) kmod-nvidia-2.6.43.5-2.fc15.i686-1:280.13-4.fc15.5.i686
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
** Found 8 pre-existing rpmdb problem(s), 'yum check' output follows:
compiz-0.9.5.92.1-0.1.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc15.i686 has missing requires of libboost_serialization-mt.so.1.46.0
compiz-gtk-0.9.5.92.1-0.1.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc15.i686 has missing requires of libboost_serialization-mt.so.1.46.0
compiz-plugins-main-0.9.5.92-1.fc15.i686 has missing requires of libboost_serialization-mt.so.1.46.0
1:kmod-nvidia-2.6.41.1-1.fc15.i686-280.13-2.fc15.9.i686 has missing requires of kernel-uname-r = ('0', '2.6.41.1', '1.fc15.i686')
1:kmod-nvidia-2.6.41.4-1.fc15.i686-280.13-4.fc15.i686 has missing requires of kernel-uname-r = ('0', '2.6.41.4', '1.fc15.i686')
1:kmod-nvidia-2.6.43.5-2.fc15.i686-280.13-4.fc15.5.i686 has missing requires of kernel-uname-r = ('0', '2.6.43.5', '2.fc15.i686')
libcompizconfig-0.9.5.92-1.fc15.i686 has missing requires of libboost_serialization-mt.so.1.46.0
libcompizconfig-0.9.5.92-1.fc15.i686 has missing requires of libprotobuf.so.6
Your transaction was saved, rerun it with:
 yum load-transaction /tmp/yum_save_tx.2012-07-31.16-06.If_nvh.yumtx
Reply With Quote
  #4  
Old 31st July 2012, 05:36 PM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,320
linuxfirefox
Re: Yet another yum update problem

From the looks of that output, you are running Fedora 17, yet the kmod packages it references are Fedora 15 packages.

It appears you have leftovers from doing an upgrade.

You can try doing a distrosync and see if that fixes your problems.

Code:
su -
(root password)

yum clean all
rm -f /var/lib/rpm/__*
rpm --rebuilddb
yum --releasever=17 --disableplugin=presto distro-sync
Edit:
If that doesn't fix your problems, then try manually removing those 8 packages listed above that are F15 versions.

(these packages)
Code:
** Found 8 pre-existing rpmdb problem(s), 'yum check' output follows:
compiz-0.9.5.92.1-0.1.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc15.i686 has missing requires of libboost_serialization-mt.so.1.46.0
compiz-gtk-0.9.5.92.1-0.1.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc15.i686 has missing requires of libboost_serialization-mt.so.1.46.0
compiz-plugins-main-0.9.5.92-1.fc15.i686 has missing requires of libboost_serialization-mt.so.1.46.0
1:kmod-nvidia-2.6.41.1-1.fc15.i686-280.13-2.fc15.9.i686 has missing requires of kernel-uname-r = ('0', '2.6.41.1', '1.fc15.i686')
1:kmod-nvidia-2.6.41.4-1.fc15.i686-280.13-4.fc15.i686 has missing requires of kernel-uname-r = ('0', '2.6.41.4', '1.fc15.i686')
1:kmod-nvidia-2.6.43.5-2.fc15.i686-280.13-4.fc15.5.i686 has missing requires of kernel-uname-r = ('0', '2.6.43.5', '2.fc15.i686')
libcompizconfig-0.9.5.92-1.fc15.i686 has missing requires of libboost_serialization-mt.so.1.46.0
libcompizconfig-0.9.5.92-1.fc15.i686 has missing requires of libprotobuf.so.6

Last edited by DBelton; 31st July 2012 at 05:38 PM.
Reply With Quote
  #5  
Old 1st August 2012, 01:16 AM
ppyvabw Offline
Registered User
 
Join Date: Dec 2008
Posts: 36
linuxchrome
Re: Yet another yum update problem

Hi DBelton.

Those commands just resulted in the exact same stream of indecipherable horse****.

Where are these packages to be found if I am going to delete them, and won't they need replacing by f17 versions?
Reply With Quote
  #6  
Old 1st August 2012, 01:43 AM
jlpierce Offline
Registered User
 
Join Date: Jul 2012
Location: Pekin, Indiana
Posts: 85
linuxopera
Re: Yet another yum update problem

Quote:
Originally Posted by ppyvabw View Post
Hi DBelton.

Those commands just resulted in the exact same stream of indecipherable horse****.

Where are these packages to be found if I am going to delete them, and won't they need replacing by f17 versions?
So why don't you post the output, rather than complain about it. If you are having so many issues you can always try a clean install, because as pointed out earlier there is obviously an issue from an upgrade.

Then again, with an attitude like the above you may just want to go enjoy that other OS.
Reply With Quote
  #7  
Old 1st August 2012, 04:02 AM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,320
linuxfirefox
Re: Yet another yum update problem

Well, there are no F17 replacements for compiz in the standard repos. Compiz doesn't work with gnome 3 shell.

And the kmod nvidia packages are for specific kernel versions, and since you no longer have those kernels installed, the kmod nvidia packages for those kernel versions isn't needed, and are preventing your updated F17 version of kmod from being able to update properly.

Code:
yum remove compiz-0.9.5.92.1-0.1.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc15.i686 compiz-gtk-0.9.5.92.1-0.1.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc15.i686 compiz-plugins-main-0.9.5.92-1.fc15.i686 libcompizconfig-0.9.5.92-1.fc15.i686 libcompizconfig-0.9.5.92-1.fc15.i686

yum remove kmod-nvidia-2.6.41.1-1.fc15.i686-280.13-2.fc15.9.i686 kmod-nvidia-2.6.41.4-1.fc15.i686-280.13-4.fc15.i686 kmod-nvidia-2.6.43.5-2.fc15.i686-280.13-4.fc15.5.i686
And it's not "indecipherable horse****". It's telling you exactly what the problem is.
Reply With Quote
  #8  
Old 1st August 2012, 03:30 PM
droidhacker Offline
Registered User
 
Join Date: Oct 2009
Posts: 827
linuxfirefox
Re: Yet another yum update problem

Quote:
Originally Posted by ppyvabw View Post
Where are these packages to be found if I am going to delete them,
On your computer where you are trying to run "yum update".
Quote:
and won't they need replacing by f17 versions?
No, otherwise the update would offer you the F17 versions instead of choking.
Reply With Quote
  #9  
Old 1st August 2012, 06:03 PM
ryptyde Offline
Registered User
 
Join Date: May 2005
Location: Tragic City, Michigan USA
Posts: 1,647
linuxfirefox
Re: Yet another yum update problem

The Fedora "upgrade" wiki says to run:
Quote:
package-cleanup --orphans
that will give you a list of your "problem childs".

What I have done after upgrading is to have "yumex" installed and then run it and select the unneeded packages for removal. Yumex will show available updates and you can pick and choose those you want to update or deselect those that are unneeded. Do a few at a time, although tedious be patient and it will work out in due time.

phil
Reply With Quote
Reply

Tags
problem, update, yum

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Update causes login problem, next update loses network icon billwww Using Fedora 2 11th June 2012 10:21 PM
software update problem after yum update polarwave Using Fedora 7 19th August 2010 08:36 AM
update problem arjunjain Using Fedora 10 3rd August 2009 07:22 PM
Amarok Update Problem from yum -y update Raafi Using Fedora 6 26th August 2005 11:23 PM
fc-3 update in yum problem fxd Using Fedora 10 3rd January 2005 02:52 PM


Current GMT-time: 11:18 (Monday, 01-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat