Fedora Linux Support Community & Resources Center
  #1  
Old 14th July 2012, 03:37 AM
xxskiterxx Offline
Registered User
 
Join Date: Jul 2012
Location: Brazil
Posts: 2
windows_7chrome
[SOLVED] No video after choosing fedora in grub.

Hello guys, today I got a sad problem: When I run fedora (liveCD), it works properly but then I install it (the installation process seems to be ok) and by the moment I choose fedora in grub, what I got is just a white-blinking screen that never ends.

So I tried to install many others DEs and distros: Fedora(KDE), Fedora(LXDE), Mint(Cinnamon), Kubuntu, Lubuntu, Mageia, OpenSuse and the same problem appears: everything works as LiveCD but not after installation on hard drive.

I don't know what is wrong, however, I'm using a ATi VGA (hd6670) and i've read that ATi graphic cards are often getting into trouble with linux.

What can I do?

Last edited by xxskiterxx; 15th July 2012 at 03:08 AM.
Reply With Quote
  #2  
Old 14th July 2012, 11:20 AM
bob Offline
Administrator (yeah, back again)
 
Join Date: Jul 2004
Location: Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
Age: 69
Posts: 22,137
linuxfirefox
Re: No video after choosing fedora in grub.

moved to Installation Help
__________________
Linux & Beer - That TOTALLY Computes!
Registered Linux User #362651


Don't use any of my solutions on working computers or near small children.
Reply With Quote
  #3  
Old 14th July 2012, 12:15 PM
smr54 Offline
Registered User
 
Join Date: Jan 2010
Posts: 5,513
linuxchrome
Re: No video after choosing fedora in grub.

A guess is that perhaps the liveCDs are all using VESA (the sort of lowest common denominator of video) but after install, they're having trouble with your video card. You can try editing the grub line and add vga=vesa to the end of it, and seeing if it will boot.

http://askubuntu.com/questions/19486...boot-parameter
Reply With Quote
  #4  
Old 15th July 2012, 03:08 AM
xxskiterxx Offline
Registered User
 
Join Date: Jul 2012
Location: Brazil
Posts: 2
linuxchrome
Re: No video after choosing fedora in grub.

@smr54! Thank you!!! By the time that worked I went bananas!

Complete procedure:

1° Edit /etc/default/grub and append vga=769 to the end of the line that starts with GRUB_CMDLINE_LINUX_DEFAULT.

2° Update GRUB2 by using command:
Code:
grub2-mkconfig -o /boot/grub2/grub.cfg
Reply With Quote
  #5  
Old 15th July 2012, 05:12 AM
smr54 Offline
Registered User
 
Join Date: Jan 2010
Posts: 5,513
linuxchrome
Re: No video after choosing fedora in grub.

Great, glad it worked.
Reply With Quote
Reply

Tags
choosing, error, fedora, grub, video

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 17 Hangs in grub - Wrong video driver tbrooke Installation, Upgrades and Live Media 4 11th June 2012 03:01 PM
not grub option for choosing the OS sanjiv Installation, Upgrades and Live Media 2 25th February 2009 02:00 PM
Fedora 9, installation issues with Grub and video driver Sporadic Crash Using Fedora 3 31st August 2008 10:22 PM
Choosing a video format and software JordanN Using Fedora 3 20th December 2005 02:20 AM
choosing a soundcard in fedora core 3 diamond Hardware & Laptops 8 11th January 2005 11:59 AM


Current GMT-time: 17:30 (Tuesday, 16-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat