Fedora Linux Support Community & Resources Center
  #1  
Old 3rd June 2012, 06:39 AM
KenJackson Offline
Registered User
 
Join Date: Aug 2008
Location: Maryland, USA
Posts: 94
linuxfirefox
Guest won't boot in KVM since host upgrade to F17

I installed NetBSD v5.1.2 in a new KVM (qemu-kvm) virtual machine a few days ago on my Fedora16 host. Last night I upgraded to Fedora17 and I haven't been able to run my NetBSD guest since. I can't even boot the CD. Both the host and guest are 64-bit. It gives this error:

Code:
warning: no /dev/console
panic: cnopen: no console device
fatal breakpoint trap in supervisor mode
trap type 1 code 0 rip ffffffff80527525 ...
...
db[0}>
It's kind of crazy that it says there's no console device, since it's scrolling text to a console desplay (either SDL or VNC).

The only other virtual machine I've tried works just fine (Arch Linux).

Is the upgrade a coincidence?
Did anyone else exerience problems?
Reply With Quote
  #2  
Old 3rd June 2012, 09:18 AM
george_toolan Offline
Registered User
 
Join Date: Dec 2006
Posts: 2,078
linuxfirefox
Re: Guest won't boot in KVM since host upgrade to F17

Does the device /dev/console exist? I hear Fedora 17 changed the directory structure. Try to start your KVM with strace -e open

Code:
man strace
Reply With Quote
  #3  
Old 3rd June 2012, 12:56 PM
weitjong Online
Registered User
 
Join Date: Oct 2006
Location: Singapore, 新加坡
Posts: 946
macossafari
Re: Guest won't boot in KVM since host upgrade to F17

I upgraded to F17 and all my qemu-kvm works just fine afterwards. I do not have netBSD though. Since you just upgraded yours, have you double check that your system has been upgraded properly? I would run 'yum check' first to see if all packages check out well.
__________________
YaoWT - Leave no window unbroken ♪ (^。^) 

Last edited by weitjong; 3rd June 2012 at 01:01 PM.
Reply With Quote
  #4  
Old 3rd June 2012, 01:13 PM
stevea Offline
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,917
linuxfirefox
Re: Guest won't boot in KVM since host upgrade to F17

I migrated my mail-server KVM and built a couple others since F17. No major problems. A little glitchiness wrt SELinux. I'm using libvirtd/virt-manager.

When you say ...
Quote:
It gives this error:
Does "It" refer to the kvm tool or to the guest ?
I *think* that trap & 'cnopen' message is from the BSD guest, but it's unclear.

Are you using libvirtd & virt-manager or are you rolling your own qemu-kvm command ?
Can you post the full command ?

I *suspect* you have configured the guest w/ no console device (maybe due to a kvm command parameter change).
Have you checked all the command parameters (there are a few changes to the command) ?

IMO running strace will be completely useless - waste of time.
The F17 changes to the executable and library layout has ZERO to do with this.
__________________
None are more hopelessly enslaved than those who falsely believe they are free.
Johann Wolfgang von Goethe

Last edited by stevea; 3rd June 2012 at 01:18 PM.
Reply With Quote
  #5  
Old 3rd June 2012, 01:14 PM
KenJackson Offline
Registered User
 
Join Date: Aug 2008
Location: Maryland, USA
Posts: 94
linuxfirefox
Re: Guest won't boot in KVM since host upgrade to F17

Quote:
Originally Posted by george_toolan View Post
Does the device /dev/console exist? I hear Fedora 17 changed the directory structure. Try to start your KVM with strace -e open
/dev/console does exist on the host.
stance does not exist on the host and I can't boot the guest to try it there.

stance? yum search stance doesn't return anything meaningful. What is that?
Reply With Quote
  #6  
Old 3rd June 2012, 01:26 PM
stevea Offline
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,917
linuxfirefox
Re: Guest won't boot in KVM since host upgrade to F17

FYI -
http://comments.gmane.org/gmane.os.netbsd.general/32288
This looks pretty similar. Since it was fixed in Centos 6.2, and presumably RHEL6.2 it should be trivial to get the fix into Fedora. Or maybe a similar problem was re-introduced in F17.

Please bugzilla it. I did a quick scan in bugzilla and did not see this problem reported yet.

Fedora bugs go here,
https://bugzilla.redhat.com/


===

FYI strace and ltrace are very powerful commands for debuging pre-compiled execuables - however they are nearly useless for debugging this guest kernel trap. Packages;
ltrace-0.6.0-2.fc16.x86_64
strace-4.7-1.fc16.x86_64
__________________
None are more hopelessly enslaved than those who falsely believe they are free.
Johann Wolfgang von Goethe

Last edited by stevea; 3rd June 2012 at 01:31 PM.
Reply With Quote
  #7  
Old 3rd June 2012, 01:27 PM
KenJackson Offline
Registered User
 
Join Date: Aug 2008
Location: Maryland, USA
Posts: 94
linuxfirefox
Re: Guest won't boot in KVM since host upgrade to F17

Quote:
Originally Posted by stevea View Post
Does "It" refer to the kvm tool or to the guest ?
I *think* that trap message is from the BSD guest, but it's unclear.

Are you using libvirtd & virt-manager or are you rolling your own qemu-kvm command ?

...
Can you post the full command ?

Have you checked all the command parameters (there are a few changes to the command) ?
"It" is the guest's console output during it's failed boot attempt.
I'm not using libvirt because I haven't figured it out yet
Here's what I execute:
Code:
qemu-kvm -boot c -hda '/vm/ken/NetBSD.qemu' \
         -cdrom '/vm/ken/iso/NetBSD-amd64cd-5.1.2.iso' \
         -vnc :7 -m 1G \
         -name NetBSD -net nic,name=coren,model=pcnet \
         -net tap,script=no,downscript=no,ifname=tap7 -usbdevice tablet &
Then I use vncviewer :7 to see the output, or I remove -vnc :7 for SDL.

It worked just fine before the host upgrade.

Are you saying kvm's command-line options changed? Oh oh. I'll check into that. Thanks.
Reply With Quote
  #8  
Old 9th June 2012, 01:29 AM
KenJackson Offline
Registered User
 
Join Date: Aug 2008
Location: Maryland, USA
Posts: 94
linuxfirefox
Re: Guest won't boot in KVM since host upgrade to F17

As I was filling in the bug report, I noticed I was still running an F16 kernel, even though I had upgraded to F17. I googled and found it was a common problem and fixed it, but it took until today to get the bug report in.

Bug ID 830261

As I explained in the bug report, you don't even need a virtual disk to observe the bug. This command is all you need for that:
Code:
qemu-kvm -boot c -cdrom amd64cd-5.1.2.iso &
Reply With Quote
Reply

Tags
boot, f17, guest, host, kvm, netbsd, upgrade

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
qemu-kvm F15 host and guest - guest screen problem gmangum Using Fedora 0 25th June 2011 05:39 PM
Guest Additions Fedora Guest/Windows Host pythagorean Guides & Solutions (No Questions) 0 17th October 2010 08:06 PM
Fedora 7 and fc6 fails to boot as a fully virtualized xen guest after upgrade romank EOL (End Of Life) Versions 0 2nd October 2007 02:33 PM
VMware XP host/FC3 guest; dual-boot; raw disk? justadog Installation, Upgrades and Live Media 2 16th May 2005 09:14 PM
VMWare Win Host with FC3 Guest? Quella Using Fedora 7 17th December 2004 09:46 AM


Current GMT-time: 01:26 (Saturday, 25-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Vellore Travel Photos on Instagram - Mirnyy Travel Photos - Carouge