Fedora Linux Support Community & Resources Center
  #1  
Old 6th May 2012, 02:59 PM
prolog Offline
Registered User
 
Join Date: May 2012
Location: Canada
Posts: 2
windows_7firefox
How to get "text mode" in virtual console in 16

Hi,

I just installed Fedora 16 on my desktop, after some years away from Linux (my last distro would've been Mandrake back in 2004 or so). While the graphical stuff is nice, a lot of the time I find myself in the virtual console (to play nethack, etc). When trying a virtual console, I noticed that the text was very small. I'm used to seeing a standard 80x25 display, and the text was ridiculously tiny. I had just installed NetBSD a few days before this, and got a standard console.

So I've tried a number of things. /etc/inittab helpfully informed me that I needed to re-link to multi-user, and reboot. Tried that, and I did get the console on reboot, but it was still in ridiculously-tiny-text mode. What do I need to do to get a sane 80x25 console so I can play nethack again?
Reply With Quote
  #2  
Old 6th May 2012, 03:44 PM
eaglelinux Offline
Registered User
 
Join Date: Jun 2011
Posts: 208
linuxchrome
Re: How to get "text mode" in virtual console in 16

Hello !

Take a look here, I think that's an solvation way: http://forums.fedoraforum.org/showthread.php?t=221898

Bye !
Reply With Quote
  #3  
Old 6th May 2012, 05:57 PM
RupertPupkin Offline
Registered User
 
Join Date: Nov 2006
Location: Detroit
Posts: 5,720
linuxfedorafirefox
Re: How to get "text mode" in virtual console in 16

I think the instructions in that thread are obsolete in F16 because of GRUB 2.

What you could do is edit /boot/grub2/grub.cfg (as root) and put in these settings somewhere after the function load_video {...} part but before the "set timeout..." line.
Code:
set gfxmode=640x480x8,640x480
load_video
insmod gfxterm
terminal_input gfxterm
terminal_output gfxterm
You'll have to reboot to see the changes.
__________________
OS: Fedora 20 x86_64 | Machine: HP Pavilion a6130n | CPU: AMD 64 X2 Dual-Core 5000+ 2.6GHz | RAM: 5GB PC5300 DDR2 | Disk: 400GB SATA | Video: ATI Radeon HD 4350 512MB | Sound: Realtek ALC888S | Ethernet: Realtek RTL8201N
Reply With Quote
  #4  
Old 6th May 2012, 07:22 PM
george_toolan Offline
Registered User
 
Join Date: Dec 2006
Posts: 2,078
linuxfirefox
Re: How to get "text mode" in virtual console in 16

If you use gnome-terminal just select View--> Zoom In a couple of times.

Does anybody know why the shortcut key (Ctrl and +/-) does not work with the +/- keys on the numeric keypad?
Reply With Quote
  #5  
Old 7th May 2012, 02:27 AM
prolog Offline
Registered User
 
Join Date: May 2012
Location: Canada
Posts: 2
macossafari
Re: How to get "text mode" in virtual console in 16

Quote:
Originally Posted by RupertPupkin View Post
I think the instructions in that thread are obsolete in F16 because of GRUB 2.

What you could do is edit /boot/grub2/grub.cfg (as root) and put in these settings somewhere after the function load_video {...} part but before the "set timeout..." line.
Code:
set gfxmode=640x480x8,640x480
load_video
insmod gfxterm
terminal_input gfxterm
terminal_output gfxterm
You'll have to reboot to see the changes.
Thanks for the advice, but unfortunately, the resolution was the same as before.
Reply With Quote
  #6  
Old 7th May 2012, 04:51 PM
RupertPupkin Offline
Registered User
 
Join Date: Nov 2006
Location: Detroit
Posts: 5,720
linuxfedorafirefox
Re: How to get "text mode" in virtual console in 16

You probably have something else controlling your framebuffer (I think plymouth is likely the culprit - I always disable it). One alternative is to add an fbset command to the /etc/rc.d/rc.local file, like this:
Code:
fbset -depth 8 640x480-60
See the fbset man page for more details. You could test that command in a console before rebooting to see if it works.
__________________
OS: Fedora 20 x86_64 | Machine: HP Pavilion a6130n | CPU: AMD 64 X2 Dual-Core 5000+ 2.6GHz | RAM: 5GB PC5300 DDR2 | Disk: 400GB SATA | Video: ATI Radeon HD 4350 512MB | Sound: Realtek ALC888S | Ethernet: Realtek RTL8201N
Reply With Quote
  #7  
Old 9th May 2012, 03:58 AM
nsnbm Offline
Registered User
 
Join Date: Dec 2007
Location: Australia
Posts: 447
linuxfirefox
Re: How to get "text mode" in virtual console in 16

Hello prolog,

To get the standard 80x25 on the console I added:

nomodeset

to the kernel line. I had to edit, as root, /etc/default/grub and then run, as root:
Code:
grub2-mkconfig -o /boot/grub/grub.cfg
to get the new kernel line in /boot/grub/grub.cfg. I also have deleted quiet and rhgb from the kernel line.
On reboot, I get the standard 80x25 fonts on the console. I also don't run gnome. Ben.

Last edited by nsnbm; 9th May 2012 at 04:09 AM. Reason: more information
Reply With Quote
Reply

Tags
console, text mode, virtual

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
"graphics" characters in text mode kosie Using Fedora 0 28th July 2008 06:42 PM
Wrong display for the "text console" (F7 as VPC guest) SaGS Using Fedora 3 27th April 2008 07:38 PM
During First Boot, PC monitor shows blank screen & ""CANNOT DISPLAY THIS VIDEO MODE" im2saxy Installation, Upgrades and Live Media 5 6th May 2007 10:17 AM
"Edit" in text mode? Aussie Using Fedora 5 8th October 2005 10:32 AM
Error:visibility arg must be one of "default", "hidden", "protected" or "internal" wangfeng Using Fedora 0 23rd May 2005 05:59 AM


Current GMT-time: 05:33 (Thursday, 27-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Paseig Del Born Travel Photos on Instagram - Ocean Hotel Guangzhou Instagram Photos - Element Fresh Travel Photos