Fedora Linux Support Community & Resources Center
  #1  
Old 26th March 2012, 10:17 AM
hallh Offline
Registered User
 
Join Date: Mar 2012
Location: Brooklyn, NY
Posts: 5
linuxfirefox
Exclamation Idle - File "/usr/local/lexmark/lxk08/bin/printdriver" has insecure permissions (0100

I'm trying to print a document on my Lexmark x2670, but I'm denied. I own the computer and printer connected to it, and I installed the printer driver from the Lexmark website. When I attempt to print a test page, I get:

Idle - File "/usr/local/lexmark/lxk08/bin/printdriver" has insecure permissions (0100775/uid=0/gid=1).

If I am the administrator of my computer, why can't I get permission to print a simple document?

I'd appreciate a rapid reply to this message.

Thanx!
Reply With Quote
  #2  
Old 26th March 2012, 10:46 AM
jpollard Online
Registered User
 
Join Date: Aug 2009
Location: Waldorf, Maryland
Posts: 6,860
linuxfirefox
Re: Idle - File "/usr/local/lexmark/lxk08/bin/printdriver" has insecure permissions (

It is not that that you don't have permission to print, but that the program/script being used to print is not secured.

Very likely it is the file /usr/local/lexmark/lxk08/bin/printdriver.

If this is the driver it is allowing non-root write to the file (gid 1 can write).

Try making the file 755 instead (rwxr-xr-x).
Reply With Quote
  #3  
Old 26th March 2012, 02:45 PM
hallh Offline
Registered User
 
Join Date: Mar 2012
Location: Brooklyn, NY
Posts: 5
linuxfirefox
Exclamation Re: Idle - File "/usr/local/lexmark/lxk08/bin/printdriver" has insecure permissions (

Thanx for your reply! However, I'm unable to edit the file permissions. I get a message stating I do not have permission to make changes and I can't log in as 'root'.

Would you know how I can access the file so that I can make a appropriate changes?
Reply With Quote
  #4  
Old 26th March 2012, 02:57 PM
jpollard Online
Registered User
 
Join Date: Aug 2009
Location: Waldorf, Maryland
Posts: 6,860
linuxfirefox
Re: Idle - File "/usr/local/lexmark/lxk08/bin/printdriver" has insecure permissions (

You have to su to root in a terminal window.
Reply With Quote
  #5  
Old 26th March 2012, 03:14 PM
AlanSac Offline
Registered User
 
Join Date: Mar 2012
Location: Sacramento CA
Posts: 26
linuxfedorafirefox
Re: Idle - File "/usr/local/lexmark/lxk08/bin/printdriver" has insecure permissions (

Another tool to do this is beesu, a nice gui manager for a lot of command line utilities. Using package manager, check all three beesu entries. After installation, click on it in the activities menu, and choose all the ones you want - you can edit, change permissions, change ownership, create, delete, etc. To use it, highlight the file/folder you want, right click and select scripts, then select the beesu script you want. It's easy to use! The actual reference is: http://honeybeenet.altervista.org/beesu/
Reply With Quote
  #6  
Old 26th March 2012, 04:11 PM
hallh Offline
Registered User
 
Join Date: Mar 2012
Location: Brooklyn, NY
Posts: 5
linuxfirefox
Exclamation Re: Idle - File "/usr/local/lexmark/lxk08/bin/printdriver" has insecure permissions (

Thanx for all the help!

But even after changing the permissions, I'm still getting the SAME error message. Is there another step I need to follow?
Reply With Quote
Reply

Tags
0100, file, idle, insecure, permissions

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
unpredictable "delete" "move to trash" or "cut" file menu option dorianrenato Using Fedora 1 21st November 2011 03:09 AM
Fedora 10 fails to boot after "Enabling local filesystem quotas" nharvey Alpha, Beta & Snapshots Discussions (Fedora 10 Only) 1 11th November 2008 04:24 PM
"ls" and "cd" treat ".." differently inside symlinked directories bnorman Using Fedora 0 19th June 2008 04:49 PM
HOW TO MOUNT "C" "D" "E" LOCAL HARDDISK PARTITION ketan_hk Using Fedora 6 6th September 2007 01:10 AM
Error:visibility arg must be one of "default", "hidden", "protected" or "internal" wangfeng Using Fedora 0 23rd May 2005 04:59 AM


Current GMT-time: 18:20 (Wednesday, 01-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat