Fedora Linux Support Community & Resources Center
  #1  
Old 23rd November 2004, 03:52 PM
FedSte69 Offline
Registered User
 
Join Date: Nov 2004
Posts: 2
FC3 and ATI fglrx-4.3.0-3.14.6 works - but ONLY FOR ROOT

I have a HP Compaq NC8000 Notebook with a ATI Radeon Mobility 9600, I could successfully install
FC3 and also the fglrx Driver (3.14.6). The installation works as follows (assuming kernel
2.6.9-1.681_FC3 from the FC3 update).

1. Install Linux Kernel sources:
# rpm -ivh kernel-2.6.9-1.681_FC3.src.rpm
# cd /usr/src/
# tar xvfjp /usr/src/redhat/SOURCES/linux-2.6.9.tar.bz2
# ln -s linux-2.6.9 linux-2.6

2. Install fglrx RPM:
# rpm --replacefiles -ivh fglrx-4.3.0-3.14.6.i386.rpm
(ignore errors)

3. Fix /lib/modules/fglrx/build_mod/2.6.x/Makefile:
Replace the line
-Idrivers/char/drm/ \
by
-I/usr/src/linux-2.6.9/drivers/char/drm \

4. Build and install fglrx.ko:
# cd /lib/modules/fglrx/build_mod/2.6.x
# make
# cp fglrx.ko /lib/modules/2.6.9-1.681_FC3/kernel/drivers/char/drm
# depmod -ae

5. Run fglrxconfig and create a symlink in /etc/X11:
# cd /etc/X11
# ln -s XF86Config-4 xorg.conf



Works nicely for root, but, oddly enough, not for normal users. When I try to login as a non-root user,
the screen freezes for a moment when trying to initialize Gnome. Immediately after that I get logged off.
/var/log/gdm/:0.log contains messages of that sort:

No matching visual for __GLcontextMode with visual class = -1 (-1), nplanes = 0

With KDE everything works nicely. Root can also login without any problems, as mentioned above.

Sounds like a access permission problem. Any ideas?

Thanks
Stefan
Reply With Quote
  #2  
Old 27th November 2004, 04:09 PM
telmo Offline
Registered User
 
Join Date: Nov 2004
Location: Braga -Portugal
Age: 38
Posts: 107
When you say it works, do you mean with 3D acceleration?
Have you tried it with gnome?

I have a graphic card just like yours and i would PAY to get it to work fully!!!
Reply With Quote
  #3  
Old 30th November 2004, 01:09 AM
FIrehawk Offline
Registered User
 
Join Date: Jun 2004
Posts: 4
You know, I too noticed that root would get into Gnome just fine, but my other user accounts crash randomly after a couple seconds. Maybe a little later I will switch over to that driver again and see about 3D. If I remember right, I might have tried it and gotten a crash...
Reply With Quote
  #4  
Old 3rd December 2004, 07:42 AM
royoni Offline
Registered User
 
Join Date: Jul 2004
Location: HK
Posts: 16
Thumbs up It also works for me, thx but shutdown failed...

Quote:
Originally Posted by FedSte69
I have a HP Compaq NC8000 Notebook with a ATI Radeon Mobility 9600, I could successfully install
FC3 and also the fglrx Driver (3.14.6). The installation works as follows (assuming kernel
2.6.9-1.681_FC3 from the FC3 update).

1. Install Linux Kernel sources:
# rpm -ivh kernel-2.6.9-1.681_FC3.src.rpm
# cd /usr/src/
# tar xvfjp /usr/src/redhat/SOURCES/linux-2.6.9.tar.bz2
# ln -s linux-2.6.9 linux-2.6

2. Install fglrx RPM:
# rpm --replacefiles -ivh fglrx-4.3.0-3.14.6.i386.rpm
(ignore errors)

3. Fix /lib/modules/fglrx/build_mod/2.6.x/Makefile:
Replace the line
-Idrivers/char/drm/ \
by
-I/usr/src/linux-2.6.9/drivers/char/drm \

4. Build and install fglrx.ko:
# cd /lib/modules/fglrx/build_mod/2.6.x
# make
# cp fglrx.ko /lib/modules/2.6.9-1.681_FC3/kernel/drivers/char/drm
# depmod -ae

5. Run fglrxconfig and create a symlink in /etc/X11:
# cd /etc/X11
# ln -s XF86Config-4 xorg.conf



Works nicely for root, but, oddly enough, not for normal users. When I try to login as a non-root user,
the screen freezes for a moment when trying to initialize Gnome. Immediately after that I get logged off.
/var/log/gdm/:0.log contains messages of that sort:

No matching visual for __GLcontextMode with visual class = -1 (-1), nplanes = 0

With KDE everything works nicely. Root can also login without any problems, as mentioned above.

Sounds like a access permission problem. Any ideas?

Thanks
Stefan
It also works for me on FC2 with kernel 2.6.9-1.6_FC2 and I can boot into X with 3D support but the problem is that when I try to shut down form X then some Black/White stripe appear on the screen and it freeze and fail to shut off?
I am running on a IBM T42 with M9600, can you advice me how to fix this?
Thank you!
Reply With Quote
  #5  
Old 3rd December 2004, 03:06 PM
dan gaffney Offline
Registered User
 
Join Date: Nov 2004
Posts: 3
FedSte69,

have you set access to OpenGL ICD to all users (it pops up in the Q & A with fglrx_config) ? I had the same problem because I accidentally set Access to OpenGL ICD to root only. Have a look at the Section "dri" in your XF86config file. Mode should be set to 0666. If not rerun flgrxconfig and answer the question :
"Please specify which restriction sheme you want to implement:"
with the default [1] ,
"1. no restrictions - any user has access to the OpenGL ICD"
Sorry if you tried this already,
D
Reply With Quote
  #6  
Old 6th December 2004, 01:07 PM
FedSte69 Offline
Registered User
 
Join Date: Nov 2004
Posts: 2
Was too optimistic - doesn't work for root, either

Hi guys,

thanks for your posts. I was a bit too optimistic - it doesn't work for root, either. I can
start the GNOME desktop, which works nicely (this doesn't work for non-root users), but if
I try to run e.g. glxgears the X session gets killed and I get logged out.

Please find attached a tar.gz file which contains my xorg.conf, /var/log/Xorg.0.log and /var/log/gdm/:0.log.

Seems to be an GL access rights problem though the OpenGL settings in xorg.conf are correct
as far as I can see.

Any ideas?

Thanks
Stefan
Attached Files
File Type: gz xorg.tar.gz (12.4 KB, 203 views)
Reply With Quote
  #7  
Old 8th December 2004, 04:41 PM
royoni Offline
Registered User
 
Join Date: Jul 2004
Location: HK
Posts: 16
Talking

Quote:
Originally Posted by FedSte69
Hi guys,

thanks for your posts. I was a bit too optimistic - it doesn't work for root, either. I can
start the GNOME desktop, which works nicely (this doesn't work for non-root users), but if
I try to run e.g. glxgears the X session gets killed and I get logged out.

Please find attached a tar.gz file which contains my xorg.conf, /var/log/Xorg.0.log and /var/log/gdm/:0.log.

Seems to be an GL access rights problem though the OpenGL settings in xorg.conf are correct
as far as I can see.

Any ideas?

Thanks
Stefan
Hi, have you tried the following link?
http://www.stanford.edu/~fenn/linux/radeon.shtml
Reply With Quote
Reply

Tags
ati, fc3, fglrx, root, works

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Suspend only works when the fglrx.so kernel module is not loaded. PashaP Hardware & Laptops 20 3rd November 2007 11:48 PM
[F7]fglrx FINALLY works, but screen turns off TdZ Hardware & Laptops 9 29th June 2007 10:39 PM
xgl/fglrx works...but not quite david101 Using Fedora 3 24th December 2006 01:37 AM
ATI fglrx driver for XPRESS 200M on zv6000 almost works gracedman Hardware & Laptops 28 27th January 2006 04:18 PM
fglrx-4.3.0-3.11.1 and kernel-2.6.8 works fine to me! wilstar Hardware & Laptops 2 22nd August 2004 08:04 PM


Current GMT-time: 00:06 (Saturday, 29-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
MEO Arena - Madame Tussauds-Shanghai Instagram Photos