Fedora Linux Support Community & Resources Center
  #1  
Old 2nd March 2012, 09:11 PM
chrismurphy Offline
Registered User
 
Join Date: May 2010
Posts: 970
macoschrome
systemd segfault after yum update

1.
Obliterated GPT and MBR and zero'd first 1M of /dev/sda

2.
Installed "Use All Space" installation type with defaults, from LiveCD.i686.

3.
yum update

4.
reboot

Result:
Code:
[   68.662358] systemd[1]: segfault at 0 ip   (null) sp bfa4d87c error 4 in libnsl-2.15.so[110000+17000]


---------- Post added at 02:03 PM ---------- Previous post was at 02:02 PM ----------

Any suggestions? Is this sort of thing preferably posted to devel@lists.fedoraproject.org?

---------- Post added at 02:11 PM ---------- Previous post was at 02:03 PM ----------

OK it seems to be a one off event so far.
Reply With Quote
  #2  
Old 2nd March 2012, 10:54 PM
AdamW Offline
Fedora QA Community Monkey
 
Join Date: Dec 2008
Location: Vancouver, BC
Posts: 4,176
linuxfirefox
Re: systemd segfault after yum update

it's ideally filed as a bug, but really only if you have a good backtrace or at least a reproducer :/
__________________
Adam Williamson | awilliam AT redhat DOT com
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
http://www.happyassassin.net
Reply With Quote
  #3  
Old 2nd March 2012, 11:33 PM
chrismurphy Offline
Registered User
 
Join Date: May 2010
Posts: 970
macoschrome
Re: systemd segfault after yum update

It's not reproducing, so it seems this deterministic contraption is a bit variable.
Reply With Quote
  #4  
Old 5th March 2012, 09:38 PM
AdamW Offline
Fedora QA Community Monkey
 
Join Date: Dec 2008
Location: Vancouver, BC
Posts: 4,176
linuxfirefox
Re: systemd segfault after yum update

chrismurphy: check the pixie dust levels.
__________________
Adam Williamson | awilliam AT redhat DOT com
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
http://www.happyassassin.net
Reply With Quote
  #5  
Old 5th March 2012, 09:40 PM
chrismurphy Offline
Registered User
 
Join Date: May 2010
Posts: 970
macoschrome
Re: systemd segfault after yum update

The computer in question has rebooted multiple times, and the problem has not materialized. Seems like it may have been a one time systemd related puke, and it now feels better. Marking as solved.
Reply With Quote
Reply

Tags
segfault, systemd, update, yum

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
A Journal Comes To systemd tox Linux Chat 0 19th November 2011 03:25 AM
systemd is broken? andrewthomas F16 Development 3 25th March 2011 06:43 PM
systemd? ssidhar F14 Development 5 29th September 2010 07:11 PM
Systemd came in - here's how to boot again. :) GoinEasy9 F16 Development 15 1st August 2010 04:44 PM
sshd segfault after yum update dave_t Using Fedora 9 17th March 2006 08:01 PM


Current GMT-time: 17:45 (Thursday, 18-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat