Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Using Fedora
FedoraForum Search

Forgot Password? Join Us!

Using Fedora General support for current versions. Ask questions about Fedora and it's software that do not belong in any other forum.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 28th February 2012, 10:55 PM
firewired Offline
Registered User
 
Join Date: Feb 2012
Location: Edinburgh
Posts: 5
linuxchrome
Adobe Flash no longer works under chrome and firefox

Hi,
I am unable to load flash videos in neither google-chrome nor firefox. The problem started shortly after upgrading from f15 to f16. Running Fedora 16 32bit, 3.2.7-1 kernel, nvidia kmod 290.10-1.

from Firefox about:plugins :

Shockwave Flash

File: nswrapper_32_32.libflashplayer.so
Version: Shockwave Flash 11.1 r102

chrome:plugins

Flash (2 files) - Version: 11.1 r102
Shockwave Flash 11.1 r102
Location: /opt/google/chrome/libgcflashplayer.so
Type: NPAPI

Name: Shockwave Flash
Version: 11.1 r102
Location: /usr/lib/flash-plugin/libflashplayer.so

(neither works)

running firefox and loading any youtube vid:

*** NSPlugin Wrapper *** ERROR: NPP_SetWindow() wait for reply: Connection closed
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0x9de2f630 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0x9de2f630 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0x9de2f630 is no longer valid!
....
*** NSPlugin Wrapper *** WARNING:(../src/npw-wrapper.c:2478):invoke_NPP_NewStream: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0x9de2f630 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0x9de2f630 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject proxy 0x9de2f630 is no longer valid!
...

I am new to linux and have no clue how to proceed so any help would be much appreciated.
Reply With Quote
  #2  
Old 28th February 2012, 11:00 PM
jpollard Online
Registered User
 
Join Date: Aug 2009
Location: Waldorf, Maryland
Posts: 6,771
linuxfirefox
Re: Adobe Flash no longer works under chrome and firefox

How did you install flash?

None of the locations you show are where it should be.

Mine is /usr/lib64/mozilla/plugins/libflashplayer.so (and yes, I'm running a 64 bit system). I would think yours should be /usr/lib/mozilla/plugins/libflashplayer.so.

forgot to say: I installed via the autoplus utility for codecs and other nice-to-have things.
Reply With Quote
  #3  
Old 28th February 2012, 11:15 PM
PabloTwo Offline
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 6,054
linuxchrome
Re: Adobe Flash no longer works under chrome and firefox

Why are you using nspluginwrapper? You don't need that to run a 32 bit plugin for a 32 bit app in a 32 bit OS.

Whatever you did to install the /opt/google/chrome/libgcflashplayer.so plugin, undo it. You have two competing flashplayer plugins in google-chrome.

Location: /usr/lib/flash-plugin/libflashplayer.so <== this is the correct location. /usr/lib/mozilla/plugins/libflashplayer.so is a symlink to the real binary reported.

Last edited by PabloTwo; 28th February 2012 at 11:25 PM.
Reply With Quote
  #4  
Old 28th February 2012, 11:17 PM
firewired Offline
Registered User
 
Join Date: Feb 2012
Location: Edinburgh
Posts: 5
linuxfirefox
Re: Adobe Flash no longer works under chrome and firefox

Quote:
Originally Posted by jpollard View Post
How did you install flash?

None of the locations you show are where it should be.

Mine is /usr/lib64/mozilla/plugins/libflashplayer.so (and yes, I'm running a 64 bit system). I would think yours should be /usr/lib/mozilla/plugins/libflashplayer.so.

forgot to say: I installed via the autoplus utility for codecs and other nice-to-have things.
I used the adobe repository:

rpm -ivh http://linuxdownload.adobe.com/adobe...0-1.noarch.rpm
rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-adobe-linux

yum install flash-plugin nspluginwrapper

Quote:
Originally Posted by PabloTwo View Post
Why are you using ndiswrapper? You don't need that to run a 32 bit plugin for a 32 bit app in a 32 bit OS.

Whatever you did to install the /opt/google/chrome/libgcflashplayer.so plugin, undo it. You have two competing flashplayer plugins in google-chrome.

Location: /usr/lib/flash-plugin/libflashplayer.so <== this is the correct location. /usr/lib/mozilla/plugins/libflashplayer.so is a symlink to the real binary reported.
I never installed the extra flush plugin in chrome. It must have been there by default. Disabling either one of the two doesn't help. Removing the chrome one gives upon loading a page with flash:

google-chrome
[32154:32154:46125136561:ERROR:x11_util.cc(951)] X Error detected: serial 3971, error_code 10 (BadAccess (attempt to access private resource denied)), request_code 142, minor_code 1 (X_ShmAttach)
[32154:32154:46125141654:ERROR:x11_util.cc(951)] X Error detected: serial 3972, error_code 159 (BadShmSeg (invalid shared segment parameter)), request_code 142, minor_code 3 (X_ShmPutImage)
[32154:32154:46125143925:ERROR:x11_util.cc(951)] X Error detected: serial 3986, error_code 159 (BadShmSeg (invalid shared segment parameter)), request_code 142, minor_code 2 (X_ShmDetach)

As to the nspluginwrapper I don't know why it is there. I just followed instructions online, having no idea what I was doing. It did work without problems for months though. Also I tried reversing the process some time ago and just installing the flash-plugin package and it broke flush in both browsers as well (reinstalliing the nspluginwrapper then re-enabled flash playback).

Last edited by firewired; 28th February 2012 at 11:39 PM.
Reply With Quote
  #5  
Old 29th February 2012, 08:50 PM
firewired Offline
Registered User
 
Join Date: Feb 2012
Location: Edinburgh
Posts: 5
windows_7chrome
Re: Adobe Flash no longer works under chrome and firefox

So I am assuming nobody has ever encountered a problem like that (Flash spontaneously stopping to work)? Can I at least get some guesses as to what might resolve this problem? I tried reinstalling flash and both browsers without any effect. If this was windows I would reinstall the system now but on linux I am lost.
Reply With Quote
  #6  
Old 29th February 2012, 09:16 PM
dd_wizard Offline
Registered User
 
Join Date: Sep 2009
Posts: 1,409
linuxfirefox
Re: Adobe Flash no longer works under chrome and firefox

Check out Comment 44 onward in this thread.

dd_wizard
Reply With Quote
  #7  
Old 1st March 2012, 12:19 AM
firewired Offline
Registered User
 
Join Date: Feb 2012
Location: Edinburgh
Posts: 5
linuxfirefox
Re: Adobe Flash no longer works under chrome and firefox

Quite frankly I don't see how this is relevant. In my case the version of adobe plugin downloaded by yum update and by chrome auto-update functionality was exactly the same. Also I tried all combinations of disabling/removing either plugin and it didn't help in the slightest. Anyway I don't understand why everyone is obsessing about chrome when the problem occurs in both browsers.

I tried removing adobe flash and installing gnash-plugin but I doesn't seem to work for me. The fedora project page has a flash installation guide which recommends installing nspluginwrapper to run adobe flash in both 32-bit and 64-bit browsers. There is also this: http://fedoraproject.org/wiki/Flash#...e.2Fpreupgrade but it seems to be only relevant where updating 64-bit system (at least I don't have the plugins-wrapped directory anywhere).

Any chance rolling back to a previous graphic driver might help? I understand nobody here is very keen on helping to troubleshot issue with a proprietary plugin crashing under a proprietary driver but cmon - help a noob out.
Reply With Quote
  #8  
Old 1st March 2012, 12:34 AM
dd_wizard Offline
Registered User
 
Join Date: Sep 2009
Posts: 1,409
linuxfirefox
Re: Adobe Flash no longer works under chrome and firefox

I installed 64 bit flash from adobe, and it's been working fine. I did do a clean install of F16, but I did yum updates for F12 > F13 > F14 > F15 and never broke flash before. You might try erasing nspluginwrapper and see if that helps.

dd_wizard

Last edited by dd_wizard; 1st March 2012 at 12:40 AM.
Reply With Quote
  #9  
Old 1st March 2012, 12:49 AM
firewired Offline
Registered User
 
Join Date: Feb 2012
Location: Edinburgh
Posts: 5
linuxfirefox
Re: Adobe Flash no longer works under chrome and firefox

I tried before, when flash was still working for me, because my computer was struggling with high-definition playback under the open nvidia driver. Never got the adobe plugin to run standalone. Certainly doesn't work now. Is it normal that gnash doesn't work either? Under firefox I just get an empty placeholder where the movie should be, under konqueror:

konqueror(6051) KConfigGroup::readXdgListEntry: List entry mime in "/usr/share/kde4/apps/klash/pluginsinfo" is not compliant with XDG standard (missing trailing semicolon).
Could not load movie '/tmp/kde-rkg/konquerorAF6051.swf'
Error: Could not load movie!

This situation is ridiculously annoying because without flash loading I cannot also download the flv files to disk and watch in a standalone player. I am running a second laptop right now with windows booted just for watching youtube vids and screencasts online...

Last edited by firewired; 1st March 2012 at 01:13 AM.
Reply With Quote
Reply

Tags
adobe, chrome, firefox, flash, longer, works

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Recent F13 update of Flash and Chrome. Chrome don't work and Firefox freezes JohnRock EOL (End Of Life) Versions 1 10th October 2011 06:23 PM
Installing Adobe Flash on Google Chrome Crockeo Using Fedora 2 20th September 2011 11:28 PM
Flash issue with Firefox but not with Chrome mac4rfree Using Fedora 1 15th September 2011 02:58 PM
adobe flash player + google chrome mandalay Using Fedora 6 30th May 2011 11:10 AM
Firefox and Adobe Flash site don't agree on Flash version schwim Using Fedora 11 6th February 2007 03:02 AM


Current GMT-time: 15:44 (Wednesday, 23-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat