Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Servers & Networking
FedoraForum Search

Forgot Password? Join Us!

Servers & Networking Discuss any Fedora server problems and Networking issues such as dhcp, IP numbers, wlan, modems, etc.

Reply
 
Thread Tools Search this Thread Display Modes
  #16  
Old 24th February 2012, 03:07 AM
heigold1 Offline
Registered User
 
Join Date: Feb 2012
Location: Los Angeles
Posts: 40
windows_vistaie
Re: Accessing apache server remotely from another machine (newbie).

JPollard, yes when I do the "ifconfig -a" then i get "192.168.0.255" for the "wlan0" entry.

So that's probably what it is then?
Reply With Quote
  #17  
Old 24th February 2012, 11:15 AM
Jake Jast Offline
Registered User
 
Join Date: Jul 2010
Posts: 49
linuxfedorafirefox
Re: Accessing apache server remotely from another machine (newbie).

Do you know how a router works? Every computer connected to it (both with cable, both with wireless) has a private ip address that must be 192.168.1.x where "x" is a number >1 <255 . The address 192.168.1.1 is the one of the router. If you type this ip(192.168.1.1) on your browser will appears the router's configuration page. If you want to see what is your private ip, you have to run "ifconfig -a". This command display all your internet connections. The output must be a thing like that:
Code:
eth0      Link encap:Ethernet  HWaddr 00:25:22:B9:72:88  
          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::225:22ff:feb9:7288/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6212 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5834 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3947652 (3.7 MiB)  TX bytes:1026119 (1002.0 KiB)
          Interrupt:44 Base address:0xc000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:960 (960.0 b)  TX bytes:960 (960.0 b)

wlan0     Link encap:Ethernet  HWaddr 00:26:5A:6D:43:92  
         inet addr: 192.168.1.194  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::226:5aff:fe6d:4392/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:79 errors:0 dropped:0 overruns:0 frame:0
          TX packets:77 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:8383 (8.1 KiB)  TX bytes:17689 (17.2 KiB)
Do you see where is red and bold? This is my wireless private ip. If you connect to your private ip you will see the same if you go to "127.0.0.1".

Now, I think that JPollard wanted to say you that you must do a "port mapping". This lets the router to redirect anyone that connects to your public ip(the one that you see at "whatismyipaddress.com") at the private address(192.168.1.x) of your pc.

Well, I can't explain you how do a port mapping because surely you haven't my same router. But I can say that you must tell to your router(from 192.168.1.1) that if someone connects to your public ip with the 80/tcp port(the one of apache and all other http servers in this world; anyone that connect to an http server use this port), it must redirect the request to your pc private address. For do that see the manual of your router.

Last edited by Jake Jast; 24th February 2012 at 12:24 PM.
Reply With Quote
  #18  
Old 25th February 2012, 01:15 AM
heigold1 Offline
Registered User
 
Join Date: Feb 2012
Location: Los Angeles
Posts: 40
windows_vistaie
Re: Accessing apache server remotely from another machine (newbie).

Jake, when I go to http://192.168.1.1 i just a gateway timeout.

Any suggestions?

Also kttam how do you stop iptables and disable selinux?
Reply With Quote
  #19  
Old 25th February 2012, 03:30 PM
Jake Jast Offline
Registered User
 
Join Date: Jul 2010
Posts: 49
windows_7firefox
Re: Accessing apache server remotely from another machine (newbie).

oh, well your private ip is 192.168.0.255 so you can try 192.168.0.1 or at least 192.168.0.0
This depends by your router subnet mask
Reply With Quote
Reply

Tags
accessing, apache, machine, newbie, remotely, server

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Accessing apache server remotely from another machine (newbie). heigold1 Servers & Networking 1 23rd February 2012 09:02 AM
Trouble accessing VNC Server remotely. chrisn8cuh Using Fedora 2 22nd August 2008 03:51 AM
Printing, and Accessing X remotely vkapila Using Fedora 6 4th March 2005 02:59 AM
Accessing FC2 server from XP machine Duke Henry Servers & Networking 10 25th July 2004 09:46 AM


Current GMT-time: 21:57 (Thursday, 23-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Charkhi Dadri Photos on Instagram - Zoetermeer Travel Photos on Instagram - Achkhoy-Martan Photos