Fedora Linux Support Community & Resources Center
  #1  
Old 15th February 2012, 01:12 PM
tuxalka Offline
Registered User
 
Join Date: Jun 2009
Posts: 10
linuxopera
trouble to connect via ssh

Hi, I have notebook and desktop in small home network. Fedora 16 rans on both of them, I followed the documentation guidelines of F16 to establish ssh connection between them. And when I try to connect from notebook to PC it reports: no route to host. I can ping both of them. I saw ssh is enabled in firewall -just in graphical user enviroment. Both notebook and PC have ip address from my router dhcp. Any advice? I changed permission on .ssh directory 775 and th authorized_keys file on 644. Please help.
Reply With Quote
  #2  
Old 15th February 2012, 01:21 PM
glennzo Online
Un-Retired Administrator
 
Join Date: Mar 2004
Location: Salem, Mass USA
Posts: 14,543
windows_xp_2003firefox
Re: trouble to connect via ssh

tuxalka, I've closed your other thread as a duplicate of this one.

http://forums.fedoraforum.org/showthread.php?t=276461

Please read the Posting Rules before posting again.
__________________
Glenn
The Bassinator © ®

[SIGPIC][/SIGPIC]
Laptop: Toshiba Satellite / Intel Core 2 Duo 1.73 GHz / 2GB / 160GB / Intel Mobile 945GM/GMS/GME/943/940GML Integrated Graphics
Desktop: BioStar MCP6PB M2+ / AMD Phenom 9750 Quad Core / 4GB / 1TB SATA / 500GB SATA / EVGA GeForce 8400 GS 1GB
Reply With Quote
  #3  
Old 15th February 2012, 02:08 PM
coffee412 Offline
Registered User
 
Join Date: Aug 2005
Location: Ask the Government.
Posts: 423
linuxfirefox
Re: trouble to connect via ssh

A great tool for investigating connection problems is probably nmap. This will show what ports are open on a computer on your network.

yum -y install nmap

Then do a "nmap <ipaddress of computer your trying to connect too>"

Also, See if you can ping the other computer.

Thats all a start to fixing your problem. If you cannot ping or discover the open ports with nmap then it very well could be a firewall problem.
__________________
Fedora20 AMD X6 1090T - 8GIG RAM - Nvidia GTX-650 - LXDE. Linux since 1995 - No Gnomes allowed.
Mythbuntu - Mythtv .27 - AMD 6core- 8 gigs ram Nvidia GTX-650 Ceton 4 port tunner
Lenovo laptop - Linux Mint 15 Xfce DE *Get your linux on*

Reply With Quote
  #4  
Old 16th February 2012, 05:25 PM
tuxalka Offline
Registered User
 
Join Date: Jun 2009
Posts: 10
linuxopera
Re: trouble to connect via ssh

Hi,
I tried the nmap and ping.
The nmap reported:
Starting Nmap 5.51 ( http://nmap.org ) at 2012-02-16 18:19 CET
Note: Host seems down. If it is really up, but blocking our ping probes, try -Pn
Nmap done: 1 IP address (0 hosts up) scanned in 0.39 seconds

The ping is succesful. I do not understand how is possible that nmap reports blocking ping probes and I can ping the adress without problem. I have the ssh service checked (ticked off) on firewall.

nmap -Pn reported this:
Starting Nmap 5.51 ( http://nmap.org ) at 2012-02-16 18:25 CET
Nmap scan report for 192.168.1.101
Host is up (0.95s latency).
All 1000 scanned ports on 192.168.1.101 are filtered

Nmap done: 1 IP address (1 host up) scanned in 54.66 seconds

Last edited by tuxalka; 16th February 2012 at 05:28 PM.
Reply With Quote
  #5  
Old 16th February 2012, 05:35 PM
PabloTwo Offline
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 5,855
linuxchrome
Re: trouble to connect via ssh

The Fedora firewall also blocks "interfaces". In your "system-config-firewall" GUI application, by default, all interfaces are marked as "untrusted". For ssh to work, on the machine you are ssh'ing into, you must go to the "Trusted Interfaces" tab and check off which ever of the interfaces you want to allow. Probably checking off "eth+" and "wlan+" will do for most circumstances. Save and exit.
Reply With Quote
  #6  
Old 16th February 2012, 08:18 PM
coffee412 Offline
Registered User
 
Join Date: Aug 2005
Location: Ask the Government.
Posts: 423
linuxfirefox
Re: trouble to connect via ssh

Quote:
Note: Host seems down. If it is really up, but blocking our ping probes
Yep. Your blocked from access.

If you dont see your ports as visible from nmap then they are most likely blocked. You need to open up the port for your local network as PabloTwo stated.

Personally, My home network is secured by my server acting also as a firewall. Therefore I just tell the server to trust my nic running the local network and leave all ports open. Now it only has to worry about the nic heading out/in from internet.

Port 22 must be available for your local network in order to connect.

take care,
__________________
Fedora20 AMD X6 1090T - 8GIG RAM - Nvidia GTX-650 - LXDE. Linux since 1995 - No Gnomes allowed.
Mythbuntu - Mythtv .27 - AMD 6core- 8 gigs ram Nvidia GTX-650 Ceton 4 port tunner
Lenovo laptop - Linux Mint 15 Xfce DE *Get your linux on*

Reply With Quote
  #7  
Old 16th February 2012, 08:36 PM
PabloTwo Offline
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 5,855
linuxchrome
Re: trouble to connect via ssh

@coffee412- My post wasn't referring to ports, it was referring to blocked "interfaces". Port 22 for ssh is enabled and open by default in F16.
Reply With Quote
  #8  
Old 16th February 2012, 10:02 PM
jswmcw Offline
Registered User
 
Join Date: Jan 2011
Location: Ohio
Posts: 45
linuxfirefox
Re: trouble to connect via ssh

Quote:
Originally Posted by PabloTwo View Post
Port 22 for ssh is enabled and open by default in F16.
Are you sure about this? I specifically remember having to enable ssh in the firewall settings. Of course, I cannot confirm this without a fresh install.



---------

Actually, I think I just had to start the service. Nevermind.
__________________
:C
"Anybody who tells me I can't use a program because it's not open source, go suck on rms. I'm not interested. 99% of that I run tends to be open source, but that's _my_ choice, dammit." -- Linus Torvalds, 2004.

Last edited by jswmcw; 16th February 2012 at 10:11 PM.
Reply With Quote
  #9  
Old 17th February 2012, 01:09 AM
coffee412 Offline
Registered User
 
Join Date: Aug 2005
Location: Ask the Government.
Posts: 423
linuxfirefox
Talking Re: trouble to connect via ssh

Quote:
Originally Posted by PabloTwo View Post
@coffee412- My post wasn't referring to ports, it was referring to blocked "interfaces". Port 22 for ssh is enabled and open by default in F16.
Note: Host seems down. If it is really up, but blocking our ping probes....

Really?
__________________
Fedora20 AMD X6 1090T - 8GIG RAM - Nvidia GTX-650 - LXDE. Linux since 1995 - No Gnomes allowed.
Mythbuntu - Mythtv .27 - AMD 6core- 8 gigs ram Nvidia GTX-650 Ceton 4 port tunner
Lenovo laptop - Linux Mint 15 Xfce DE *Get your linux on*

Reply With Quote
Reply

Tags
connect, ssh, trouble

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
trouble with eth0, cant connect to internet evgeni22 Servers & Networking 2 21st January 2010 12:48 PM
Network Connect Trouble-FC6 sturmvogel Servers & Networking 2 7th November 2006 02:46 AM
unable to connect to internet,able to connect through windows XP Narasimha Servers & Networking 1 4th October 2005 12:16 AM
unable to connect to internet,able to connect through windows XP Narasimha Servers & Networking 0 3rd October 2005 06:35 PM
freezing during screensaver and trouble on reboot + gnome panel trouble bwalsh Using Fedora 0 5th July 2005 02:45 AM


Current GMT-time: 10:32 (Wednesday, 23-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat