Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Using Fedora
FedoraForum Search

Forgot Password? Join Us!

Using Fedora General support for current versions. Ask questions about Fedora that do not belong in any other forum.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 13th January 2012, 07:14 PM
errorxp Offline
Registered User
 
Join Date: Jul 2007
Posts: 371
linuxfirefox
How to stop screen from turning off when using vlc?

Why does my display keep turning off when watching video in vlc or youtube? As far as I can remember this problem has existed with every release that i've been using and the solution has been to uninstall gnome-screensaver and install xscreensaver. Does the same thing apply to gnome3 (cinnamon)? No such problem in Mint12 for example, very annoying.
__________________
these command lines are like casino slot machines, every time I input commands NOTHING HAPPENS
Reply With Quote
  #2  
Old 13th January 2012, 08:43 PM
caf4926 Offline
Registered User
 
Join Date: Jun 2007
Location: The English Lakes
Posts: 125
linuxfirefox
Re: How to stop screen from turning off when using vlc?

I ended up using SMPlayer - It works
__________________
Novell Knowledge Partner
Reply With Quote
  #3  
Old 13th January 2012, 09:02 PM
nonamedotc Offline
Community Manager
 
Join Date: Mar 2011
Location: USA
Posts: 3,805
linuxchrome
Re: How to stop screen from turning off when using vlc?

You can install the package caffeine which does what you want to do. I believe you might have to install it using the rpm. I am not sure if it is available in the repositories.

---------- Post added at 03:02 PM ---------- Previous post was at 03:01 PM ----------

May be you can start from here ..Caffeine
Reply With Quote
  #4  
Old 13th January 2012, 09:09 PM
sea Offline
"Shells" (of a sub world)
 
Join Date: May 2011
Location: Confoederatio Helvetica (Swissh)
Age: 34
Posts: 3,439
linuxfirefox
Re: How to stop screen from turning off when using vlc?

Didnt care about movies while tested G3.
But with F16 LXDE, i had set xscreensaver to go black/screensaver after 90min idle. Pw 1 min after to activate.
However, i ended up put it to 2 hrs, as i was watching many movies during longer than 100 min.
__________________
Laptop: Toshiba satellite p50-a-11 CPU: Intel i7 8*2400 MHz GPU: GeForce GT 745M RAM: 8192 MB Distro: Fedora (Rawhide) DE: Awesome
Text User Interface (TUI) // Windows 8+ & Fedora 20+ Dualboot
Reply With Quote
  #5  
Old 13th January 2012, 11:06 PM
JohnVV Offline
Registered User
 
Join Date: Aug 2005
Location: Ann Arbor
Age: 47
Posts: 3,936
linuxfirefox
Re: How to stop screen from turning off when using vlc?

did you check the " disable screen saver" check box in VLC

and have you turned off the default "blank screen after 5 min"
screen saver/power setting
__________________
OpenSUSE 13.1-64bit & Scientific Linux 6.5-64bit ( fedora 4 to 11) and 19/20 on KVM
My Celestia Downloads

h t t p ://celestiamotherlode.net/catalog/show_creator_details.php?creator_id=10
Reply With Quote
  #6  
Old 14th January 2012, 12:04 AM
geoffmen Offline
Registered User
 
Join Date: Jun 2011
Posts: 31
linuxchrome
Cool Re: How to stop screen from turning off when using vlc?

I use some gnome-shell-extension-presentation-mode
It's bastardly identified as an extension to "control de screen saver"

It actually inhibits the screensaver.

search around you'll find how to install it.
__________________
Fedora 16 64
Gnome 3.2
Dell XPS M1330
Intel Core2 Duo CPU T6400 @ 2.00GHz × 2
Intel 965GM
Reply With Quote
  #7  
Old 15th January 2012, 07:36 PM
errorxp Offline
Registered User
 
Join Date: Jul 2007
Posts: 371
windows_7firefox
Re: How to stop screen from turning off when using vlc?

The "disable screensaver" thing is enabled but it has no effect whatsoever.
Why can't there be an option to disable the screensaver to begin with. Nobody ever uses it right, let's remove everything.
Tried to install the gnome-shell-extension-presentation-mode package but no such option appeared.
__________________
these command lines are like casino slot machines, every time I input commands NOTHING HAPPENS
Reply With Quote
  #8  
Old 15th January 2012, 09:22 PM
Gareth Jones Offline
Official Gnome 3 Sales Rep. (and Adminstrator)
 
Join Date: Jul 2011
Location: Birmingham, UK
Age: 31
Posts: 2,771
linuxfirefox
Re: How to stop screen from turning off when using vlc?

Quote:
Originally Posted by errorxp View Post
The "disable screensaver" thing is enabled but it has no effect whatsoever.
I think the screen-saver control API was changed fairly recently, and programs still using the old API (which seems to be almost everything outside of GNOME itself) silently fail to turn it off. Other than the things already suggested though, I don't know of any solution for VLC. Totem (the GNOME default player) seems to disable the screen-saver okay.

Gareth
Reply With Quote
  #9  
Old 16th January 2012, 06:56 PM
errorxp Offline
Registered User
 
Join Date: Jul 2007
Posts: 371
linuxfirefox
Re: How to stop screen from turning off when using vlc?

OK I uninstalled gnome-screensaver since there is no easy way to turn it off and installed xscreensaver.
It seems to work ok in "blank screen only" mode although you can't use the lock screen in the system menu anymore.
Nonetheless it doesn't interrupt vlc. Now here's a question - why can't the gnome devs fix something that has been broken for ages and produce something that works.
__________________
these command lines are like casino slot machines, every time I input commands NOTHING HAPPENS
Reply With Quote
  #10  
Old 16th January 2012, 07:17 PM
Dangermouse Offline
Administrator - (On Leave)
 
Join Date: Aug 2007
Location: London Postbox (the red one)
Age: 48
Posts: 3,864
linuxfirefox
Re: How to stop screen from turning off when using vlc?

http://forums.fedoraforum.org/showpost.php?p=1547131&postcount=3
Reply With Quote
  #11  
Old 16th January 2012, 08:39 PM
errorxp Offline
Registered User
 
Join Date: Jul 2007
Posts: 371
linuxfirefox
Re: How to stop screen from turning off when using vlc?

Installed that and enabled it with gnome tweak tool - no such option is added to the panel.
__________________
these command lines are like casino slot machines, every time I input commands NOTHING HAPPENS
Reply With Quote
  #12  
Old 16th January 2012, 09:12 PM
Dangermouse Offline
Administrator - (On Leave)
 
Join Date: Aug 2007
Location: London Postbox (the red one)
Age: 48
Posts: 3,864
linuxfirefox
Re: How to stop screen from turning off when using vlc?

It would of been enabled when you installed it, you probably have disabled it ?

https://extensions.gnome.org/local/
Reply With Quote
  #13  
Old 16th January 2012, 09:34 PM
errorxp Offline
Registered User
 
Join Date: Jul 2007
Posts: 371
linuxfirefox
Re: How to stop screen from turning off when using vlc?

https://extensions.gnome.org/local/ site tells me its installed and ON, also gnome tweak tool, but I can see only the suspend button, nothing more.
Weird, for example the alternative-status-menu extension works.
__________________
these command lines are like casino slot machines, every time I input commands NOTHING HAPPENS

Last edited by errorxp; 16th January 2012 at 09:43 PM.
Reply With Quote
  #14  
Old 17th January 2012, 02:58 PM
errorxp Offline
Registered User
 
Join Date: Jul 2007
Posts: 371
linuxfirefox
Re: How to stop screen from turning off when using vlc?

Sigh. The "presentation mode" in fedora repo-s only works on laptops because there is no battery icon in desktop. This is what you need - https://extensions.gnome.org/extensi...entation-mode/

__________________
these command lines are like casino slot machines, every time I input commands NOTHING HAPPENS
Reply With Quote
  #15  
Old 18th January 2012, 09:06 AM
errorxp Offline
Registered User
 
Join Date: Jul 2007
Posts: 371
windows_7firefox
Re: How to stop screen from turning off when using vlc?

It appears that I can't logout, poweroff etc when the "presentation mode" is on.
__________________
these command lines are like casino slot machines, every time I input commands NOTHING HAPPENS
Reply With Quote
Reply

Tags
screen, stop, turning, vlc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FC15 stop gnome from turning screen off RogerOdle2 EOL (End Of Life) Versions 21 18th November 2012 02:54 PM
Blank screen screensaver VS turning disply off kona0197 Wibble 4 11th January 2012 02:23 AM
[SOLVED] F16 prevent screen from turning off makuz Using Fedora 2 22nd November 2011 09:47 AM
White screen- How do I stop compiz from turning on at login? Thaidog Using Fedora 7 13th February 2009 08:20 AM
Turning off screen blanking fossy101 Using Fedora 0 6th January 2006 04:46 AM


Current GMT-time: 08:13 (Wednesday, 01-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat