Fedora Linux Support Community & Resources Center
  #1  
Old 6th December 2011, 11:45 PM
poblano Offline
Registered User
 
Join Date: Jul 2006
Posts: 30
linuxchrome
[SOLVED] how can I "automount" USB drives?

I've recently installed Fedora 16 (XFCE spin) and am currently tweaking it. I have two external drives that I typically use for backups (one is USB, the other FireWire), and while I can see that they are visible to the kernel when I plug them in, I'd like to be able to mount them when I plug them in. I had done this successfully with thunar under Debian, but so far I've been unable to duplicate that success. Is there anyone out there who has done this with either thunar or nautilus?

Thanks in advance. This forum has been extremely helpful.

Last edited by poblano; 7th December 2011 at 11:50 PM.
Reply With Quote
  #2  
Old 7th December 2011, 03:20 AM
sidebrnz Offline
Registered User
 
Join Date: Oct 2007
Location: Freedonia
Age: 65
Posts: 2,626
linuxfirefox
Re: how can I "automount" USB drives?

This is easy, once you know how. Go to Preferences, Removable Drives And Media and select the tab for Storage. (It's the one on the left.) Put a check in the first box and Bob's your uncle. HTH, HAND.
__________________
Registered Linux user #470359 and permanently recovered BOFH.

Any advice in this post is worth exactly what you paid for it.
Reply With Quote
  #3  
Old 7th December 2011, 11:24 PM
poblano Offline
Registered User
 
Join Date: Jul 2006
Posts: 30
linuxchrome
Re: how can I "automount" USB drives?

Thanks for the quick reply! I *think* I've done exactly what you've said. Here's the screenshot:



Unfortunately, no joy. Even though both devices show up when I do an fdisk -l, they don't mount as expected:

Code:
pablo@sombrero=> sudo fdisk -l
[sudo] password for pablo: 

Disk /dev/sda: 250.0 GB, 250000000000 bytes
255 heads, 63 sectors/track, 30394 cylinders, total 488281250 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xa42d04a3

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1              63     3903794     1951866   82  Linux swap / Solaris
/dev/sda2         3903856   488279609   242187877    5  Extended
/dev/sda5         3903858    52339769    24217956   83  Linux
/dev/sda6        52339833   100775744    24217956   83  Linux
/dev/sda7       246083733   488279609   121097938+  83  Linux
/dev/sda8       149211783   197647694    24217956   83  Linux
/dev/sda9   *   100775808   149211719    24217956   83  Linux
/dev/sda10      197650432   246083583    24216576   83  Linux

Partition table entries are not in disk order

Disk /dev/sdf: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000e6181

   Device Boot      Start         End      Blocks   Id  System
/dev/sdf1              63   625137344   312568641   83  Linux

Disk /dev/sdg: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders, total 312581808 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xab1aa141

   Device Boot      Start         End      Blocks   Id  System
/dev/sdg1   *          63   312576704   156288321   83  Linux
pablo@sombrero=> df -h
Filesystem      Size  Used Avail Use% Mounted on
rootfs           23G  3.5G   20G  16% /
devtmpfs        995M     0  995M   0% /dev
tmpfs          1003M  216K 1003M   1% /dev/shm
tmpfs          1003M   39M  964M   4% /run
/dev/sda9        23G  3.5G   20G  16% /
tmpfs          1003M   39M  964M   4% /run
tmpfs          1003M     0 1003M   0% /sys/fs/cgroup
tmpfs          1003M     0 1003M   0% /media
/dev/sda7       114G   45G   64G  42% /export
Is there something else I need to be doing?

Thanks again.
Reply With Quote
  #4  
Old 7th December 2011, 11:28 PM
sidebrnz Offline
Registered User
 
Join Date: Oct 2007
Location: Freedonia
Age: 65
Posts: 2,626
linuxfirefox
Re: how can I "automount" USB drives?

Yes, you've done what I suggested. Sometimes, with XFCE, you have to log out and back in before changes like that start working. If that doesn't work, try their forum, as this is DE specific.
__________________
Registered Linux user #470359 and permanently recovered BOFH.

Any advice in this post is worth exactly what you paid for it.
Reply With Quote
  #5  
Old 7th December 2011, 11:49 PM
poblano Offline
Registered User
 
Join Date: Jul 2006
Posts: 30
linuxchrome
Re: how can I "automount" USB drives?

Quote:
Originally Posted by sidebrnz View Post
Yes, you've done what I suggested. Sometimes, with XFCE, you have to log out and back in before changes like that start working. If that doesn't work, try their forum, as this is DE specific.
I had not only logged out, but rebooted, since I was test-driving a new kernel. I'll check in with the XFCE forum.

Thanks again!

---------- Post added at 06:49 PM ---------- Previous post was at 06:35 PM ----------

Found the answer pretty quickly on the XFCE forum. The solution is to start up the thunar file manager as a daemon. After that, Bob finally became my uncle.

Thanks for the tip.
Reply With Quote
  #6  
Old 8th December 2011, 03:09 AM
fdrake Offline
Registered User
 
Join Date: Dec 2011
Posts: 47
linuxfirefox
Re: how can I "automount" USB drives?

if you want to auto-mount those specific devices in the sys you can do that with fstab:
Code:
sudo mkdir /mnt/disk_1
sudo mkdir /mnt/disk_2
add these lines to your /etc/fstab
Quote:
# automount disk 1
UUID=disk_1_UUID_code /mnt/disk_1 TYPE1 rw,auto,user,exec,sync 0 0

# automount disk 2
UUID=disk_2_UUID_code /mnt/disk_2 TYPE2 rw,auto,user,exec,sync 0 0
note to find the info for TYPE1/TYPE2 and UUID-code use blkid after you have plugged the usb disk to the pc:
Code:
sudo blkid
reboot. And you should be all set!

Last edited by fdrake; 8th December 2011 at 03:18 AM.
Reply With Quote
  #7  
Old 8th December 2011, 04:32 AM
sidebrnz Offline
Registered User
 
Join Date: Oct 2007
Location: Freedonia
Age: 65
Posts: 2,626
linuxfirefox
Re: how can I "automount" USB drives?

That works fine if and only if you're only planning on mounting specific drives, not J. Random Flashdrive to give a friend a copy of something. Still, it's a good way to handle that kind of thing.
__________________
Registered Linux user #470359 and permanently recovered BOFH.

Any advice in this post is worth exactly what you paid for it.
Reply With Quote
Reply

Tags
automount, drives, usb

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
unpredictable "delete" "move to trash" or "cut" file menu option dorianrenato Using Fedora 1 21st November 2011 03:09 AM
"ls" and "cd" treat ".." differently inside symlinked directories bnorman Using Fedora 0 19th June 2008 04:49 PM
Fedora 9 Installation "no drives found" Mylex DAC960 zardoz Installation, Upgrades and Live Media 2 29th May 2008 07:22 PM
How to congigure automount to mount cd/dvd with "user" option - F7 Duli Using Fedora 2 6th June 2007 05:49 AM
Error:visibility arg must be one of "default", "hidden", "protected" or "internal" wangfeng Using Fedora 0 23rd May 2005 04:59 AM


Current GMT-time: 18:13 (Thursday, 30-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Makiyivka - Kushchevskaya - Capao da Canoa