Fedora Linux Support Community & Resources Center
  #1  
Old 12th November 2011, 04:03 AM
mdberger Offline
Registered User
 
Join Date: Oct 2011
Posts: 64
windows_xp_2003firefox
F16_64 grub2: stop quiet boot

On my new F16_64, I see that /boot/grub is essentially empty,
and now we have /boot/grub2. We no longer have a grub.conf
that can be modified to expose the log during boot.

I found /boot/grub2/grub.cfg that looked promising, In it
I in fact found linux command lines with the "quiet" keys.
I deleted the "quiet". The result was that some of the
boot log appeared, but it seemed that part of the boot
log was still covered by the useless boot gui.

Any suggestions on how I could expose the whole boot log?
Thanks for your suggestions.

Mike.
Reply With Quote
  #2  
Old 12th November 2011, 04:52 AM
skytux Offline
Registered User
 
Join Date: Mar 2010
Location: São José dos Campos (Brasil)
Posts: 65
linuxfirefox
Re: F16_64 grub2: stop quiet boot

You have to rebuild grub.cfg for the changes to take effect:

Code:
grub2-mkconfig -o /boot/grub2/grub.cfg
HTH
Reply With Quote
  #3  
Old 12th November 2011, 07:11 AM
markus39 Offline
Registered User
 
Join Date: Jul 2008
Location: Maastricht, the Netherlands
Age: 50
Posts: 68
linuxfirefox
Re: F16_64 grub2: stop quiet boot

This is only half the story,

You have to edit /etc/default/grub to add the kernel option and then run
the command:

grub2-mkconfig -o /boot/grub2/grub.cfg
Reply With Quote
  #4  
Old 12th November 2011, 07:29 AM
sonoran Offline
Registered User
 
Join Date: May 2005
Location: Sonoran Desert
Posts: 2,421
linuxfirefox
Re: F16_64 grub2: stop quiet boot

And for a third opinion...

You need to delete both "quiet" and "rhgb" from the kernel line ("linux") in /boot/grub2/grub.cfg.

You can safely ignore the DO NOT EDIT THIS FILE warning, as long as you DO NOT run grub2-mkconfig.
Fedora uses grubby to rewrite grub.cfg after kernel updates, and grubby will respect any changes
you have made to the file.

If you run grub2-mkconfig changes will be overwritten.

http://lists.fedoraproject.org/piper...er/407190.html
Reply With Quote
  #5  
Old 12th November 2011, 02:05 PM
martyfelker Offline
Registered User
 
Join Date: Jan 2006
Location: Floyd, VA
Posts: 95
linuxfirefox
Re: F16_64 grub2: stop quiet boot

A way that always works for me incorporates is a combination of the above hints.

1) Edit /etc/default/grub (I suggest you make a backup!) Mine reads

GRUB_CMDLINE_LINUX="rd.md=0 rd.dm=0 rd.lvm.lv=Linux/Fedora KEYTABLE=us SYSFONT=latarcyrheb-sun16 rd.luks=0 LANG=en_US.UTF-8"

I've removed "quiet" and "rhgb" from GRUB_CMDLINE_LINUX

2) run /grub2-mkdconfig -o /boot/grub2/grub.cfg


Reboot and enjoy! I like to see what's happening as well!
Reply With Quote
  #6  
Old 12th November 2011, 07:36 PM
AdamW Offline
Fedora QA Community Monkey
 
Join Date: Dec 2008
Location: Vancouver, BC
Posts: 4,328
linuxfirefox
Re: F16_64 grub2: stop quiet boot

sonoran and marty are both correct on this one.
__________________
Adam Williamson | awilliam AT redhat DOT com
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
http://www.happyassassin.net
Reply With Quote
  #7  
Old 13th November 2011, 10:29 PM
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 7,066
linuxfirefox
Re: F16_64 grub2: stop quiet boot

Quote:
Originally Posted by martyfelker View Post

>> 2) run /grub2-mkdconfig -o /boot/grub2/grub.cfg

Just to get the typos corrected since the above won't run, do this:
Quote:
/sbin/grub2-mkconfig -o /boot/grub2/grub.cfg
Reply With Quote
  #8  
Old 13th November 2011, 11:23 PM
smr54 Online
Registered User
 
Join Date: Jan 2010
Posts: 7,001
linuxchrome
Re: F16_64 grub2: stop quiet boot

I have a little page on this, which covers some of it. It was more of a reminder to myself, actually, but might be semi-useful. (Nothing in it that hasn't been mentioned here)

http://home.roadrunner.com/~computertaijutsu/grub2.html
Reply With Quote
  #9  
Old 14th November 2011, 01:08 AM
sonoran Offline
Registered User
 
Join Date: May 2005
Location: Sonoran Desert
Posts: 2,421
linuxfirefox
Re: F16_64 grub2: stop quiet boot

There seems to be some confusion about configuring grub2 in Fedora 16. Some of that
confusion stems from the "Do Not Edit This File" warning at the top of grub.cfg.

Fedora 16 uses grubby (see man grubby) when it updates the kernel, and grubby - depending
on how it's called - does not simply overwrite grub.cfg, but has the ability to incorporate
any changes that have been made to the grub.cfg file.

In the mail list link I posted above Fedora's grub2 hacker said he forgot to remove the
"Do Not Edit ..." warning. It will be removed eventually.

Fedora actually simplified use of grub2 for us - we can edit grub.cfg just as we did the
old grub.conf, and changes will be preserved across kernel updates.

The other way of modifying grub.cfg by editing /etc/default/grub or one of the other files
and then running /sbin/grub2-mkconfig -o /boot/grub2/grub.cfg, will work, but is not
necessary. One can simply edit grub.cfg and the changes will stick as long as one does not
run grub2-mkconfig.

Fedora scripts do not use grub2-mkconfig. They use grubby and incorporate grub.cfg changes.

One should decide which method one wants to use and then stick with that. If you edit
grub.cfg and then subsequently run grub2-mkconfig your changes will be overwritten.
Reply With Quote
  #10  
Old 14th November 2011, 02:30 AM
PabloTwo Offline
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 7,532
linuxfirefox
Re: F16_64 grub2: stop quiet boot

There is another way to get the boot up text display, using a Plymouth theme. It's what I did using F12, and I just tried it out now in F16. It works. You don't even need to remove the quiet and rhgb kernel line options.

To see your Plymouth theme choices (they haven't changed since F12 days):
Code:
plymouth-set-default-theme --list
charge
details
text
The "details" themes gives a neatly ordered display... sans the "[OK]" bit that it used to show.
To set details as the default, as root:
Code:
plymouth-set-default-theme details --rebuild-initrd
Give the above command a little time to finish as it will build a new initramfs image file. If you haven't already, you'll probably also want to give the text screen a bit more real estate than the default. I add "vga=791" to the kernel boot line. You'll see the effect on your next reboot.
Reply With Quote
  #11  
Old 7th December 2011, 10:39 AM
jontis Offline
Registered User
 
Join Date: Jun 2009
Posts: 35
linuxfirefox
Re: F16_64 grub2: stop quiet boot

This sounded great to me so I tried:

Quote:
Originally Posted by PabloTwo View Post
Code:
plymouth-set-default-theme details --rebuild-initrd
and got:
Code:
grubby fatal error: unable to find a suitable template
which is beyond my knowledge. Any suggestions?
This is for an updated F16 installed by preupgrade from F15.

Addition to my own post after some testing and googling.
The methods works fine and the error message seems to be benign according to bugzilla.

Last edited by jontis; 7th December 2011 at 11:05 AM. Reason: new knowledege
Reply With Quote
  #12  
Old 7th December 2011, 10:46 PM
martyfelker Offline
Registered User
 
Join Date: Jan 2006
Location: Floyd, VA
Posts: 95
linuxfirefox
Re: F16_64 grub2: stop quiet boot

I sue a text boot up in Fedora 17 Rawhide (used in F16 also). All you need to do is edit /etc/default/grub to remove quiet and rhbg from the GRUB_CMDLINE_LINUX line and then run sudo grub2-mkconfig -o /boot/grub2/grub.cfg. Since Plymouth is only used if want a graphical login I can't understand whey you'd want to modify your kernel. But perhaps I'm misunderstanding what you want.
Reply With Quote
  #13  
Old 22nd January 2012, 01:59 PM
jontis Offline
Registered User
 
Join Date: Jun 2009
Posts: 35
linuxfirefox
Re: F16_64 grub2: stop quiet boot

Thanks. I was looking for a way to increase the resolution of the console output during boot and it seemed difficult to do it in grub2.

I still ended up following that path with:
http://www.fedoraforum.org/forum/sho...=272807&page=2
Reply With Quote
Reply

Tags
boot, f1664, grub2, quiet, stop

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
boot fedora from iso using loopback in grub2 geseeker Installation, Upgrades and Live Media 19 27th February 2013 08:13 PM
HOW TO: Fedora 15 with /boot inside LVM using GRUB2 Scipio Guides & Solutions (Not For Questions) 3 12th September 2012 03:04 AM
grub2 and mdraid /boot and other confusion wangmaster Installation, Upgrades and Live Media 0 9th November 2011 07:00 AM
Grub2 quiet booting javiermon F16 Development 8 25th October 2011 10:33 PM
[SOLVED] Putting /boot inside LVM with grub2 Scipio Installation, Upgrades and Live Media 2 1st June 2011 06:04 PM


Current GMT-time: 01:48 (Friday, 26-05-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat