Fedora Linux Support Community & Resources Center
  #1  
Old 10th November 2011, 09:22 AM
seabird Offline
Registered User
 
Join Date: Jan 2009
Location: Den Bosch, Netherlands
Posts: 282
windows_7ie
Tiger VNC server

good morning all,

just re-installed my server with F16. I noticed a few changes and googled most solutions. The thing I could not figure out yet is the best way to set up the vnc server startup. This used to be:
/etc/sysconfig/vncservers
Code:
VNCSERVERS="1:user1 2:user1 3:user2"
VNCSERVERARGS[1]="-geometry 1400x900"
VNCSERVERARGS[2]="-geometry 1300x700"
VNCSERVERARGS[3]="-geometry 1300x650"
The reason I did this was different resolutions on desktop/laptop to connect.
What is the new way to set this up?

Thanks in advance, I did google this, but couldn't find it.
__________________
OS: Fedora 16
Casing: Chenbro RM21508B
Mainboard: ATX D2778
Processor: Intel Xeon W3550 (8 core)
Memory: 6Gb DDR3, ECC, 1333 MHz, PC3-10600
HD #1: OCZ Vertex 3 60Gb
Storage Drives: 4x 2Tb WD20EARS + 2x 2Tb WD20EARX
Graphics: Nvidia GeForce 210 Silent
PCI Card: Promise FastTrak TX4
Reply With Quote
  #2  
Old 10th November 2011, 10:51 PM
seabird Offline
Registered User
 
Join Date: Jan 2009
Location: Den Bosch, Netherlands
Posts: 282
windows_7ie
Re: Tiger VNC server

ok, re-installed and enabled the service with
systemctl enable vncserver@.service

reboot gives:
Code:
[root@server ~]# systemctl status vncserver@multi-user.service
vncserver@multi-user.service - Remote desktop service (VNC)
          Loaded: loaded (/lib/systemd/system/vncserver@.service; enabled)
          Active: failed since Thu, 10 Nov 2011 23:45:37 +0100; 4min 11s ago
         Process: 1008 ExecStart=/usr/bin/vncserver %i (code=exited, status=2)
          CGroup: name=systemd:/system/vncserver@.service/multi-user
[root@server ~]#
is there any documentation on this?
I know I want to edit this part, but unsure how:
Code:
[Service]
Type=forking
User=root
ExecStart=/usr/bin/vncserver %i
ExecStop=/usr/bin/vncserver -kill %i
__________________
OS: Fedora 16
Casing: Chenbro RM21508B
Mainboard: ATX D2778
Processor: Intel Xeon W3550 (8 core)
Memory: 6Gb DDR3, ECC, 1333 MHz, PC3-10600
HD #1: OCZ Vertex 3 60Gb
Storage Drives: 4x 2Tb WD20EARS + 2x 2Tb WD20EARX
Graphics: Nvidia GeForce 210 Silent
PCI Card: Promise FastTrak TX4

Last edited by seabird; 10th November 2011 at 10:54 PM.
Reply With Quote
  #3  
Old 11th November 2011, 06:37 AM
billzhuang Offline
Registered User
 
Join Date: Nov 2011
Posts: 1
windows_7chrome
Re: Tiger VNC server

i also meet this problem.
Reply With Quote
  #4  
Old 11th November 2011, 02:52 PM
khyr0n Offline
Registered User
 
Join Date: Nov 2011
Posts: 1
linuxfirefox
Re: Tiger VNC server

I am experiencing the exact same problem... This is surely not an isolated case...

Code:
[root@thor difrob40]# systemctl status vncserver@multi-user.service 
vncserver@multi-user.service - Remote desktop service (VNC)
	  Loaded: loaded (/lib/systemd/system/vncserver@.service; enabled)
	  Active: failed since Fri, 11 Nov 2011 10:06:10 -0500; 1min 5s ago
	 Process: 910 ExecStart=/usr/bin/vncserver %i (code=exited, status=2)
	  CGroup: name=systemd:/system/vncserver@.service/multi-user
Reply With Quote
  #5  
Old 11th November 2011, 08:11 PM
powderhound Offline
Registered User
 
Join Date: Jun 2007
Posts: 5
windows_7firefox
Re: Tiger VNC server

Hi, I'm having the same problem. Does anyone have a how to guide for setting up VNC under Fedora 16 please?

I've tried copying the file as per /lib/systemd/system/vncserver@.service

# Quick HowTo:
# 1. Copy this file to /etc/systemd/system/vncserver@:<display>.service
# 2. Edit "User" and "ExecStart" variables appropriately
# (ExecStart should be "/usr/bin/vncserver %i -arg1 -arg2")
# 3. Run `systemctl daemon-reload`


But I must be missing something

Thanks :-)
Reply With Quote
  #6  
Old 11th November 2011, 09:26 PM
ewa8949 Offline
Registered User
 
Join Date: Nov 2011
Posts: 2
windows_7chrome
Re: Tiger VNC server

I am having the same issue also. I installed Fedora last Tuesday and got this to work but then it quit working yesterday. I ran "yum update" and had installed several development packages like git so I wonder if something got broken. This was working consistently for me two days ago

UPDATED: I noticed that when I try to start a new vncserver just by running "vncserver -geometry 1600x1080" then I get error messages that "Warning: eadams-desktop:1 is taken because of /tmp/.X11-unix/X1 Remove this file if there is no X server eadams-desktop:1"

I had this error a lot when Tightvnc would segfault on my previous Ubuntu installation.

Last edited by ewa8949; 11th November 2011 at 09:52 PM.
Reply With Quote
  #7  
Old 12th November 2011, 02:42 PM
seabird Offline
Registered User
 
Join Date: Jan 2009
Location: Den Bosch, Netherlands
Posts: 282
macossafari
Re: Tiger VNC server

The problem is not how to start a vnc server. Running the server on requires the command vncserver. The current problem is how to auto start it.

The /tmp/X11 problem is just a unclean shutdown and easily fixed by deleting the socket file.
__________________
OS: Fedora 16
Casing: Chenbro RM21508B
Mainboard: ATX D2778
Processor: Intel Xeon W3550 (8 core)
Memory: 6Gb DDR3, ECC, 1333 MHz, PC3-10600
HD #1: OCZ Vertex 3 60Gb
Storage Drives: 4x 2Tb WD20EARS + 2x 2Tb WD20EARX
Graphics: Nvidia GeForce 210 Silent
PCI Card: Promise FastTrak TX4
Reply With Quote
  #8  
Old 12th November 2011, 04:22 PM
cygautier Offline
Registered User
 
Join Date: Nov 2011
Posts: 3
linuxchrome
Re: Tiger VNC server

Hello,
I've installed Fedora16 and I've just try to setup VNC using systemd.
I copy /lib/systemd/system/vncserver@.service to /etc/systemd/system/vncserver.service
I choose display :0 and modify this file (the simplest way i could at this moment)
so, i replace %i with :0 and setup args (probably not the best way for %i...)
The vncserver.service file is there :

[Unit]
Description=Remote desktop service (VNC)
After=syslog.target network.target

[Service]
Type=forking
User=cyrille
ExecStart=/usr/bin/vncserver :0 -geometry 1280x1024 -depth 16 -securitytypes=none -fp /usr/share/X11/fonts/misc
ExecStop=/usr/bin/vncserver -kill :0

[Install]
WantedBy=multi-user.target
I use xinetd.d before (not on fedora16) but with systemd, -inetd arg result is vnc not starting.

as indicated in vnc config file, i reloaded daemon and look at vncserver status and log
[cg]# systemctl enable vncserver.service
[cg]# systemctl --system daemon-reload

[cg]# systemctl status vncserver.service
[cg]# grep vnc /var/log/messages

I have to reboot before all just start fine...
vnsserver is running, but at this moment, gnome-session is not stable.

if someone could help on the ~/.vnc/xstartup file to correctly start gnome-session...

Cyrille.

Last edited by cygautier; 12th November 2011 at 10:32 PM.
Reply With Quote
  #9  
Old 12th November 2011, 05:47 PM
seabird Offline
Registered User
 
Join Date: Jan 2009
Location: Den Bosch, Netherlands
Posts: 282
macossafari
Re: Tiger VNC server

Strange choice to select screen 0. This is the actual on server display. Normally vnc is run as screen 1 or higher.
__________________
OS: Fedora 16
Casing: Chenbro RM21508B
Mainboard: ATX D2778
Processor: Intel Xeon W3550 (8 core)
Memory: 6Gb DDR3, ECC, 1333 MHz, PC3-10600
HD #1: OCZ Vertex 3 60Gb
Storage Drives: 4x 2Tb WD20EARS + 2x 2Tb WD20EARX
Graphics: Nvidia GeForce 210 Silent
PCI Card: Promise FastTrak TX4
Reply With Quote
  #10  
Old 12th November 2011, 07:20 PM
cygautier Offline
Registered User
 
Join Date: Nov 2011
Posts: 3
linuxchrome
Re: Tiger VNC server

Yes, you're right, normally vnc is used vith display 1, 2, ...
but my server is a headless box with no physical display, nor keyboard either.
I try with :1 instead of :0 and the result is the same with vncserver.

During my tests, I try Xvnc with -inet -query localhost as args (in order to access via XDMCP), but i did'nt manage to get it work.
I now use vncserver with display :1 and xfce and it seems to be stable.

cyrille.

Shuttle xs35GTv2

Last edited by cygautier; 14th November 2011 at 10:11 PM.
Reply With Quote
  #11  
Old 14th November 2011, 02:15 PM
seabird Offline
Registered User
 
Join Date: Jan 2009
Location: Den Bosch, Netherlands
Posts: 282
windows_7ie
Re: Tiger VNC server

Ok, I guess nobody else is responding anymore. Your example seems to work fine for 1 user. Can probably even set up multiple session by repeating the ExecStart (and stop) line.

Should I just replicate the complete service section for each user?
__________________
OS: Fedora 16
Casing: Chenbro RM21508B
Mainboard: ATX D2778
Processor: Intel Xeon W3550 (8 core)
Memory: 6Gb DDR3, ECC, 1333 MHz, PC3-10600
HD #1: OCZ Vertex 3 60Gb
Storage Drives: 4x 2Tb WD20EARS + 2x 2Tb WD20EARX
Graphics: Nvidia GeForce 210 Silent
PCI Card: Promise FastTrak TX4
Reply With Quote
  #12  
Old 14th November 2011, 02:20 PM
powderhound Offline
Registered User
 
Join Date: Jun 2007
Posts: 5
windows_7firefox
Re: Tiger VNC server

I've tried using the above but I receive the mesage

[root@powder-app-01 ~]# systemctl status vncserver.service
xvncserver.service
Loaded: error (Reason: No such file or directory)
Active: inactive (dead)
[root@powder-app-01 ~]#


help please?
Reply With Quote
  #13  
Old 14th November 2011, 02:22 PM
seabird Offline
Registered User
 
Join Date: Jan 2009
Location: Den Bosch, Netherlands
Posts: 282
macossafari
Re: Tiger VNC server

Try Vncserver@.service
__________________
OS: Fedora 16
Casing: Chenbro RM21508B
Mainboard: ATX D2778
Processor: Intel Xeon W3550 (8 core)
Memory: 6Gb DDR3, ECC, 1333 MHz, PC3-10600
HD #1: OCZ Vertex 3 60Gb
Storage Drives: 4x 2Tb WD20EARS + 2x 2Tb WD20EARX
Graphics: Nvidia GeForce 210 Silent
PCI Card: Promise FastTrak TX4
Reply With Quote
  #14  
Old 14th November 2011, 02:36 PM
powderhound Offline
Registered User
 
Join Date: Jun 2007
Posts: 5
windows_7firefox
Re: Tiger VNC server

No Sorry :-(

[root@powder-app-01 ~]# systemctl status Vncserver@.service
Failed to issue method call: Unit name Vncserver@.service is not valid.
[root@powder-app-01 ~]#

am I missing something basic?
Reply With Quote
  #15  
Old 14th November 2011, 08:58 PM
cygautier Offline
Registered User
 
Join Date: Nov 2011
Posts: 3
linuxchrome
Re: Tiger VNC server

Hello,
do you have enabled your service with

systemctl enable vncserver.service

doing this, systemctl create a symbolic link to the vncserver.service file you create in /etc/systemd/system.

Cyrille.

Last edited by cygautier; 14th November 2011 at 09:00 PM.
Reply With Quote
Reply

Tags
server, tiger, vnc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Tiger Warnings bootneck Security and Privacy 2 11th March 2011 10:08 AM
Maybe Tiger needs one of these.... SwampKracker Wibble 1 20th February 2010 05:47 AM
Tiger Direct JN4OldSchool Wibble 15 26th December 2008 03:06 AM
Samba server and os x tiger binderim Servers & Networking 1 26th March 2006 08:56 PM
so... mac osx 10.4 tiger :P Trendkill Wibble 2 10th May 2005 03:19 AM


Current GMT-time: 23:10 (Wednesday, 22-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Megarine Instagram Photos - Qingyuan Photos - Saint-Pierre-des-Corps