Fedora Linux Support Community & Resources Center
  #1  
Old 10th November 2011, 02:37 AM
HalfEmptyHero Offline
Registered User
 
Join Date: Jun 2011
Posts: 8
linuxfirefox
Tracker?

Tracking keeps on crashing on me and running up my cpu. How can I disable it? I tried killall tracker-extract but it keeps on respawning.
Reply With Quote
  #2  
Old 10th November 2011, 05:55 AM
AdamW Offline
Fedora QA Community Monkey
 
Join Date: Dec 2008
Location: Vancouver, BC
Posts: 4,186
linuxfirefox
Re: Tracker?

run 'gnome-session-properties' and disable all the Tracker bits.
__________________
Adam Williamson | awilliam AT redhat DOT com
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
http://www.happyassassin.net
Reply With Quote
  #3  
Old 10th November 2011, 08:49 PM
HalfEmptyHero Offline
Registered User
 
Join Date: Jun 2011
Posts: 8
linuxfirefox
Re: Tracker?

Nice, thanks.
Reply With Quote
  #4  
Old 11th August 2012, 03:13 AM
undoIT Offline
Registered User
 
Join Date: May 2009
Location: Reno
Posts: 29
linuxfirefox
Re: Tracker?

Thanks for this. I was having the same problem with Fedora 17 KDE. Looked everywhere in system settings and couldn't find the place to turn off tracker. Added to my list of hacks for post-install.

---------- Post added at 07:13 PM ---------- Previous post was at 10:07 AM ----------

Nope. Didn't work. Installed system updates, rebooted into KDE and tracker came back.

Darned tracker is still crashing. Currently, the tracker junk running in the background is consuming almost 1GB of RAM.

Quote:
Process /usr/libexec/tracker-extract was killed by signal 11 (SIGSEGV)
Checked gnome-session-properties and all instances of tracker are still unchecked. I think it is also necessary to do this:

Code:
sudo rm ~/.config/autostart/tracker-miner-fs.desktop && rm  ~/.config/autostart/tracker-store.desktop
Reply With Quote
  #5  
Old 11th August 2012, 10:27 PM
Gareth Jones Offline
Official Gnome 3 Sales Rep. (and Adminstrator)
 
Join Date: Jul 2011
Location: Birmingham, UK
Age: 31
Posts: 2,771
linuxfirefox
Re: Tracker?

gnome-session-properies is for GNOME, and has no relevance to KDE's session manager. I'm not sure what the normal way to configure KDE's session manager is though.
Reply With Quote
  #6  
Old 11th August 2012, 11:56 PM
dd_wizard Offline
Registered User
 
Join Date: Sep 2009
Posts: 1,409
linuxfirefox
Re: Tracker?

If you're going to shutdown tracker permanently, you might want to run:
Code:
tracker-control --hard-reset --remove-config

       -r, --hard-reset
              This  kills  all processes in the same way that --kill does but it also removes
              all databases. Restarting tracker-store re-creates the databases.

       -c, --remove-config
              This removes all config files in $HOME/.config/tracker. All  files  listed  are
              files  which  were  found  and successfully removed.  Restarting the respective
              processes re-creates the default configuration files.
Disabling tracker and cleaning up after it's initial start are two things I do after every install. I was kind of hoping it would go away, but it's part of gnome.

dd_wizard
Reply With Quote
  #7  
Old 14th August 2012, 03:59 AM
undoIT Offline
Registered User
 
Join Date: May 2009
Location: Reno
Posts: 29
linuxfirefox
Re: Tracker?

Tracker will not die!

Even after doing everything listed in this thread and also turning off everything I could find related to Nepomuk/Strigi Desktop search, tracker-miner-fs, tracker-store and tracker-extract are still running in the background after reboot, chewing up the CPU, guzzling RAM and reducing the life of my SSD.

This is frustrating.

---------- Post added at 07:59 PM ---------- Previous post was at 07:49 PM ----------

I finally tracked down the culprits:

/etc/xdg/autostart/tracker-miner-flickr.desktop
/etc/xdg/autostart/tracker-miner-fs.desktop
/etc/xdg/autostart/tracker-store.desktop

If you are feeling barbaric you can deal with the offenders like so:
Code:
sudo rm /etc/xdg/autostart/tracker-miner-flickr.desktop && rm /etc/xdg/autostart/tracker-miner-fs.desktop && rm /etc/xdg/autostart/tracker-store.desktop
Otherwise, you can try editing each entry to disable them (not sure how to do that and don't feel like fiddling with tracker anymore).
Reply With Quote
  #8  
Old 14th August 2012, 08:12 AM
bepaald Offline
Registered User
 
Join Date: Nov 2004
Posts: 124
linuxfirefox
Re: Tracker?

Quote:
Originally Posted by undoIT View Post
Tracker will not die!

I finally tracked down the culprits:

/etc/xdg/autostart/tracker-miner-flickr.desktop
/etc/xdg/autostart/tracker-miner-fs.desktop
/etc/xdg/autostart/tracker-store.desktop

If you are feeling barbaric you can deal with the offenders like so:
Code:
sudo rm /etc/xdg/autostart/tracker-miner-flickr.desktop && rm /etc/xdg/autostart/tracker-miner-fs.desktop && rm /etc/xdg/autostart/tracker-store.desktop
Otherwise, you can try editing each entry to disable them (not sure how to do that and don't feel like fiddling with tracker anymore).
This obviously works, but is not the normal way of disabling these services. Note also that if you use this method, that is editing/removing global files, any update of a package providing these files will recreate and thus re-enable the services. A more permanent way to disable services from xdg/autostart is to create user-owned .desktop files in your home directory. The desktop files can simply be empty. During startup, the home directory will be checked first and, even though the empty file doesn't do anything (because it's empty), desktop files with the same name from other places (like /etc/xdg/autostart, which is scanned later) are not started anymore. As they are personal files in your home directory, they will persist through updates and reinstalls. So, to disable the three services mentioned above simply:
Code:
touch ~/.config/autostart/tracker-miner-flickr.desktop ~/.config/autostart/tracker-miner-fs.desktop ~/.config/autostart/tracker-store.desktop
I don't have these tracker-things by the way, probably because I don't have gnome installed, but this is how I managed to disable zeitgeist. And I must say I was pretty disappointed that KDE (and gnome?) do not provide GUIs to manage the services started through the xdg autostart method.

bepaald
__________________
Running F20 x86_64 with KDE
Intel Core i7-4771 @ 3.5GHz
8G RAM
Reply With Quote
  #9  
Old 3rd May 2013, 11:07 PM
jhhaynes Offline
Registered User
 
Join Date: Mar 2005
Posts: 94
linuxfirefox
Re: Tracker?

Quote:
Originally Posted by bepaald View Post
This obviously works, but is not the normal way of disabling these services. Note also that if you use this method, that is editing/removing global files, any update of a package providing these files will recreate and thus re-enable the services. A more permanent way to disable services from xdg/autostart is to create user-owned .desktop files in your home directory. The desktop files can simply be empty. During startup, the home directory will be checked first and, even though the empty file doesn't do anything (because it's empty), desktop files with the same name from other places (like /etc/xdg/autostart, which is scanned later) are not started anymore. As they are personal files in your home directory, they will persist through updates and reinstalls. So, to disable the three services mentioned above simply:
Code:
touch ~/.config/autostart/tracker-miner-flickr.desktop ~/.config/autostart/tracker-miner-fs.desktop ~/.config/autostart/tracker-store.desktop
I don't have these tracker-things by the way, probably because I don't have gnome installed, but this is how I managed to disable zeitgeist. And I must say I was pretty disappointed that KDE (and gnome?) do not provide GUIs to manage the services started through the xdg autostart method.

bepaald
Well for some reason that doesn't work for me. The files you said to touch are already there,
so I renamed them and then touched new empty ones, and tracker is still there when I log out
and back in. So guess I will have to use the more brutal method.
Reply With Quote
Reply

Tags
tracker

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Tracker seems to be a resource hog... dd_wizard F16 Development 4 31st August 2011 09:58 PM
Tracker gui wants older version of tracker CiaW Fedora 13 Development Branch 3 6th May 2010 12:52 PM
tracker frontend katastrophal Fedora 13 Development Branch 1 27th April 2010 04:38 PM
Offline Bug Tracker? smurffit Using Fedora 0 9th January 2010 05:04 PM
The Fedora Tracker mhelios Links 8 30th March 2004 01:50 AM


Current GMT-time: 14:29 (Thursday, 02-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat