Fedora Linux Support Community & Resources Center
  #1  
Old 12th October 2011, 07:27 PM
AdrianRiley Offline
Registered User
 
Join Date: Jun 2008
Posts: 19
linuxfirefox
xfce4 not saving wifi network password

I'm using xfce4 with Fedora15. Every time I log in I have to enter my wifi network password. gnome-keyring-daemon is running:
Code:
[adrian@paxton ~]$ ps -ef | grep keyring
adrian    5268     1  0 19:03 ?        00:00:00 /usr/bin/gnome-keyring-daemon --daemonize --login
I have seen some other posts on the same issue, but reported as fixed. I think I have the latest release versions of everything.

Is there something else I need to do? Any help very welcome, thanks.
Reply With Quote
  #2  
Old 12th October 2011, 09:33 PM
David Batson Offline
Registered User
 
Join Date: Jul 2009
Posts: 1,234
windows_7opera
Re: xfce4 not saving wifi network password

I am just trying out xfce on Arch Linux. Haven't got all the bugs worked out yet, but the Arch Wiki has the following which seems to work for me.

Code:
# mv /etc/wpa_supplicant.conf /etc/wpa_supplicant.conf.original
# wpa_passphrase linksys "my_secret_passkey" > /etc/wpa_supplicant.conf
The word linksys above should of course be replaced with your network essid (network name).
__________________
Fedora 19 Gnome on a ThinkPad X220, i5-2540M CPU, Intel HD Graphics 3000, Intel N 6205 wireless, and Sierra Wireless 754S Mobile Hotspot (AT&T)
Reply With Quote
  #3  
Old 13th October 2011, 08:54 PM
AdrianRiley Offline
Registered User
 
Join Date: Jun 2008
Posts: 19
linuxfirefox
Re: xfce4 not saving wifi network password

Thanks, but that had no effect. I do see that the problem is not related to xfce4, tried it with xlde and even went back to gnome3 again, all the same.

I see this in /var/logs/messages on logging in:

Code:
Oct 13 20:45:32 paxton pam: gdm-password[5480]: WARNING: unable to log session
Oct 13 20:45:33 paxton NetworkManager[3990]: <info> Auto-activating connection 'Auto Harcourt'.
Oct 13 20:45:33 paxton NetworkManager[3990]: <info> Activation (wlan0) starting connection 'Auto Harcourt'
Oct 13 20:45:33 paxton NetworkManager[3990]: <info> (wlan0): device state change: disconnected -> prepare (reason 'none') [30 40 0]
Oct 13 20:45:33 paxton NetworkManager[3990]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Oct 13 20:45:33 paxton NetworkManager[3990]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
Oct 13 20:45:33 paxton NetworkManager[3990]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
Oct 13 20:45:33 paxton NetworkManager[3990]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Oct 13 20:45:33 paxton NetworkManager[3990]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Oct 13 20:45:33 paxton NetworkManager[3990]: <info> (wlan0): device state change: prepare -> config (reason 'none') [40 50 0]
Oct 13 20:45:33 paxton NetworkManager[3990]: <info> Activation (wlan0/wireless): access point 'Auto Harcourt' has security, but secrets are required.
Oct 13 20:45:33 paxton NetworkManager[3990]: <info> (wlan0): device state change: config -> need-auth (reason 'none') [50 60 0]
Oct 13 20:45:33 paxton NetworkManager[3990]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Oct 13 20:45:33 paxton NetworkManager[3990]: <warn> No agents were available for this request.
Oct 13 20:45:33 paxton NetworkManager[3990]: <info> (wlan0): device state change: need-auth -> failed (reason 'no-secrets') [60 120 7]
Oct 13 20:45:33 paxton NetworkManager[3990]: <warn> Activation (wlan0) failed for access point (Harcourt)
Oct 13 20:45:33 paxton NetworkManager[3990]: <info> Marking connection 'Auto Harcourt' invalid.
Oct 13 20:45:33 paxton NetworkManager[3990]: <warn> Activation (wlan0) failed.
Oct 13 20:45:33 paxton NetworkManager[3990]: <info> (wlan0): device state change: failed -> disconnected (reason 'none') [120 30 0]
Oct 13 20:45:33 paxton NetworkManager[3990]: <info> (wlan0): deactivating device (reason 'none') [0]
Oct 13 20:45:35 paxton gnome-keyring-daemon[5472]: couldn't set environment variable in session: The name org.gnome.SessionManager was not provided by any .service files
Oct 13 20:45:35 paxton gnome-keyring-daemon[5472]: couldn't set environment variable in session: The name org.gnome.SessionManager was not provided by any .service files
Oct 13 20:45:35 paxton gnome-keyring-daemon[5472]: couldn't set environment variable in session: The name org.gnome.SessionManager was not provided by any .service files
Reply With Quote
  #4  
Old 14th October 2011, 09:40 PM
AdrianRiley Offline
Registered User
 
Join Date: Jun 2008
Posts: 19
linuxfirefox
[SOLVED] Re: xfce4 not saving wifi network password

Ok, after much searching around, I found the answer here: https://bugzilla.redhat.com/show_bug.cgi?id=706204#c8

Use nm-connection-editor to set the password, or manually edit /etc/sysconfig/network-scripts/ifcfg-<name> and /etc/sysconfig/network-scripts/keys-<name>
Reply With Quote
  #5  
Old 12th November 2011, 11:24 PM
cheerio158 Offline
Registered User
 
Join Date: Apr 2005
Location: Toronto, Ontario, Canada
Posts: 231
linuxchrome
Angry Re: xfce4 not saving wifi network password

If got the same problem with Fedora 16 (Gnome3) on a live USB. All was fine up until Fedora 14 and was broken in Fedora 15.

Of course, this solution isn't going to work for me because /etc is not persistent. However, I could do something kludgey like inject the connection settings of my frequently accessed wifi connections when I build my live USB.

How does a non-administrative user save information in /etc anyway!? This change in behaviour is moronic!
__________________
Desktop Smolt profile
Laptop Smolt profile
EeePC Smolt profile
Reply With Quote
Reply

Tags
network, password, saving, wifi, xfce4

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How stop request for password to password manager whenever logs in to wifi? 6tr6tr Using Fedora 7 27th June 2009 05:46 PM
NetworkManager and saving password Adaghost Servers & Networking 4 22nd November 2007 03:47 AM
saving a file to your harddrive, it can't be viewed by another computer on network.. bcruze Servers & Networking 1 25th September 2007 02:02 PM
XFCE4, wifi, power management an a Fujitsu/Siemens Lifebook C1110... anotherdike Guides & Solutions (No Questions) 0 15th June 2006 04:55 PM
saving a file on a network from one node to another on a N/W alisha Servers & Networking 0 12th September 2004 08:29 PM


Current GMT-time: 09:24 (Thursday, 23-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Zunyi - Elburg Travel Photos - Dijkot Instagram Photos