Fedora Linux Support Community & Resources Center
  #1  
Old 1st October 2011, 02:39 PM
sea Offline
"Shells" (of a sub world)
 
Join Date: May 2011
Location: Confoederatio Helvetica (Swissh)
Age: 34
Posts: 3,483
linuxfedorafirefox
Start lxpanel at upper left corner?

Heyas

In ~/.config/autostart i have a lxpanel.desktop:
PHP Code:
[Desktop Entry]
Encoding=UTF-8
Name
=LXTerminal
Comment
=Use the command line
#TryExec=lxterminal
Exec=lxterminal  --geometry=100x45+1+--title="sea Console"
Icon=lxterminal
Type
=BGConsole
Role
=Test
Categories
=GTK;TerminalEmulator;System;
X-Desktop-File-Install-Version=0.18 
And it opens on login, so far so good.

However, i assumed that +1+1 would place it in upper left corner, 1 line and 1 collum distance from screen border.
Thats not the case.
Even +0+0 doesnt have an effect.

Any idea how i can place it in upper left corner?
Thank you.
__________________
Laptop: Toshiba satellite p50-a-11 CPU: Intel i7 8*2400 MHz GPU: GeForce GT 745M RAM: 8192 MB Distro: Fedora (Rawhide) DE: Awesome
Text User Interface (TUI) // Windows 8+ & Fedora 20+ Dualboot
Reply With Quote
  #2  
Old 1st October 2011, 03:10 PM
PabloTwo Online
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 6,190
linuxfirefox
Re: Start lxpanel at upper left corner?

lxterminal doesn't conform to the standard X-server geometry format. You can only dictate it's size, not it's screen location.

--geometry=CHARACTERSxLINES

I just installed lxterminal to check it out and test it. You could use another terminal, such as xterm or urxvt, which will allow you to use the --geometry=XxY+x+y format.
Reply With Quote
  #3  
Old 1st October 2011, 03:12 PM
sea Offline
"Shells" (of a sub world)
 
Join Date: May 2011
Location: Confoederatio Helvetica (Swissh)
Age: 34
Posts: 3,483
linuxfedorafirefox
Re: Start lxpanel at upper left corner?

I'd like to have that yummy transparent effect, which i dont have with xterm
Going to try urxvt.
Fedora hasnt that in repos, right?

Ty
__________________
Laptop: Toshiba satellite p50-a-11 CPU: Intel i7 8*2400 MHz GPU: GeForce GT 745M RAM: 8192 MB Distro: Fedora (Rawhide) DE: Awesome
Text User Interface (TUI) // Windows 8+ & Fedora 20+ Dualboot
Reply With Quote
  #4  
Old 1st October 2011, 03:40 PM
PabloTwo Online
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 6,190
linuxfirefox
Re: Start lxpanel at upper left corner?

Yes, install urxvt from Fedora repo using: yum install rxvt-unicode
urxvt allows for true transparent background if you are using a compositing manager that supports that. I use xcompmgr with Openbox (no LXDE) which does true transparency. True, xterm will not do transparent backgrounds.

---------- Post added at 10:40 AM ---------- Previous post was at 10:20 AM ----------

You can configure uxrvt from either command line options or, easier, from ~/.Xresources file. Here's my ~/.Xresources entries for urxvt:
Code:
BASH:~/-> cat .Xresources | grep URxvt
URxvt*title: urxvt
URxvt*depth: 32
URxvt*saveLines: 12000
URxvt*loginShell: true
URxvt*internalBorder: 3
URxvt*cursorColor: orange
URxvt*pointerColor: yellow
URxvt*foreground: WhiteSmoke
URxvt*background: rgba:0000/0000/0000/2222
URxvt*geometry: 140x50+110+60
URxvt*font: xft:Bitstream Vera Sans Mono:pixelsize=13
!URxvt*font: -*-courier-medium-r-normal-*-*-140-*-*-*-*-iso8859-1
!URxvt*boldFont: -*-courier-bold-r-normal-*-*-140-*-*-*-*-iso8859-1
URxvt*scrollBar: false
URxvt*scrollBar_right: false
URxvt*scrollstyle: rxvt
The line in bold sets the background color and transparency level.
Reply With Quote
  #5  
Old 1st October 2011, 03:53 PM
sea Offline
"Shells" (of a sub world)
 
Join Date: May 2011
Location: Confoederatio Helvetica (Swissh)
Age: 34
Posts: 3,483
linuxfedorafirefox
Re: Start lxpanel at upper left corner?

I've copy pasted your settings to ~/.Xresources as it didnt exists on my LXDE system.
I have just the same white backround as in xterm

Or would these changes only match if my system wasnt LXDE?

---------- Post added at 02:53 PM ---------- Previous post was at 02:49 PM ----------

Code:
urxvt -background rgba:0000/0000/0000/2222
Shows up with a black background, but no desktop-background shown.
__________________
Laptop: Toshiba satellite p50-a-11 CPU: Intel i7 8*2400 MHz GPU: GeForce GT 745M RAM: 8192 MB Distro: Fedora (Rawhide) DE: Awesome
Text User Interface (TUI) // Windows 8+ & Fedora 20+ Dualboot
Reply With Quote
  #6  
Old 1st October 2011, 04:12 PM
PabloTwo Online
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 6,190
linuxfirefox
Re: Start lxpanel at upper left corner?

What does LXDE use as it's compositing manager? Or does it even have one? Did you log out and back in of your session after creating the ~/.Xresources file?

---------- Post added at 11:00 AM ---------- Previous post was at 10:55 AM ----------

The settings for urxvt in the .Xresources file are valid for any DE you might be using. However, the transparency setting will only work if you are using a compositing manager that supports true transparency, not pseudo-transparency.

---------- Post added at 11:12 AM ---------- Previous post was at 11:00 AM ----------

Anytime you create/modify/edit your ~/.Xresources or ~/.Xdefaults file, you either have to log out and back in to your session to make the changes active, or, easier, just give the command:

xrdb -merge ~/.Xresources

And with URxvt*background: rgba:0000/0000/0000/2222
the background should be black, even if transparency isn't working.
Reply With Quote
  #7  
Old 1st October 2011, 04:16 PM
sea Offline
"Shells" (of a sub world)
 
Join Date: May 2011
Location: Confoederatio Helvetica (Swissh)
Age: 34
Posts: 3,483
linuxfedorafirefox
Re: Start lxpanel at upper left corner?

Dont know what compositing manager (if any) LXDE uses, all i know is that it uses openbox.
Ok after relog, it applied changes, however, transparency isnt one of them, just simple black.

I'd rather move the shell around, than miss the transperncy
__________________
Laptop: Toshiba satellite p50-a-11 CPU: Intel i7 8*2400 MHz GPU: GeForce GT 745M RAM: 8192 MB Distro: Fedora (Rawhide) DE: Awesome
Text User Interface (TUI) // Windows 8+ & Fedora 20+ Dualboot
Reply With Quote
  #8  
Old 1st October 2011, 04:18 PM
smr54 Offline
Registered User
 
Join Date: Jan 2010
Posts: 5,524
linuxchrome
Re: Start lxpanel at upper left corner?

LXDE uses openbox. You'll have to specify the x and y coordinates. (Sea, I mention it on the article I linked earlier.)

So something like, in the applications section of $HOME/.config/openbox/lxde-rc.xml

Code:
application name="gbuffy">
<decor>no</decor>
<layer>above</layer>
<position><x>0</x><y>0</y></position>
<desktop>all</desktop>
</application>
That's cut and pasted from an entry in my rc.xml--that layer and desktop thing just makes it appear on all desktops and always be on top. Decor just means no top frame. All those are probably unnecessary for your needs. You probably just want the name, getting that is also covered on that page I mentioned in the other thread.
Reply With Quote
  #9  
Old 1st October 2011, 04:26 PM
sea Offline
"Shells" (of a sub world)
 
Join Date: May 2011
Location: Confoederatio Helvetica (Swissh)
Age: 34
Posts: 3,483
linuxfedorafirefox
Re: Start lxpanel at upper left corner?

I was just looking the same, though i havent found any examples using <position> in lxde-rc.xml.
Yes roadrunner, but that was about a keybinding, not position of shell, allthough it seems to be thhe same file..

Well i did found soemthing with position, but that was inside the <dock> section.

---------- Post added at 03:26 PM ---------- Previous post was at 03:21 PM ----------

Yup, that was the proper place to look.
Thank you very much, both of you

PHP Code:
    <application title="sea Console">
      <
position><x>0</x><y>0</y></position>
      <
decor>no</decor>
      <
fullscreen>no</fullscreen>
      <
maximized>no</maximized>
      <
skip_taskbar>yes</skip_taskbar>
      <
skip_pager>yes</skip_pager>
      <
layer>below</layer>
    </
application
__________________
Laptop: Toshiba satellite p50-a-11 CPU: Intel i7 8*2400 MHz GPU: GeForce GT 745M RAM: 8192 MB Distro: Fedora (Rawhide) DE: Awesome
Text User Interface (TUI) // Windows 8+ & Fedora 20+ Dualboot

Last edited by sea; 1st October 2011 at 04:23 PM.
Reply With Quote
  #10  
Old 1st October 2011, 04:31 PM
PabloTwo Online
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 6,190
linuxfirefox
Re: Start lxpanel at upper left corner?

Then it would appear LXDE doesn't give you a compositing manager along with OpenBox. You could:
Code:
yum install xcompmgr
Then add to your ~/.config/openbox/autostart.sh file, the line:

(sleep 2 && xcompmgr -cCfF -r7 -o.65 -l-10 -t-8 -D4) &

Then restart your LXDE session and urxvt should show background transparency, unless something about LXDE itself interferes with xcompmgr.

Last edited by PabloTwo; 1st October 2011 at 06:41 PM.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mouse cursor starts in upper left corner in Fedora 15 ThubLives Using Fedora 1 22nd August 2011 12:02 AM
Four boxes in lower left corner? hrh1818 Using Fedora 2 20th April 2009 07:34 AM
All windows start beyond the upper left hand corner. keeler1 Using Fedora 6 24th April 2007 10:23 PM
gDesklets stuck in the upper right corner theturtlemoves Using Fedora 5 7th February 2006 04:17 PM
How to change the redhat icon in the lower left corner to something else ? Mr Tux Using Fedora 0 6th August 2005 06:44 PM


Current GMT-time: 03:10 (Wednesday, 22-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Hopatcong Photos - Johi Instagram Photos - Zhangjiagang Photos on Instagram