Fedora Linux Support Community & Resources Center
  #1  
Old 26th August 2011, 02:28 PM
rolfijn Offline
Registered User
 
Join Date: Jan 2009
Posts: 11
windows_7firefox
urxvt doesn't honour xdefaults?

Hello list,

I figured I'd try something else for a change and installed the i3 tiling windowmanager. It comes (in Fedora 15) bundled with the urxvt terminal. I would like to change the background color so I created a file ~/.Xdefaults and added the line:
Code:
urxvt*background: Red
However, after running...
Code:
xrdb -load ~/.Xdefaults
...and starting another urxvt terminal it's still white. I also tried:
  • putting rxvt*background: Red in .Xdefaults
  • putting xterm*background: Red in .Xdefaults
  • restarting X
  • changing other properties like urxvt*scrollbar: off
  • Using . instead off * (urxvt.background: Red)
  • Putting it in .Xresources and restart X

So far nothing has worked and urxvt doesn't change a bit! All the documentation I found regarding this issue state it should work. Hope someone can tell me what goes wrong here? I am really pulling my hairs out here...

Thanks in advance,
Rolf Deenen
Reply With Quote
  #2  
Old 26th August 2011, 02:44 PM
PabloTwo Online
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 6,190
linuxfirefox
Re: urxvt doesn't honour xdefaults?

I'm using F12. I occasionally use urxvt and have the X configuration for it set in ~/.Xresources. They work fine for me. After making any changes, I use the command "xrdb -merge ~/.Xresources", which also works for me. All my entries use "URxvt", not "rxvt" as in some examples you post (I don't know if that makes a difference or not).
Code:
URxvt*title: urxvt
URxvt*depth: 32
URxvt*saveLines: 12000
URxvt*loginShell: true
URxvt*internalBorder: 3
URxvt*cursorColor: orange
URxvt*pointerColor: yellow
URxvt*foreground: WhiteSmoke
URxvt*background: rgba:0000/0000/0000/2222
URxvt*geometry: 140x50+110+60
URxvt*font: xft:Bitstream Vera Sans Mono:pixelsize=13
!URxvt*font: -*-courier-medium-r-normal-*-*-140-*-*-*-*-iso8859-1
!URxvt*boldFont: -*-courier-bold-r-normal-*-*-140-*-*-*-*-iso8859-1
URxvt*scrollBar: false
URxvt*scrollBar_right: false
URxvt*scrollstyle: rxvt
I really don't have an answer for you, but hope my usage and example might bring you to a "break through" to your issue.
Reply With Quote
  #3  
Old 26th August 2011, 03:13 PM
rolfijn Offline
Registered User
 
Join Date: Jan 2009
Posts: 11
windows_7firefox
Re: urxvt doesn't honour xdefaults?

I have been trying some more and by accident discovered that it dows work when I startx from the commandline instead of starting x from the graphical login. The search continues...
Reply With Quote
  #4  
Old 26th August 2011, 03:17 PM
jpollard Offline
Registered User
 
Join Date: Aug 2009
Location: Waldorf, Maryland
Posts: 6,865
linuxfedorafirefox
Re: urxvt doesn't honour xdefaults?

I think there is a bug in the resource operation, or a bug in the configure options...

Using the default doesn't work. Neither does --enable-everything

The only thing that has worked is "rxvt -bg blue"

This hasn't been worked on since 2003, so the project appears dead.

I would suggest using xterm.
Reply With Quote
  #5  
Old 26th August 2011, 03:27 PM
PabloTwo Online
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 6,190
linuxfirefox
Re: urxvt doesn't honour xdefaults?

Did you install "rxvt" or "rxvt-unicode" ? I'm using rxvt-unicode.
Reply With Quote
  #6  
Old 26th August 2011, 03:29 PM
jpollard Offline
Registered User
 
Join Date: Aug 2009
Location: Waldorf, Maryland
Posts: 6,865
linuxfedorafirefox
Re: urxvt doesn't honour xdefaults?

I was testing rxvt...
Reply With Quote
  #7  
Old 26th August 2011, 03:41 PM
PabloTwo Online
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 6,190
linuxfirefox
Re: urxvt doesn't honour xdefaults?

That was directed at the OP, but no matter. I would imagine the command line parameters between rxvt and urxvt would be nearly identical, if not totally identical, but the issue I was sneaking up on was the program name entries in either .Xdefaults or .Xresources.

URxvt*whatever: something

wouldn't be valid if the OP was actually using rxvt instead of urxvt, the latter provided by package rxvt-unicode.
Reply With Quote
  #8  
Old 26th August 2011, 06:13 PM
RupertPupkin Offline
Registered User
 
Join Date: Nov 2006
Location: Detroit
Posts: 5,684
linuxfedorafirefox
Re: urxvt doesn't honour xdefaults?

PabloTwo's settings in ~/.Xdefaults work for me with urxvt in F15. Doing "xrdb -merge ~/.Xdefaults" was all I had to do after editing the file so that restarting X was not necessary.

By the way, the urxvt man page explains how all this works:

Code:
RESOURCES
       Note: `urxvt --help' gives a list of all resources (long options)
       compiled into your version. All resources are also available as long-
       options.

       You can set and change the resources using X11 tools like xrdb. Many
       distribution do also load settings from the ~/.Xresources file when X
       starts. urxvt will consult the following files/resources in order, with
       later settings overwriting earlier ones:

         1. app-defaults file in $XAPPLRESDIR
         2. $HOME/.Xdefaults
         3. RESOURCE_MANAGER property on root-window of screen 0
         4. SCREEN_RESOURCES property on root-window of the current screen
         5. $XENVIRONMENT file OR $HOME/.Xdefaults-<nodename>
         6. resources specified via -xrm on the commandline

       Note that when reading X resources, urxvt recognizes two class names:
       Rxvt and URxvt. The class name Rxvt allows resources common to both
       urxvt and the original rxvt to be easily configured, while the class
       name URxvt allows resources unique to urxvt, to be shared between
       different urxvt configurations.
__________________
OS: Fedora 20 x86_64 | Machine: HP Pavilion a6130n | CPU: AMD 64 X2 Dual-Core 5000+ 2.6GHz | RAM: 5GB PC5300 DDR2 | Disk: 400GB SATA | Video: ATI Radeon HD 4350 512MB | Sound: Realtek ALC888S | Ethernet: Realtek RTL8201N
Reply With Quote
  #9  
Old 29th August 2011, 10:14 AM
rolfijn Offline
Registered User
 
Join Date: Jan 2009
Posts: 11
windows_7firefox
Re: urxvt doesn't honour xdefaults?

Thanks for all the replies. I wanted to get urxvt running to see if I should use a tiling windowmanager and console based apps instead of a more conservative approach. Like I said (sort of) the urxvt settings (rxvt-unicode) do work as described in this thread and the manpage when I start an X-session from the terminal but not when I login through GDM. This meant that I could use a tiling windomanager and urxvt and try out how it works for me. After using it for some time this weekend I have decided that it's not for me. All the different and exotic configuration options give it a steep learning curve and I have not yet really noticed the benefits. Perhaps I should give it some more time, but I am afraid that at some point the solution will be insufficient for some tasks and am therefore reluctant to invest more time, when an excellent alternative (gnome3) is readily available.
Reply With Quote
  #10  
Old 29th August 2011, 12:21 PM
smr54 Online
Registered User
 
Join Date: Jan 2010
Posts: 5,524
linuxchrome
Re: urxvt doesn't honour xdefaults?

As an alternative, with less of a learning curve, you might try fluxbox or openbox. Both of those work with pytyle as well, if you want to use tiling. I have a fairly basic page at http://home.roadrunner.com/~computer.../fluxopen.html. Not sure if you just wanted something more basic, wanted to save resources, or were just curious.

For me, the big benefit of those two is being able to move terminals around with keystrokes. Though tiling window managers let you enlarge and shrink terminals, my own personal needs are more that of moving something around. I can always maximize with another predefined key shortcut.

Last edited by smr54; 29th August 2011 at 12:24 PM.
Reply With Quote
  #11  
Old 29th August 2011, 12:29 PM
jpollard Offline
Registered User
 
Join Date: Aug 2009
Location: Waldorf, Maryland
Posts: 6,865
linuxfedorafirefox
Re: urxvt doesn't honour xdefaults?

That is a bug in gdm then.
Reply With Quote
Reply

Tags
i3-windowmanager, urxvt, xdefaults, xresources

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Urxvt copy problem listar Using Fedora 3 3rd August 2011 10:49 AM
Yum/yumex does not honour architecture vpp Using Fedora 3 25th October 2009 04:58 PM
aterm .Xdefaults problem 19bab79 Using Fedora 0 19th August 2008 06:40 AM
Typing exit in urxvt freezes system scottro Fedora Focus 5 9th April 2008 07:46 PM


Current GMT-time: 22:24 (Wednesday, 22-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Karow Instagram Photos - Ratia Photos - Tuttlingen Travel Photos