Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Using Fedora
FedoraForum Search

Forgot Password? Join Us!

Using Fedora General support for current versions. Ask questions about Fedora and it's software that do not belong in any other forum.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 7th August 2011, 09:25 AM
gwynw Offline
Registered User
 
Join Date: Jun 2011
Location: Wellington, New Zealand
Posts: 40
linuxfirefox
external monitor won't work - both monitor and laptop screen black

Hi,

I am having problems getting my external monitor to work. When I plug in the monitor, both the laptop screen and the external monitor go black. When I unplug the monitor, the laptop screen works again.
When I startup with the external monitor plugged in, neither screen works or teh computer hangs or something.

I have had the external monitor going on a couple of occasions. I did manage to configure my monitors through System Settings > Display. I turned off the laptop monitor as I just want to use the external. But after rebooting, things didn't work.

I have a Thinkpad E420, Fedora 15
00:02.0 VGA compatible controller: Intel Corporation Device 0126 (rev 09)
01:00.0 VGA compatible controller: ATI Technologies Inc Device 6741 (no driver is installed for this)

If anyone can help me, I would really appreciate it

Gwyn
Reply With Quote
  #2  
Old 7th August 2011, 09:45 AM
flyingfsck Offline
Registered User
 
Join Date: Aug 2010
Location: Al Ain, UAE
Posts: 1,822
linuxfirefox
Re: external monitor won't work - both monitor and laptop screen black

Try plugging it in just before you log in.
Reply With Quote
  #3  
Old 7th August 2011, 08:38 PM
didier83 Offline
Registered User
 
Join Date: Nov 2010
Location: Carcès, France
Age: 59
Posts: 96
linuxfirefox
Re: external monitor won't work - both monitor and laptop screen black

I have a similar problem for which I have opened a bug report:
, but no solution now:

https://bugzilla.redhat.com/show_bug.cgi?id=723328
Reply With Quote
  #4  
Old 8th August 2011, 09:10 AM
gwynw Offline
Registered User
 
Join Date: Jun 2011
Location: Wellington, New Zealand
Posts: 40
linuxfirefox
Re: external monitor won't work - both monitor and laptop screen black

I tried plugging the monitor in before I logged in. (Actually, I normally log in automatically, so I logged out and then plugged in the monitor.) When logged out, both monitors work, but as soon as I am logged in, both monitors go black.

Why?
Reply With Quote
  #5  
Old 8th August 2011, 10:53 AM
flyingfsck Offline
Registered User
 
Join Date: Aug 2010
Location: Al Ain, UAE
Posts: 1,822
linuxfirefox
Re: external monitor won't work - both monitor and laptop screen black

That is why it is called Plug and Pray.

Ramadan kareem.
Reply With Quote
  #6  
Old 9th August 2011, 11:16 AM
gwynw Offline
Registered User
 
Join Date: Jun 2011
Location: Wellington, New Zealand
Posts: 40
linuxfirefox
Re: external monitor won't work - both monitor and laptop screen black

glug glug glug
Reply With Quote
  #7  
Old 9th August 2011, 11:25 AM
flyingfsck Offline
Registered User
 
Join Date: Aug 2010
Location: Al Ain, UAE
Posts: 1,822
linuxfirefox
Re: external monitor won't work - both monitor and laptop screen black

Howdy,

Since the PnP system doesn't work with your screens, you may have to configure things the hard way. That would likely entail creating a xorg.conf file to describe the two screens. You should probably also try different video drivers. The VESA driver almost always works, but there are one or two others with similar robustness.

The bottom line is that you need to go to the Xorg project web site and read the Wiki. I don't think that there is a simple solution to your problem. A black screen of death is always most painful to fix, since you cannot see what is going on.

Cheers,

F.
Reply With Quote
  #8  
Old 10th August 2011, 09:35 AM
gwynw Offline
Registered User
 
Join Date: Jun 2011
Location: Wellington, New Zealand
Posts: 40
linuxfirefox
Re: external monitor won't work - both monitor and laptop screen black

Thanks flyingfsck. I have had a bit of a look at the Xorg wiki. I managed to add a new VGA mode with xrandr, but plugging the monitor in still gave me black screens!!! And on restart, my new VGA mode had disappeared:

[gwyn@gwyn-E420 ~]$ xrandr
Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192
LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 309mm x 173mm
1366x768 60.1*+
1024x768 60.0
800x600 60.3 56.2
640x480 59.9
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)

I will look into the Xorg wiki further...

However, I actually found an old doc that tells me how to edit xorg.conf for my external monitor. I used it when I was running Ubuntu 9.10 on an old computer, even though there was no xorg.cong file in that Ubuntu distribution.

One question: If I create an xorg.conf file in Fedora 15 and then add the settings for my external monitor, will my laptop monitor keep working?

gwyn

Maybe I
Reply With Quote
  #9  
Old 10th August 2011, 09:48 AM
flyingfsck Offline
Registered User
 
Join Date: Aug 2010
Location: Al Ain, UAE
Posts: 1,822
linuxfirefox
Re: external monitor won't work - both monitor and laptop screen black

Howdy,

You should read the xorg man page. The command 'xorg -configure' will create the xorg.conf file for you, after which you can edit it. There are many other things you can do with the xorg utility.

BTW, since the screens come up black, you should install SSH Server. Then you can log in from another machine to experiment and restart X without having to do a full time wasting reboot.

Cheers,

F

Last edited by flyingfsck; 10th August 2011 at 09:54 AM.
Reply With Quote
  #10  
Old 13th August 2011, 12:11 AM
gwynw Offline
Registered User
 
Join Date: Jun 2011
Location: Wellington, New Zealand
Posts: 40
linuxfirefox
Re: external monitor won't work - both monitor and laptop screen black

I tried to create an xorg.conf.new file that I could then edit. But I just get stuck.

I got this:
[root@gwyn-E420 gwyn]# X -configure

Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.

The wiki has instructions for dealing with this fatal error here: http://www.x.org/wiki/FAQErrorMessag...fordisplay0.22

rm -rf /tmp/.X0-lock didn't get me anywhere.

I tried starting a second Xserver with this command: startx -- :1
I found myself logged into the gui as root. When I plugged in the external monitor, it worked. xrandr gave me this output:

[root@gwyn-E420 ~]# xrandr
Screen 0: minimum 320 x 200, current 2646 x 1024, maximum 8192 x 8192
LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 309mm x 173mm
1366x768 60.1*+
1024x768 60.0
800x600 60.3 56.2
640x480 59.9
VGA1 connected 1280x1024+1366+0 (normal left inverted right x axis y axis) 337mm x 270mm
1280x1024 60.0*+ 75.0
1024x768 75.1 75.0 70.1 60.0
832x624 74.6
800x600 72.2 75.0 60.3 56.2
640x480 72.8 75.0 66.7 60.0
720x400 70.1
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)

But when I logged back in as me, the external monitor doesn't work. Black screens.

My external monitor used to work until I changed settings in System Settings > Display. Something seems to have got stuffed up in the process.

Any ideas about how I can get 'X -configure' to work?
Reply With Quote
  #11  
Old 13th August 2011, 05:03 AM
flyingfsck Offline
Registered User
 
Join Date: Aug 2010
Location: Al Ain, UAE
Posts: 1,822
linuxfirefox
Re: external monitor won't work - both monitor and laptop screen black

# Xorg -configure

Read the Xorg man page.
Reply With Quote
  #12  
Old 13th August 2011, 08:12 AM
gwynw Offline
Registered User
 
Join Date: Jun 2011
Location: Wellington, New Zealand
Posts: 40
linuxfirefox
Re: external monitor won't work - both monitor and laptop screen black

flyingfsck, can you please tell me what you mean by the Xorg man page? Where is it? I have been reading http://wiki.x.org/wiki/Home

Xorg -configure just leads to fatal errors....


id: cannot find name for group ID 1000
[gwyn@gwyn-E420 ~]$ Xorg -configure
The '-configure' option can only be used by root.
[gwyn@gwyn-E420 ~]$ su
Password:
[root@gwyn-E420 gwyn]# Xorg -configure

Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.


Please consult the Fedora Project support
at http://wiki.x.org
for help.

[root@gwyn-E420 gwyn]# ps aux | grep `cat /tmp/.X0-lock`
root 2631 3.1 0.2 98976 10560 tty7 Ss+ 18:51 0:03 /usr/bin/Xorg :0 -br -verbose -auth /var/run/gdm/auth-for-gdm-6JriCo/database -nolisten tcp
root 3162 0.0 0.0 109104 832 pts/0 S+ 18:52 0:00 grep --color=auto 2631

[root@gwyn-E420 gwyn]# rm -rf /tmp/.X0-lock

[root@gwyn-E420 gwyn]# Xorg -configure
_XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running
Warning: Xalloc: requesting unpleasantly large amount of memory: 0 bytes.

Fatal server error:
Cannot establish any listening sockets - Make sure an X server isn't already running

Please consult the Fedora Project support
at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

[root@gwyn-E420 gwyn]#
Reply With Quote
  #13  
Old 13th August 2011, 01:45 PM
rinjo Offline
Registered User
 
Join Date: Dec 2010
Location: Bangalore, India
Age: 32
Posts: 56
linuxfirefox
Re: external monitor won't work - both monitor and laptop screen black

Hi,

I had similar issues while connecting external monitor to my laptop.
Check the details mentioned in the following post and try. It worked for me and I regularly use the external monitor without any issues.

http://forums.fedoraforum.org/showthread.php?t=256567
Reply With Quote
  #14  
Old 13th August 2011, 06:34 PM
flyingfsck Offline
Registered User
 
Join Date: Aug 2010
Location: Al Ain, UAE
Posts: 1,822
linuxfirefox
Re: external monitor won't work - both monitor and laptop screen black

Code:
# man Xorg
Xorg(1)                                                                Xorg(1)

NAME
       Xorg - X11R7 X server

SYNOPSIS
       Xorg [:display] [option ...]

DESCRIPTION
       Xorg  is a full featured X server that was originally designed for UNIX
       and UNIX-like operating systems running on Intel x86 hardware.  It  now
       runs on a wider range of hardware and OS platforms.

       This  work  was  derived  by  the  X.Org  Foundation  from  the XFree86
       Project's XFree86 4.4rc2 release.  The XFree86 release  was  originally
       derived from X386 1.2 by Thomas Roell which was contributed to X11R5 by
       Snitily Graphics Consulting Service.
Also here
http://www.x.org/archive/X11R6.8.0/doc/Xorg.1.html

Last edited by flyingfsck; 13th August 2011 at 06:36 PM.
Reply With Quote
  #15  
Old 15th August 2011, 08:56 AM
gwynw Offline
Registered User
 
Join Date: Jun 2011
Location: Wellington, New Zealand
Posts: 40
linuxfirefox
Re: external monitor won't work - both monitor and laptop screen black

Thanks for your help everyone. I seem to have things pretty much working now. I followed the second post in this thread:
http://www.fedoraforum.org/forum/sho...d.php?t=223934
See what I did below.

The only problem I still have is that I am unable to close the laptop lid without the monitors turning off. The computer doesn't seem to go into suspend. I used Gnome Tweak Tool to tell the laptop screen to go blank when the lid is closed. It just doesn't quite obey. Both screens go blank

Gwyn


To get external monitor to work, I did this with the external monitor unplugged:

[gwyn@gwyn-E420 ~]$ gtf 1280 1024 60

# 1280x1024 @ 60.00 Hz (GTF) hsync: 63.60 kHz; pclk: 108.88 MHz
Modeline "1280x1024_60.00" 108.88 1280 1360 1496 1712 1024 1025 1028 1060 -HSync +Vsync

[gwyn@gwyn-E420 ~]$ xrandr --newmode "1280x1024_60.00" 108.88 1280 1360 1496 1712 1024 1025 1028 1060 -HSync +Vsync

[gwyn@gwyn-E420 ~]$ xrandr
Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192
LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 309mm x 173mm
1366x768 60.1*+
1024x768 60.0
800x600 60.3 56.2
640x480 59.9
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
1280x1024_60.00 (0xbe) 108.9MHz
h: width 1280 start 1360 end 1496 total 1712 skew 0 clock 63.6KHz
v: height 1024 start 1025 end 1028 total 1060 clock 60.0Hz

[gwyn@gwyn-E420 ~]$ xrandr --addmode VGA1 "1280x1024_60.00"

[gwyn@gwyn-E420 ~]$ xrandr
Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192
LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 309mm x 173mm
1366x768 60.1*+
1024x768 60.0
800x600 60.3 56.2
640x480 59.9
VGA1 disconnected (normal left inverted right x axis y axis)
1280x1024_60.00 60.0
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
[gwyn@gwyn-E420 ~]$

I then plugged the monitor in. All worked. And I get more VGA modes:

[gwyn@gwyn-E420 ~]$ xrandr
...
VGA1 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 337mm x 270mm
1280x1024 60.0*+ 75.0
1024x768 75.1 75.0 70.1 60.0
832x624 74.6
800x600 72.2 75.0 60.3 56.2
640x480 72.8 75.0 66.7 60.0
720x400 70.1
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
External Monitor and Monitor of Laptop HyperCube Hardware & Laptops 0 7th June 2011 04:06 PM
Screen goes black in mplayer when connected to an extended external monitor anishjp Hardware & Laptops 3 2nd March 2011 02:52 PM
external monitor connected to laptop, half inch black border all around... lunar_mind Hardware & Laptops 2 1st August 2009 08:32 AM
External Monitor on 8.01 ATI 1300 Mobility Has Wrong Res/Big Black Bar vostok4 Using Fedora 1 13th February 2008 07:05 AM
Radeon: black external monitor mstolar Hardware & Laptops 0 15th August 2007 12:11 AM


Current GMT-time: 20:29 (Monday, 28-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat