Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Security and Privacy
FedoraForum Search

Forgot Password? Join Us!

Security and Privacy Sadly, malware, spyware, hackers and privacy threats abound in today's world. Let's be paranoid and secure our penguins, and slam the doors on privacy exploits.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 13th November 2004, 12:01 AM
TheBadger Offline
Registered User
 
Join Date: Jun 2004
Location: Ky USA
Age: 56
Posts: 34
Security Level disabled

After the updates today 11/12/04, my Security Level will no longer launch. One update was libselunix.?.? and I can't remember the other one. When I first restarted my mouse was gone, after a second reboot everything seemed to work except my security levels GUI. Is there a way to do this comand line? I have to turn my eth0 to trusted to use my network Windoz box.
Reply With Quote
  #2  
Old 13th November 2004, 01:13 AM
sayeeth Offline
Registered User
 
Join Date: Jul 2004
Location: Singapore
Age: 34
Posts: 661
I have the same problem. Here is the error message when I attempt to run system-config-securitylevel.
Code:
[sayeeth@flirt ~]$ system-config-securitylevel
Traceback (most recent call last):
  File "/usr/share/system-config-securitylevel/system-config-securitylevel.py",line 18, in ?
    app.stand_alone()
  File "/usr/share/system-config-securitylevel/securitylevel.py", line 427, in stand_alone
    self.selinuxPage = selinuxPage.selinuxPage()
  File "/usr/share/system-config-securitylevel/selinuxPage.py", line 329, in __init__
    self.refreshTunables(self.initialtype)
  File "/usr/share/system-config-securitylevel/selinuxPage.py", line 427, in refreshTunables
    self.loadBooleans()
  File "/usr/share/system-config-securitylevel/selinuxPage.py", line 418, in loadBooleans
    on=rec[3]=="1"
IndexError: list index out of range
[sayeeth@flirt ~]$
__________________
[sayeeth@somebody ~]$ kill bill
bash: kill: bill: arguments must be process or job IDs
Reply With Quote
  #3  
Old 13th November 2004, 03:05 PM
jcridge Offline
Registered User
 
Join Date: Nov 2004
Location: Maryland
Posts: 24
Unhappy

I'm getting the same thing here. Updated yesterday on 11/12/04 and now I receive the following errors when I run system-config-securitylevel as root.


Code:
[root@ridge-md-xp jcridge]# system-config-securitylevel
Traceback (most recent call last):
  File "/usr/share/system-config-securitylevel/system-config-securitylevel.py", line 18, in ?
    app.stand_alone()
  File "/usr/share/system-config-securitylevel/securitylevel.py", line 427, in stand_alone
    self.selinuxPage = selinuxPage.selinuxPage()
  File "/usr/share/system-config-securitylevel/selinuxPage.py", line 329, in __init__
    self.refreshTunables(self.initialtype)
  File "/usr/share/system-config-securitylevel/selinuxPage.py", line 427, in refreshTunables
    self.loadBooleans()
  File "/usr/share/system-config-securitylevel/selinuxPage.py", line 418, in loadBooleans
    on=rec[3]=="1"
IndexError: list index out of range

Now I'm wondering what security level my system is actually running at?

Any word when this might get corrected?
Reply With Quote
  #4  
Old 13th November 2004, 03:41 PM
jcridge Offline
Registered User
 
Join Date: Nov 2004
Location: Maryland
Posts: 24
Issue Entered Into Bugzilla

This issue has been entered into BUGZILLA at: https://bugzilla.redhat.com/bugzilla....cgi?id=139166
Reply With Quote
  #5  
Old 13th November 2004, 04:04 PM
sayeeth Offline
Registered User
 
Join Date: Jul 2004
Location: Singapore
Age: 34
Posts: 661
Quote:
Originally Posted by jcridge
This issue has been entered into BUGZILLA at: https://bugzilla.redhat.com/bugzilla....cgi?id=139166
Alright dude, thanks.
__________________
[sayeeth@somebody ~]$ kill bill
bash: kill: bill: arguments must be process or job IDs
Reply With Quote
  #6  
Old 13th November 2004, 04:32 PM
TheBadger Offline
Registered User
 
Join Date: Jun 2004
Location: Ky USA
Age: 56
Posts: 34
I found the system-config-securitylevel command and get the same error. I had set my eth0 to trusted to share with my Windoz box. I guess it's stuck there now. I( would like to regain control over my firewall and Selunix.
Is having the eth0 set to trusted a bad thing for the net? I use the net lots more than file sharing.
Reply With Quote
  #7  
Old 14th November 2004, 04:25 AM
k4dgw Offline
Registered User
 
Join Date: Jun 2004
Location: Virginia
Age: 53
Posts: 194
Apparently that issue has been marked as a duplicate of this one

https://bugzilla.redhat.com/bugzilla....cgi?id=139155

Still not sure what we are supposed to do to fix it. It appears they have another patch/update coming out with a fix. I tried googling around for the update in there at the bottom, but I could not find anything.

Dave
-=K4DGW=-
Reply With Quote
  #8  
Old 14th November 2004, 09:21 AM
yeauch Offline
Registered User
 
Join Date: Nov 2004
Posts: 17
Arghh... no wonder mine isn't working as well. I do get the same error messages as the above. Looking forward to see it fixed.
Reply With Quote
  #9  
Old 14th November 2004, 04:52 PM
RedFedora Offline
Registered User
 
Join Date: May 2004
Posts: 503
I performed the same updates, no problems here with the security level. I wonder why that is?
Reply With Quote
  #10  
Old 14th November 2004, 05:50 PM
jcridge Offline
Registered User
 
Join Date: Nov 2004
Location: Maryland
Posts: 24
Quote:
Originally Posted by RedFedora
I performed the same updates, no problems here with the security level. I wonder why that is?

Do you have SELinux enabled or disabled?
__________________
IBM T61 6457-4XU - Fedora Core 9
Registered Linux User #372440
Reply With Quote
  #11  
Old 15th November 2004, 01:26 PM
girtsch Offline
Registered User
 
Join Date: Nov 2004
Posts: 3
how is it possible to install this patch:

########### patch ####################
--- system-config-securitylevel/selinuxPage.py.orig 2004-11-13 11:31:08.321869987 +0000
+++ system-config-securitylevel/selinuxPage.py 2004-11-13 11:31:54.182987016 +0000
@@ -415,7 +415,7 @@ class selinuxPage:
for i in booleansList:
rec=i.split()
name=rec[0]
- on=rec[3]=="1"
+ on=rec[2]=="active"
self.modifiers.add(name,Boolean(name,on,self.boolc onf[self.getType()].has_key(name)))

def refreshTunables(self,type):
########### patch ####################

i am a bit a linux noob, can anyone tell me what to do?
thx
Reply With Quote
  #12  
Old 15th November 2004, 03:55 PM
girtsch Offline
Registered User
 
Join Date: Nov 2004
Posts: 3
ok it works now
Reply With Quote
  #13  
Old 15th November 2004, 04:34 PM
k4dgw Offline
Registered User
 
Join Date: Jun 2004
Location: Virginia
Age: 53
Posts: 194
What fixed it?

Dave
-=K4DGW=-
Reply With Quote
  #14  
Old 15th November 2004, 04:48 PM
PeTzZz Offline
Retired Community Manager
 
Join Date: Mar 2004
Location: Tartu
Posts: 1,550
I downgraded to an older version as he first suggested me there.
First I uninstalled libselinux-devel as it was needed:
Code:
#yum remove libselinux-devel
Then used command
Code:
#rpm --force -Uvh libselinux-1.17.14-1.i386.rpm
to downgrade to the older one. You have to be in the folder where the older rpm is to use that command. You can find it on the first Fedora cd. Then you should install libselinux-devel from the second or third cd.

Thats it. But you can also use that patch, but I don't know how to use it. I stay with the downgrade, I don't need more. There will be an update for this problem soon as I read there.

Last edited by PeTzZz; 15th November 2004 at 04:59 PM.
Reply With Quote
  #15  
Old 15th November 2004, 04:59 PM
djf_jeff Offline
Registered User
 
Join Date: Mar 2004
Location: Quebec
Posts: 78
You just need to modify /usr/share/system-config-securitylevel/selinuxPage.py at line 418 and replace

on=rec[3]=="1" by on=rec[2]=="active"
__________________
Jeff Saucier (djf_jeff)
Fedora profile
GPG : 0xA9E6E953
Reply With Quote
Reply

Tags
disabled, level, security

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Security Level won't take with gui Core1 can564 Security and Privacy 4 9th March 2006 01:13 AM
Security Level Problem Please Help. lxgamer Using Fedora 3 26th January 2006 10:33 PM
Security Level beny Security and Privacy 1 3rd January 2006 09:53 AM
Security level. Cerbz Using Fedora 4 15th June 2005 06:37 PM


Current GMT-time: 09:49 (Friday, 01-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat