Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Using Fedora
FedoraForum Search

Forgot Password? Join Us!

Using Fedora General support for current versions. Ask questions about Fedora and it's software that do not belong in any other forum.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 22nd July 2011, 01:38 AM
malkortechie Offline
Registered User
 
Join Date: Dec 2008
Posts: 7
linuxfirefox
Unhappy chkconfig sshd returns _nothing_ in new Fedora15 install


I've had no problems remoting into my fedora box before but, after a clean wipe and install of Fedora 15, I can't seem to catch a break.



I've tried to set up the service already, per Google'd howto's specific to F15, including turning off SELinux. When I have chkconfig list...

[root@icarus malkor]# chkconfig --list



I get...

Note: This output shows SysV services only and does not include native

systemd services. SysV configuration data might be overridden by native

systemd configuration.



abrt-ccpp 0:off 1:off 2:off 3:on 4:off 5:on 6:off

abrt-oops 0:off 1:off 2:off 3:on 4:off 5:on 6:off

auditd 0:off 1:off 2:on 3:on 4:on 5:on 6:off

backuppc 0:off 1:off 2:off 3:off 4:off 5:off 6:off

btseed 0:off 1:off 2:off 3:off 4:off 5:off 6:off

bttrack 0:off 1:off 2:off 3:off 4:off 5:off 6:off

cgconfig 0:off 1:off 2:on 3:on 4:on 5:on 6:off

cgred 0:off 1:off 2:off 3:off 4:off 5:off 6:off

cpuspeed 0:off 1:on 2:on 3:on 4:on 5:on 6:off

cups 0:off 1:off 2:on 3:on 4:on 5:on 6:off

dnsmasq 0:off 1:off 2:off 3:off 4:off 5:off 6:off

ebtables 0:off 1:off 2:off 3:off 4:off 5:off 6:off

firstboot 0:off 1:off 2:off 3:off 4:off 5:off 6:off

gfs2 0:off 1:off 2:off 3:off 4:off 5:off 6:off

gpsd 0:off 1:off 2:off 3:off 4:off 5:off 6:off

hddtemp 0:off 1:off 2:off 3:off 4:off 5:off 6:off

httpd 0:off 1:off 2:off 3:off 4:off 5:off 6:off

ip6tables 0:off 1:off 2:on 3:on 4:on 5:on 6:off

ipsec 0:off 1:off 2:off 3:off 4:off 5:off 6:off

iptables 0:off 1:off 2:on 3:on 4:on 5:on 6:off

irda 0:off 1:off 2:off 3:off 4:off 5:off 6:off

iscsi 0:off 1:off 2:off 3:on 4:on 5:on 6:off

iscsid 0:off 1:off 2:off 3:on 4:on 5:on 6:off

ksm 0:off 1:off 2:off 3:on 4:on 5:on 6:off

ksmtuned 0:off 1:off 2:off 3:on 4:on 5:on 6:off

libvirt-guests 0:off 1:off 2:on 3:on 4:on 5:on 6:off

libvirtd 0:off 1:off 2:off 3:on 4:on 5:on 6:off

lirc 0:off 1:off 2:off 3:off 4:off 5:off 6:off

lvm2-monitor 0:off 1:on 2:on 3:on 4:on 5:on 6:off

mdmonitor 0:off 1:off 2:on 3:on 4:on 5:on 6:off

multipathd 0:off 1:off 2:off 3:off 4:off 5:off 6:off

mysqld 0:off 1:off 2:off 3:off 4:off 5:off 6:off

netconsole 0:off 1:off 2:off 3:off 4:off 5:off 6:off

netfs 0:off 1:off 2:off 3:on 4:on 5:on 6:off

network 0:off 1:off 2:off 3:off 4:off 5:off 6:off

nfs 0:off 1:off 2:off 3:off 4:off 5:off 6:off

nfslock 0:off 1:off 2:off 3:on 4:on 5:on 6:off

openvpn 0:off 1:off 2:off 3:off 4:off 5:off 6:off

pcscd 0:off 1:off 2:on 3:on 4:on 5:on 6:off

portreserve 0:off 1:off 2:on 3:on 4:on 5:on 6:off

psacct 0:off 1:off 2:off 3:off 4:off 5:off 6:off

rpcbind 0:off 1:off 2:on 3:on 4:on 5:on 6:off

rpcgssd 0:off 1:off 2:off 3:on 4:on 5:on 6:off

rpcidmapd 0:off 1:off 2:off 3:on 4:on 5:on 6:off

rpcsvcgssd 0:off 1:off 2:off 3:off 4:off 5:off 6:off

sandbox 0:off 1:off 2:off 3:off 4:off 5:on 6:off

saslauthd 0:off 1:off 2:off 3:off 4:off 5:off 6:off

sendmail 0:off 1:off 2:on 3:on 4:on 5:on 6:off

smolt 0:off 1:off 2:on 3:on 4:on 5:on 6:off

snmpd 0:off 1:off 2:off 3:off 4:off 5:off 6:off

snmptrapd 0:off 1:off 2:off 3:off 4:off 5:off 6:off

speech-dispatcherd 0:off 1:off 2:off 3:off 4:off 5:off 6:off

sshd 0:off 1:on 2:on 3:on 4:on 5:on 6:off

wpa_supplicant 0:off 1:off 2:off 3:off 4:off 5:off 6:off

xinetd 0:off 1:off 2:off 3:on 4:on 5:on 6:off

ypbind 0:off 1:off 2:off 3:off 4:off 5:off 6:off

zvbid 0:off 1:off 2:off 3:off 4:off 5:off 6:off



xinetd based services:

chargen-dgram: off

chargen-stream: off

daytime-dgram: off

daytime-stream: off

discard-dgram: off

discard-stream: off

echo-dgram: off

echo-stream: off

rsync: off

tcpmux-server: off

tftp: off

time-dgram: off

time-stream: off





Also did...

[root@icarus etc]# chkconfig --list sshd



Note: This output shows SysV services only and does not include native

systemd services. SysV configuration data might be overridden by native

systemd configuration.



sshd 0:off 1:on 2:on 3:on 4:on 5:on 6:off





...so SSH is listed, and I'm in my normal runlevel: multiuser w/ KDE. After checking the man page for chkconfig, I tried...

[root@icarus malkor]# chkconfig ssh





...which returned nothing.



I then tried...

[root@icarus malkor]# chkconfig /etc/init.d/sshd



...and, to make sure I was using the correct one, I did ...

[root@icarus malkor]# which sshd

/usr/sbin/sshd





Wheh I tried with that full-path-filename, however, I got the same result...

[root@icarus malkor]# chkconfig /usr/sbin/sshd





When I 'ls -l' each copy of ssh, I got...

-rwxr-xr-x. 1 root root 4600 Jul 14 08:05 /etc/init.d/sshd

-rwxr-xr-x. 1 root root 548648 Jul 14 08:05 /usr/sbin/sshd





...so neither is a link: both appear to be executable and the script in init.d _does_ point to the actual program in /usr/sbin.



I then tried...

[root@icarus malkor]# service sshd status



...which got me.

sshd.service - LSB: Start up the OpenSSH server daemon

Loaded: loaded (/etc/rc.d/init.d/sshd)

Active: active (exited) since Wed, 20 Jul 2011 20:06:58 -0500; 9h ago

Process: 954 ExecStart=/etc/rc.d/init.d/sshd start (code=exited, status=0/SUCCESS)

Main PID: 1084 (code=exited, status=255)

CGroup: name=systemd:/system/sshd.service




I tried to Google 'service sshd status' to find out what I _should_ see, but all I found were error-reports. I could find no good, current examplar.





Checked a couple of other things...

[root@icarus etc]# ps -ef | grep ssh

malkor 1467 1338 0 Jul20 ? 00:00:00 /usr/bin/ssh-agent /etc/X11/xinit/Xclients

root 8140 2457 0 06:48 pts/0 00:00:00 grep --color=auto ssh

[root@icarus malkor]#

[root@icarus malkor]# service sshd status

sshd.service - LSB: Start up the OpenSSH server daemon

Loaded: loaded (/etc/rc.d/init.d/sshd)

Active: active (exited) since Wed, 20 Jul 2011 20:06:58 -0500; 9h ago

Process: 954 ExecStart=/etc/rc.d/init.d/sshd start (code=exited, status=0/SUCCESS)

Main PID: 1084 (code=exited, status=255)

CGroup: name=systemd:/system/sshd.service







Read a few more 'man' pages and tried...

[root@icarus malkor]# chkconfig ssh on

error reading information on service ssh: No such file or directory



And, finally, I can't even ssh into my own localhost.



I'll provide whatever else is needed: I'm just spun round right now and don't know what to do next. Thanks for the help!



Reply With Quote
  #2  
Old 22nd July 2011, 01:51 AM
jpollard Online
Registered User
 
Join Date: Aug 2009
Location: Waldorf, Maryland
Posts: 6,660
linuxfedorafirefox
Re: chkconfig sshd returns _nothing_ in new Fedora15 install

I think you are looking in the wrong place.

sshd is started by systemd, and I think it has taken over what chkconfig used to do.

I believe your problem is actually in the sshd configuration.

SELinux has worked with sshd for quite some time, and has no problem in F15 either.
Reply With Quote
  #3  
Old 22nd July 2011, 01:57 AM
scott32746 Offline
Registered User
 
Join Date: Jun 2007
Location: Lake Mary, Florida
Age: 49
Posts: 1,088
windows_xp_2003firefox
Re: chkconfig sshd returns _nothing_ in new Fedora15 install

Hello,

What is the error you are getting ?
Have you looked in / var/log/secure or dmesg ?
You said you disable SElinux did you reboot after ?
check firewall ?
Reply With Quote
  #4  
Old 22nd July 2011, 02:50 AM
stevea Online
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,552
linuxfedorafirefox
Re: chkconfig sshd returns _nothing_ in new Fedora15 install

***PLEASE*** don't use the horrible big dbl spaced font - hard to read ***


I don't see any issue w/ your chkconfig commands.
You should do
sudo chkconfig sshd on
service sshd start


Yes these still work w/ systemd.

If the sshd service is still not running you cold check the logs - or try this ...

sudo /usr/sbin/sshd -Dddd

You'll get diagnostics in the screen - probably telling what is failing.
My hunch is bad permissions on some config file you editted/created.

Also - use netstat to see what is listening on port 22
Quote:
[stevea@lycoperdon ~]$ sudo netstat -ntpl | grep 22
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 10623/sshd
tcp 0 0 :::22 :::* LISTEN 10623/sshd
__________________
None are more hopelessly enslaved than those who falsely believe they are free.
Johann Wolfgang von Goethe
Reply With Quote
  #5  
Old 22nd July 2011, 03:19 AM
marko Online
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 5,898
linuxfirefox
Re: chkconfig sshd returns _nothing_ in new Fedora15 install

Quote:
Originally Posted by jpollard View Post
I think you are looking in the wrong place.

sshd is started by systemd, and I think it has taken over what chkconfig used to do.

I believe your problem is actually in the sshd configuration.

SELinux has worked with sshd for quite some time, and has no problem in F15 either.
That's ok to use chkconfig still, if chkconfig refers to a service than it will correctly forward changes you make in chkconfig to systemd
Reply With Quote
  #6  
Old 30th July 2011, 02:54 PM
malkortechie Offline
Registered User
 
Join Date: Dec 2008
Posts: 7
linuxfirefox
Talking Re: chkconfig sshd returns _nothing_ in new Fedora15 install

Okay, doing '/usr/sbin/sshd -Dddd' as root got me...

debug2: load_server_config: filename /etc/ssh/sshd_config
debug2: load_server_config: done config len = 569
debug2: parse_server_config: config /etc/ssh/sshd_config len 569
debug3: /etc/ssh/sshd_config:13 setting Port 484
debug3: /etc/ssh/sshd_config:19 setting Protocol 2
debug3: /etc/ssh/sshd_config:34 setting SyslogFacility AUTHPRIV
debug3: /etc/ssh/sshd_config:64 setting PasswordAuthentication yes
debug3: /etc/ssh/sshd_config:68 setting ChallengeResponseAuthentication no
debug3: /etc/ssh/sshd_config:79 setting GSSAPIAuthentication yes
debug3: /etc/ssh/sshd_config:81 setting GSSAPICleanupCredentials yes
debug3: /etc/ssh/sshd_config:95 setting UsePAM yes
debug3: /etc/ssh/sshd_config:98 setting AcceptEnv LANG LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE LC_MONETARY LC_MESSAGES
debug3: /etc/ssh/sshd_config:99 setting AcceptEnv LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE LC_MEASUREMENT
debug3: /etc/ssh/sshd_config:100 setting AcceptEnv LC_IDENTIFICATION LC_ALL LANGUAGE
debug3: /etc/ssh/sshd_config:101 setting AcceptEnv XMODIFIERS
debug3: /etc/ssh/sshd_config:107 setting X11Forwarding yes
debug3: /etc/ssh/sshd_config:130 setting Subsystem sftp /usr/libexec/openssh/sftp-server
debug1: sshd version OpenSSH_5.6p1
debug3: Not a RSA1 key file /etc/ssh/ssh_host_rsa_key.
debug1: read PEM private key done: type RSA
debug1: private host key: #0 type 1 RSA
debug3: Not a RSA1 key file /etc/ssh/ssh_host_dsa_key.
debug1: read PEM private key done: type DSA
debug1: private host key: #1 type 2 DSA
debug1: rexec_argv[0]='/usr/sbin/sshd'
debug1: rexec_argv[1]='-Dddd'
debug3: oom_adjust_setup
Set /proc/self/oom_adj from 0 to -17
debug2: fd 3 setting O_NONBLOCK
debug1: Bind to port 484 on 0.0.0.0.
Bind to port 484 on 0.0.0.0 failed: Address already in use.
debug2: fd 3 setting O_NONBLOCK
debug3: sock_set_v6only: set socket 3 IPV6_V6ONLY
debug1: Bind to port 484 on ::.
Bind to port 484 on :: failed: Address already in use.
Cannot bind any address.


changed the port to 22, and now it works.

I wanted to use a port other than 22 for security: now to figure out what is listening at port 484! Thanks for the help!
Reply With Quote
Reply

Tags
chkconfig, fedora 15, selinux, service, ssh

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to install fedora15 without internet? toulunta Installation, Upgrades and Live Media 3 30th June 2011 02:24 AM
Starting sshd: /etc/init.d/sshd: line 113: /usr/sbin/sshd: Permission denied sumanc Using Fedora 9 28th March 2008 06:37 AM
yum install chkconfig namit Installation, Upgrades and Live Media 4 26th February 2007 11:24 AM
how to install chkconfig pliu59 Using Fedora 2 3rd November 2005 01:53 AM
install FC3-64 from cd returns blank screen Kaya Saman Installation, Upgrades and Live Media 6 20th December 2004 04:05 PM


Current GMT-time: 05:33 (Friday, 18-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat