Fedora Linux Support Community & Resources Center
  #1  
Old 16th July 2011, 01:52 AM
Blast Ang3L Offline
Registered User
 
Join Date: May 2011
Location: Backwoods, Kentucky
Posts: 20
linuxopera
Unhappy SOLVED: When YUM acts evil...

Hi Friends,

I looked on this forum and found similar posts. I even did a Google search and did all the suggestions from previous post. Nada. Zilch. Goose Eggs.

I know this has been posted before yet none of the yum commands are fixing this problem.

I am running XFCE Fedora 15.

I tried to update today only to be met with a message:

Error: Cannot retrieve metalink for repository: fedora. Please verify its path and try again

I did some more digging and found this too:

yum.Errors.RepoError: Cannot retrieve repository metadata (repomd.xml) for repository: fedora. Please verify its path and try again

and this:

libpanelappletmm-2.26.0-2.fc12.i686 has missing requires of libpanel-applet-2.so.0

I have tried yum clean all, I've rebuilded the DB, I have tried to get an update. Nothing.

For Fedora sake, I even tried to go to the Repo folder and try to delete the repos there. Nothing.

Please, for the love of everything good and descent, help!!!

Last edited by Blast Ang3L; 17th July 2011 at 08:30 PM. Reason: Change to Solved
Reply With Quote
  #2  
Old 16th July 2011, 02:42 AM
stoat Offline
Registered User
 
Join Date: Jun 2006
Posts: 7,550
linuxfirefox
Re: When YUM acts evil...

Well, I guess you put those repo files back where they were. Yum will never work without those. Anyway, an easy thing to try is to enter DNS nameserver IP addresses in NetworkManager. I have to do that for yum and wget. If you want to try that idea, you can use OpenDNS's IP addresses and instructions. The steps are for Ubuntu, but it's exactly the same for Fedora (ignore step #8).
https://store.opendns.com/setup/operatingsystem/ubuntu
Reply With Quote
  #3  
Old 16th July 2011, 02:54 AM
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 6,068
linuxfirefox
Re: When YUM acts evil...

@stoat

But wouldn't a total failure of DNS mean no internet at all would work? Why is yum so specially afflicted with this DNS problem?
Reply With Quote
  #4  
Old 16th July 2011, 03:54 AM
stoat Offline
Registered User
 
Join Date: Jun 2006
Posts: 7,550
linuxfedorafirefox
Re: When YUM acts evil...

I guess so, but I didn't remember it happening that way. Maybe something like the DNS cache of my router caused a particular sequence of events to make me think about it that way. I never bothered with it again. Just now, I removed the nameserver IP addresses from that IPv4 Settings tab in NetworkManager and it affected everything.
Reply With Quote
  #5  
Old 16th July 2011, 06:16 PM
nirik Offline
Community Manager
 
Join Date: Mar 2009
Location: Broomfield, CO
Posts: 436
macosmidori
Re: When YUM acts evil...

This is a machine you upgraded from a previous release?

yum remove libpanelappletmm

This package was removed in f15, and is no longer shipped or works.
Remove it and that should fix up that part of your issue.

As for the dns/other issues, do:

URLGRABBER_DEBUG=1 yum update

and look at the output. It will tell you if it can't resolve the mirror manager hostname or can't download from a mirror or what.
Reply With Quote
  #6  
Old 16th July 2011, 10:53 PM
Blast Ang3L Offline
Registered User
 
Join Date: May 2011
Location: Backwoods, Kentucky
Posts: 20
linuxopera
Re: When YUM acts evil...

@ Nirik:

I tried the remove libpanel and I still get an error message:

Error: Cannot retrieve repository metadata (repomd.xml) for repository: fedora. Please verify its path and try again
You could try using --skip-broken to work around the problem
Reply With Quote
  #7  
Old 16th July 2011, 11:45 PM
nirik Offline
Community Manager
 
Join Date: Mar 2009
Location: Broomfield, CO
Posts: 436
macosmidori
Re: When YUM acts evil...

Thats back to the other issue.
Solve that first... try the URLGRABBER_DEBUG line...
Reply With Quote
  #8  
Old 17th July 2011, 01:48 AM
Blast Ang3L Offline
Registered User
 
Join Date: May 2011
Location: Backwoods, Kentucky
Posts: 20
linuxopera
Re: When YUM acts evil...

First of all, thanks Nirik for your help as well as others.

To answer your question before:

This is a machine you upgraded from a previous release?

Answer: Yes.

I tried the URL command and got this feedback from this command:

2011-07-16 20:47:57,763 attempt 1/10: https://mirrors.fedoraproject.org/me...a-15&arch=i386
INFO:urlgrabber:attempt 1/10: https://mirrors.fedoraproject.org/me...a-15&arch=i386
2011-07-16 20:47:57,767 opening local file "/var/cache/yum/i386/15/fedora/metalink.xml.tmp" with mode wb
INFO:urlgrabber:opening local file "/var/cache/yum/i386/15/fedora/metalink.xml.tmp" with mode wb
* Could not resolve host: mirrors.fedoraproject.org; Cannot allocate memory
* Closing connection #0
* Couldn't resolve host name
2011-07-16 20:47:58,419 exception: [Errno 14] curl#6 - "Couldn't resolve host"
INFO:urlgrabber:exception: [Errno 14] curl#6 - "Couldn't resolve host"
2011-07-16 20:47:58,421 retrycode (14) not in list [-1, 2, 4, 5, 6, 7], re-raising
INFO:urlgrabber:retrycode (14) not in list [-1, 2, 4, 5, 6, 7], re-raising
Error: Cannot retrieve metalink for repository: fedora. Please verify its path and try again

Reply With Quote
  #9  
Old 17th July 2011, 02:19 AM
nirik Offline
Community Manager
 
Join Date: Mar 2009
Location: Broomfield, CO
Posts: 436
macosmidori
Re: When YUM acts evil...

ok, the key here is:

Couldn't resolve host name

If you add 'nameserver 8.8.8.8' to the top of /etc/resolv.conf does it start working?
Reply With Quote
  #10  
Old 17th July 2011, 03:10 AM
Blast Ang3L Offline
Registered User
 
Join Date: May 2011
Location: Backwoods, Kentucky
Posts: 20
linuxopera
Re: When YUM acts evil...

How do I do this?
Reply With Quote
  #11  
Old 17th July 2011, 05:11 PM
nirik Offline
Community Manager
 
Join Date: Mar 2009
Location: Broomfield, CO
Posts: 436
macosmidori
Re: When YUM acts evil...

su -c 'nano /etc/resolv.conf'

and add 'nameserver 8.8.8.8' to the top.

You could also right click on the nm-applet, edit connections, select the connection, edit, change 'dhcp' to 'dhcp address only' and enter 8.8.8.8 into the nameserver field.
Reply With Quote
  #12  
Old 17th July 2011, 05:28 PM
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 6,068
linuxfirefox
Re: When YUM acts evil...

I'd prefer nirik's second option, that would retain your change in the permanent nm-applet configuration. If you just edit the /etc/resolv.conf directly, networkmanager will just overwrite it the next time it wants to (which is why the top of that file says "Generated by NetworkManager" as a warning) and your change would be gone.
Reply With Quote
  #13  
Old 17th July 2011, 07:49 PM
Blast Ang3L Offline
Registered User
 
Join Date: May 2011
Location: Backwoods, Kentucky
Posts: 20
linuxopera
Talking Re: When YUM acts evil...

Quote:
Originally Posted by nirik View Post
su -c 'nano /etc/resolv.conf'

and add 'nameserver 8.8.8.8' to the top.

You could also right click on the nm-applet, edit connections, select the connection, edit, change 'dhcp' to 'dhcp address only' and enter 8.8.8.8 into the nameserver field.
***DOES THE HAPPY DANCE!!!***

THANK YOU, THANK YOU, THANK YOU!

Reply With Quote
  #14  
Old 17th July 2011, 10:19 PM
stoat Offline
Registered User
 
Join Date: Jun 2006
Posts: 7,550
linuxfirefox
Re: When YUM acts evil...

Very well.

Since that was the same thing I suggested way back in post #2 except with a different nameserver (OpenDNS's instead of Google's), I wonder if you would take a moment to clear up a couple of issues (for the record and for my understanding). One is did you ever even try OpenDNS nameservers (because it shouldn't matter)? And the other is did this problem affect only yum and not your browser (because I claimed earlier that it is possible and was challenged)?

P.S.: Here is another example of Firefox-works-yum-doesn't that was fixed by a DNS nameserver...
http://forums.fedoraforum.org/showthread.php?t=267115
So I kinda stick to my original story where I said I remember Firefox working but yum wouldn't until I added DNS nameservers into NetworkManager.
Reply With Quote
  #15  
Old 18th July 2011, 02:14 AM
Blast Ang3L Offline
Registered User
 
Join Date: May 2011
Location: Backwoods, Kentucky
Posts: 20
linuxfirefox
Re: When YUM acts evil...

Hi Stoat,

My apologies for not trying your suggestion. I did not fully understand what you wanted me to do (aka Newbie).

All I know is that when I tried the suggestion by nirik, the updates were able to be made with no problems or error messages.

Any and all help in further education in DNS and the like is definitely appreciated.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
F11 udev acts completely broken jhhadc Using Fedora 11 18th August 2009 03:22 AM
Firefox acts as though Flash is not installed when clearly it is ajamison Using Fedora 19 19th August 2008 07:07 PM
NIC Acts up after Motherboard Swap Pharoz Hardware & Laptops 3 22nd April 2008 09:48 PM
Yum used to work, now it acts bizzaro Master_Kato Using Fedora 9 28th July 2005 11:37 PM
FC4 - Syslog acts weird Venzent Using Fedora 2 21st July 2005 07:49 AM


Current GMT-time: 10:29 (Saturday, 01-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Teresina Instagram Photos - Pasaia - Pelotas Travel Photos