Fedora Linux Support Community & Resources Center
  #1  
Old 30th June 2011, 08:40 AM
naticus Offline
Registered User
 
Join Date: Jun 2011
Posts: 7
linuxfirefox
Fedora 15 cut battery life in half!

So I just installed F15 and I really like it. I had to upgradde to kernel version 2.6.39.1 to get my wireless from disconnecting -- aparentlyey it is a bug in kernels 2.6.38.x .

Now my problem, and it was also a problem with kernel 2.6.38.x, is that my battery life on my netbook (gateway LT2320, atom n450 @1.6, gma 3150, 1gb ram, 1024x600) is cut by half. I used to get 7-8 hours of battery life, with Crunchbang, Ubuntu, etc., but now i get 4.5 hours.

I have read that this is a problem with the current kernels available after 2.6.37.x.

My question is have they found a fix? Are we going to have to wait for 2.6.31? How much longer until that kernel is in the fedora repositories?

Thanks in advance!
Reply With Quote
  #2  
Old 30th June 2011, 01:57 PM
xjonquilx Offline
Registered User
 
Join Date: Jun 2011
Location: Florida
Posts: 131
linuxopera
Re: Fedora 15 cut battery life in half!

Yes, a fix has been found! Unfortunately I don't know how to accomplish this myself, but the following article describes the fix: http://www.linuxfordevices.com/c/a/N...around/?kc=rss
Reply With Quote
  #3  
Old 30th June 2011, 02:14 PM
naticus Offline
Registered User
 
Join Date: Jun 2011
Posts: 7
linuxchrome
Re: Fedora 15 cut battery life in half!

I checked my policy and it was set to "powersave" but I beleive it needs to be on default. Not sure if I want to mess with this as it might make the system unresponsive.

how to check:

sys/module/pcie_aspm/parameters/policy
Reply With Quote
  #4  
Old 30th June 2011, 02:18 PM
stevea Offline
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,696
linuxfedorafirefox
Re: Fedora 15 cut battery life in half!

According to Phoronix ....
Quote:
add "pcie_aspm=force" to their boot command line
This would go in the /boot/grub/grub.conf file, appended the the kernel line(s).

Phoronix has been spreading their typical alarmist-headlines + low-on-facts FUD about this problem for months. It is NOT a general problem AFAICT. It appears to be relate to a BIOS bug *some* systems.

In tests my Lenovo T510 is using slightly LESS power with 2.6.39.
__________________
None are more hopelessly enslaved than those who falsely believe they are free.
Johann Wolfgang von Goethe
Reply With Quote
  #5  
Old 30th June 2011, 02:44 PM
weitjong Online
Registered User
 
Join Date: Oct 2006
Location: Singapore, 新加坡
Posts: 936
linuxfirefox
Re: Fedora 15 cut battery life in half!

The Linux kernel power regression has been reported quite sometimes ago in Phoronix. Why not get the updates and possibly workaround directly from the source http://www.phoronix.com. Accurate or not, the NoScript plugin in my FF somehow does not *like* the site provided by URL above in the #2 post.

The way I understand it, the problem is with the Linux Kernel and although one of the culprit has been found, it seems it will still take some more time for the whole regression issue to be resolved and for the changes to propagate from upstream to Fedora Project, assuming the kernel developer will back port the fix at all.

In the latest Phoronix update on this issue, Larabel has provided a simple workaround by adding an option in the kernel option in the grub.conf. "pcie_aspm=force", but please read the article first. It is an interesting read.

---------- Post added at 09:44 PM ---------- Previous post was at 09:41 PM ----------

It looks like stevea beat me to it .
__________________
YaoWT - Leave no window unbroken ♪ (^。^) 
Reply With Quote
  #6  
Old 30th June 2011, 02:55 PM
naticus Offline
Registered User
 
Join Date: Jun 2011
Posts: 7
linuxchrome
Re: Fedora 15 cut battery life in half!

Quote:
Originally Posted by weitjong View Post
The Linux kernel power regression has been reported quite sometimes ago in Phoronix. Why not get the updates and possibly workaround directly from the source http://www.phoronix.com. Accurate or not, the NoScript plugin in my FF somehow does not *like* the site provided by URL above in the #2 post.

The way I understand it, the problem is with the Linux Kernel and although one of the culprit has been found, it seems it will still take some more time for the whole regression issue to be resolved and for the changes to propagate from upstream to Fedora Project, assuming the kernel developer will back port the fix at all.

In the latest Phoronix update on this issue, Larabel has provided a simple workaround by adding an option in the kernel option in the grub.conf. "pcie_aspm=force", but please read the article first. It is an interesting read.

---------- Post added at 09:44 PM ---------- Previous post was at 09:41 PM ----------

It looks like stevea beat me to it .
Logged in as root ( su --login) then I go to the file mentioned above and try to edit, but it says "I dont have permission necessary to open the file"

Is their another form of root I need to log into?
Reply With Quote
  #7  
Old 30th June 2011, 03:33 PM
xjonquilx Offline
Registered User
 
Join Date: Jun 2011
Location: Florida
Posts: 131
linuxopera
Re: Fedora 15 cut battery life in half!

Quote:
Originally Posted by stevea View Post
According to Phoronix ....

This would go in the /boot/grub/grub.conf file, appended the the kernel line(s).

Phoronix has been spreading their typical alarmist-headlines + low-on-facts FUD about this problem for months. It is NOT a general problem AFAICT. It appears to be relate to a BIOS bug *some* systems.

In tests my Lenovo T510 is using slightly LESS power with 2.6.39.
Thank you, I suspected it was Grub but wasn't sure.

---------- Post added at 10:33 AM ---------- Previous post was at 10:30 AM ----------

Quote:
Originally Posted by naticus View Post
Logged in as root ( su --login) then I go to the file mentioned above and try to edit, but it says "I dont have permission necessary to open the file"

Is their another form of root I need to log into?
Just log in to your regular user account and copy/paste the following in to Terminal:

Code:
sudo gedit /etc/grub.conf
It will ask for a password first, so type in your regular user password and press Enter. Gedit should pop up with the configuration without any issues. If you have problems, try this:

Code:
su
Type in the root password, then:

Code:
gedit /etc/grub.conf
I hope this helps!
Reply With Quote
  #8  
Old 30th June 2011, 04:07 PM
stevea Offline
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,696
linuxfedorafirefox
Re: Fedora 15 cut battery life in half!

sudo sed -e 's/ ro / ro pcie_aspm=force/' -i /etc/grub.conf

should do it.
__________________
None are more hopelessly enslaved than those who falsely believe they are free.
Johann Wolfgang von Goethe
Reply With Quote
  #9  
Old 30th June 2011, 09:43 PM
naticus Offline
Registered User
 
Join Date: Jun 2011
Posts: 7
linuxchrome
Re: Fedora 15 cut battery life in half!

Quote:
Originally Posted by xjonquilx View Post
Thank you, I suspected it was Grub but wasn't sure.

---------- Post added at 10:33 AM ---------- Previous post was at 10:30 AM ----------



Just log in to your regular user account and copy/paste the following in to Terminal:

Code:
sudo gedit /etc/grub.conf
It will ask for a password first, so type in your regular user password and press Enter. Gedit should pop up with the configuration without any issues. If you have problems, try this:

Code:
su
Type in the root password, then:

Code:
gedit /etc/grub.conf
I hope this helps!
Yep top line did the trick. Also the 'fix' aforementioned seemed to work. I got an extra 40% more battery life, and it got much closer to what I am used to (from abysmall 4hours to 7hours).

Now let's hope they can fix this in 2.6.31 kernel.

Thanks all for the help.
Reply With Quote
  #10  
Old 30th June 2011, 10:24 PM
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 5,997
solarisfirefox
Re: Fedora 15 cut battery life in half!

Quote:
Originally Posted by naticus View Post
Yep top line did the trick. Also the 'fix' aforementioned seemed to work. I got an extra 40% more battery life, and it got much closer to what I am used to (from abysmall 4hours to 7hours).

Now let's hope they can fix this in 2.6.31 kernel.

Thanks all for the help.
2.6.31 is too old, it doesn't have this problem
Reply With Quote
  #11  
Old 1st July 2011, 04:24 AM
weitjong Online
Registered User
 
Join Date: Oct 2006
Location: Singapore, 新加坡
Posts: 936
macosfirefox
Re: Fedora 15 cut battery life in half!

May be he meant kernel 3.1 instead
__________________
YaoWT - Leave no window unbroken ♪ (^。^) 
Reply With Quote
  #12  
Old 1st July 2011, 03:36 PM
naticus Offline
Registered User
 
Join Date: Jun 2011
Posts: 7
linuxchrome
Re: Fedora 15 cut battery life in half!

Quote:
Originally Posted by weitjong View Post
May be he meant kernel 3.1 instead
LOL that is correct. That is what 48 hour shift will do to you.
Reply With Quote
  #13  
Old 3rd July 2011, 02:08 PM
PauGNU Offline
Registered User
 
Join Date: Aug 2008
Location: Barcelona
Age: 32
Posts: 28
linuxfirefox
Re: Fedora 15 cut battery life in half!

Quote:
Originally Posted by stevea View Post
sudo sed -e 's/ ro / ro pcie_aspm=force/' -i /etc/grub.conf

should do it.
Warning!!

We need a space! When I run this command, the result was:
<code>kernel /vmlinuz-2.6.38.8-32.fc15.x86_64 ro pcie_aspm=forceroot=/dev/mapper/VolGroup-lv_root rd_LVM_LV=VolGroup/lv_root</code>

As you can see, there was no space between «force» and «root».
__________________
GNULinux.cat
Reply With Quote
  #14  
Old 3rd July 2011, 03:40 PM
naticus Offline
Registered User
 
Join Date: Jun 2011
Posts: 7
linuxchrome
Re: Fedora 15 cut battery life in half!

So should their be a space? should I alter the config then? Or does it not matter?
Reply With Quote
Reply

Tags
battery, cut, fedora, half, life

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Power management on fedora 15: poor battery life _lorenzo87_ Hardware & Laptops 4 10th February 2012 08:12 PM
Fedora 14 and Battery Life? graycolor Using Fedora 4 10th January 2011 11:01 PM
Running Half Life 2 under wine MrNuke Gamers' Lounge 8 8th September 2010 12:17 PM
Half Life 2 with Wine Very Slow (FC5) Shakes Using Fedora 1 14th July 2006 02:53 PM
Half Life 2 + Ati9700 = DX7 ? Knudson Using Fedora 2 2nd May 2005 09:08 AM


Current GMT-time: 05:46 (Wednesday, 23-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat