Fedora Linux Support Community & Resources Center
  #1  
Old 28th June 2011, 01:13 PM
abmyers Offline
Registered User
 
Join Date: Jul 2006
Posts: 33
linuxfirefox
Gnome 3 - How to change Key binding

Hi,

I'm slowly coming to terms with Gnome 3 but one thing I can't get used to is using the "Windows Key".

For me it's a difficult key to use regularly. What I'd rather to is remap the "Switch between overview and desktop" action to alt-space, which I am used to from "Launchy" which I have been using in Windows for some time.

A couple of issues though - this is already mapping to "Activate the window menu". I never use it though. Are there any implications of remaping it?

Secondly, what is the command I need to map the key to, in order to emulate the Gnome 3 "Windows Key" behaviour?

Many thanks,
Andrew.
Reply With Quote
  #2  
Old 28th June 2011, 01:52 PM
wojox Offline
Registered User
 
Join Date: Mar 2010
Location: US, Texas
Age: 42
Posts: 46
linuxfirefox
Re: Gnome 3 - How to change Key binding

I ditched Gnome 3 for KDE, but if I remember doesn't the Windows key and Alt+F1 do the same thing?

If you open a terminal and run this can you change anything?

Code:
gnome-keybinding-properties
__________________
Fedora 16 Desktop Edition
Reply With Quote
  #3  
Old 28th June 2011, 09:16 PM
cymbaline42 Offline
Registered User
 
Join Date: May 2011
Posts: 165
linuxopera
Re: Gnome 3 - How to change Key binding

Quote:
Originally Posted by abmyers View Post
Hi,

I'm slowly coming to terms with Gnome 3 but one thing I can't get used to is using the "Windows Key".

For me it's a difficult key to use regularly. What I'd rather to is remap the "Switch between overview and desktop" action to alt-space, which I am used to from "Launchy" which I have been using in Windows for some time.

A couple of issues though - this is already mapping to "Activate the window menu". I never use it though. Are there any implications of remaping it?

Secondly, what is the command I need to map the key to, in order to emulate the Gnome 3 "Windows Key" behaviour?

Many thanks,
Andrew.

You can change this from the keyboard settings.

Open System Settings.
Click Keyboard and navigate to the 'Shortcuts' tab.
Choose 'System' on the left column, and you can change the 'Show the activities overview' shortcut by highlighting it and pressing Backspace.
Reply With Quote
  #4  
Old 29th June 2011, 01:36 PM
abmyers Offline
Registered User
 
Join Date: Jul 2006
Posts: 33
linuxfirefox
Thumbs up Re: Gnome 3 - How to change Key binding

Quote:
Originally Posted by cymbaline42 View Post
You can change this from the keyboard settings.

Open System Settings.
Click Keyboard and navigate to the 'Shortcuts' tab.
Choose 'System' on the left column, and you can change the 'Show the activities overview' shortcut by highlighting it and pressing Backspace.
Thank you - that worked perfectly.
Reply With Quote
  #5  
Old 5th April 2012, 11:31 PM
ClientAlive Offline
Registered User
 
Join Date: Feb 2012
Location: South Dakota
Posts: 17
linuxfirefox
Re: Gnome 3 - How to change Key binding

Hi,

I also needed to do something like this. I'm using fedora 16 with gnome 3 and found this thread through google. I tried what is suggested in post #3 but it isn't working for me. This is what I tried and what happens...

I'm trying to enable shortcut keys to launch the terminal (ctrl+alt+t). I went to "System Settings > Keyboard > Shortcuts tab." "Launch Terminal" is shown as "Disabled". It says along the bottom of the window: "To edit a shortcut, click the row and hold down the new keys or press Backspace to clear." I've tried both but with no response/ result. What am I doing wrong?

Can anyone help?
Reply With Quote
  #6  
Old 23rd May 2012, 08:22 PM
murfman Offline
Registered User
 
Join Date: May 2012
Location: Burke
Posts: 1
linuxchrome
Re: Gnome 3 - How to change Key binding

Quote:
Originally Posted by ClientAlive View Post
Hi,

I also needed to do something like this. I'm using fedora 16 with gnome 3 and found this thread through google. I tried what is suggested in post #3 but it isn't working for me. This is what I tried and what happens...

I'm trying to enable shortcut keys to launch the terminal (ctrl+alt+t). I went to "System Settings > Keyboard > Shortcuts tab." "Launch Terminal" is shown as "Disabled". It says along the bottom of the window: "To edit a shortcut, click the row and hold down the new keys or press Backspace to clear." I've tried both but with no response/ result. What am I doing wrong?

Can anyone help?
I am having the exact same issue. If I can figure it out I will let you know.

---------- Post added at 02:22 PM ---------- Previous post was at 02:10 PM ----------

I figured it out. Don't click on the actual name of the keybinding, but on the shortcut itself. It's an annoying but trivial issue.
Reply With Quote
  #7  
Old 4th July 2012, 01:24 AM
mariogiov Offline
Registered User
 
Join Date: Jan 2012
Posts: 4
linuxfirefox
Re: Gnome 3 - How to change Key binding

Here's a twist on this question -- I just upgraded to F17 and find my original terminal shortcut, ctrl-shift-w, has been overridden by the gnome-wide shortcut ctrl-w. I can't assign it through the System Settings --> Keyboard --> Shortcuts interface because every time I type it the window closes.

Any thoughts?


Mario
Reply With Quote
  #8  
Old 4th July 2012, 10:00 AM
megaloman Offline
Registered User
 
Join Date: Dec 2004
Posts: 140
linuxfirefox
Re: Gnome 3 - How to change Key binding

Quote:
Originally Posted by mariogiov View Post
Here's a twist on this question -- I just upgraded to F17 and find my original terminal shortcut, ctrl-shift-w, has been overridden by the gnome-wide shortcut ctrl-w. I can't assign it through the System Settings --> Keyboard --> Shortcuts interface because every time I type it the window closes.

Any thoughts?
Mario
change the "window close" shourtcut first?
__________________
megaloman.org
Reply With Quote
  #9  
Old 4th July 2012, 05:19 PM
mariogiov Offline
Registered User
 
Join Date: Jan 2012
Posts: 4
linuxfirefox
Re: Gnome 3 - How to change Key binding

Yeah I thought that might do it too but "Close Window" is assigned to Alt-F4, not Ctrl-W. I also looked through the file ~/.gnome2/accels/nautilus but didn't find any Ctrl-W assignments there.

I've never been an expert on how any of the gnome settings are laid out in the filesystem -- does anyone know if this can be set manually in a text file somewhere?
Reply With Quote
Reply

Tags
binding, change, gnome, key

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I change from TWM to Gnome? arozar Using Fedora 2 2nd October 2007 09:23 PM
Change Gnome to KDE cyclonmaster Using Fedora 2 6th April 2007 11:59 PM
How to Change from Gnome to KDE?? helpwithcore6 Using Fedora 4 31st December 2006 11:44 PM
where does gnome key-binding configuration file reside? chy1013m1 Using Fedora 0 9th December 2005 08:17 PM


Current GMT-time: 17:06 (Thursday, 24-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat