Fedora Linux Support Community & Resources Center
  #1  
Old 1st June 2011, 07:08 PM
ninwa Offline
Registered User
 
Join Date: Jun 2011
Posts: 2
linuxchrome
RPM Fusion error, cannot update packages, details inside.

Hey all!

I wanted to do a routine check/update today and I recieved this error:

Code:
GPG key retrieval failed: [Errno 14] Could not open/read file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-nonfree-fedora-15-x86_64
Here is my output from 'yum repolist':
Code:
# yum repolist
Loaded plugins: langpacks, presto, refresh-packagekit
repo id                    repo name                                      status
fedora                     Fedora 15 - x86_64                             24,085
google-chrome              google-chrome                                       3
google64                   Google - x86_64                                     4
livna                      rpm.livna.org for 15 - x86_64                       3
playonlinux                PlayOnLinux Official repository                     8
rpmfusion-free             RPM Fusion for Fedora 15 - Free                   438
rpmfusion-free-updates     RPM Fusion for Fedora 15 - Free - Updates          20
rpmfusion-nonfree          RPM Fusion for Fedora 15 - Nonfree                179
rpmfusion-nonfree-rawhide  RPM Fusion for Fedora Rawhide - Nonfree           180
rpmfusion-nonfree-updates  RPM Fusion for Fedora 15 - Nonfree - Updates       10
skype                      Skype Repository                                    1
updates                    Fedora 15 - x86_64 - Updates                    1,747
repolist: 26,678
I was wondering what causes this error and what I can do to fix it?

Cheers,
Ninwa
Reply With Quote
  #2  
Old 1st June 2011, 07:11 PM
AndyFlag Offline
Registered User
 
Join Date: Mar 2011
Posts: 17
linuxfirefox
Re: RPM Fusion error, cannot update packages, details inside.

Could you post the command and entire output? I think I had something similar happen and fixed it
Reply With Quote
  #3  
Old 1st June 2011, 07:20 PM
ninwa Offline
Registered User
 
Join Date: Jun 2011
Posts: 2
linuxchrome
Re: RPM Fusion error, cannot update packages, details inside.

Quote:
Originally Posted by AndyFlag View Post
Could you post the command and entire output? I think I had something similar happen and fixed it
I was receiving this error in the software update tool, but it also happens at command line:

Code:
T# yum update
Loaded plugins: langpacks, presto, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package rpmfusion-nonfree-release.noarch 0:12-3 will be updated
---> Package rpmfusion-nonfree-release.noarch 0:15-1 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                       Arch       Version   Repository             Size
================================================================================
Updating:
 rpmfusion-nonfree-release     noarch     15-1      rpmfusion-nonfree      15 k

Transaction Summary
================================================================================
Upgrade       1 Package(s)

Total download size: 15 k
Is this ok [y/N]: y
Downloading Packages:
Setting up and reading Presto delta metadata
Processing delta metadata
Package(s) data still to download: 15 k
rpmfusion-nonfree-release-15-1.noarch.rpm                |  15 kB     00:00     
warning: rpmts_HdrFromFdno: Header V3 RSA/SHA256 Signature, key ID 6d0c8ec2: NOKEY
Public key for rpmfusion-nonfree-release-15-1.noarch.rpm is not installed
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-nonfree-fedora-15-x86_64


GPG key retrieval failed: [Errno 14] Could not open/read file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-nonfree-fedora-15-x86_64
Reply With Quote
  #4  
Old 1st June 2011, 09:43 PM
AndyFlag Offline
Registered User
 
Join Date: Mar 2011
Posts: 17
linuxfirefox
Re: RPM Fusion error, cannot update packages, details inside.

Found a similar thread here that had a solution
su -
http://gcdnmirror.paultan.org/forums...d.php?t=262355

Or a simple yum update should fix the proble

Last edited by AndyFlag; 1st June 2011 at 09:54 PM.
Reply With Quote
Reply

Tags
details, error, fusion, inside, packages, rpm, update

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
software update error could not update packages accboy Using Fedora 2 29th June 2010 12:19 AM
Update packages then an apache error. AltGrendel Servers & Networking 0 11th August 2009 07:41 PM
Compiz Fusion local file conflic between packages Newbie_from_NJ Using Fedora 1 26th January 2009 08:40 PM
Fedora 9 inside VMware Fusion 2.0 ScottishCaptain Using Fedora 1 21st September 2008 09:56 AM
Need Help - FDS 1.0.4 - Admin Console - Details Inside - Thanks sphenis Servers & Networking 3 23rd June 2007 01:49 AM


Current GMT-time: 00:12 (Saturday, 30-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat