Fedora Linux Support Community & Resources Center
  #1  
Old 20th May 2011, 11:21 PM
Sockmonster Offline
Registered User
 
Join Date: May 2011
Posts: 8
linuxfedorafirefox
Hard disks only spin down for a few seconds

Hi, I'm running fedora on a laptop and have installed Laptop-Mode-Tools. When I enter laptop mode my hard disks spin-down but almost immediately start up again. When I run "hdparm -Y /dev/sda" the drive spins-down for approx 5 sec.

I've set dirty_writeback_centisecs to 5000 and have set vm.swappiness to 100 to try and limit the amount of disk writes, but it is having no effect. It seems that something is constantly writing to my disk!!

Any help would be grand

Thanks.
Reply With Quote
  #2  
Old 21st May 2011, 12:04 AM
flansuse Offline
Registered User
 
Join Date: May 2010
Posts: 78
linuxchrome
Re: Hard disks only spin down for a few seconds

What value is -B (power management) set to with laptop-mode? I've had issues with anything lower than 128. Too many parks of the head is not good for the drive in the long term.
Reply With Quote
  #3  
Old 21st May 2011, 01:09 AM
Sockmonster Offline
Registered User
 
Join Date: May 2011
Posts: 8
linuxfedorafirefox
Re: Hard disks only spin down for a few seconds

Not sure what -B is, how do i check?
Thanks.
Reply With Quote
  #4  
Old 21st May 2011, 03:19 PM
flansuse Offline
Registered User
 
Join Date: May 2010
Posts: 78
windows_7chrome
Re: Hard disks only spin down for a few seconds

Quote:
Originally Posted by Sockmonster View Post
Not sure what -B is, how do i check?
Thanks.
With the hdparm tool, you can manually set certain hard drive attributes, such as power management with the -B option. In the configuration file for laptop-mode, there is a section that sets the -B level based on three conditions: is laptop-mode running on battery? on AC? is it disabled?

This file is located under /etc/laptop-mode/laptop-mode.conf

Code:
BATT_HD_POWERMGMT
LM_AC_HD_POWERMGMT
NOLM_AC_HD_POWERMGMT

These values specify the power management level for your hard drives. The legal values for these options can be found in the hdparm manual page, in the documentation of the -B option
You will see the current values it is set to. Most likely the NOLM value is 254, and the value for laptop-mode being active is either 1 or 128. Leave the 254 alone, but change the other values to 128 or greater. If you would rather your drive not constantly spin down and start up, over and over, set it to 254.

You can also manually check the current power management level of any drive with hdparm.

The following command displays the drive's information, while only revealing the lines with the word "power" in them:
Code:
hdparm -I /dev/sda | grep -i power

Last edited by flansuse; 21st May 2011 at 05:29 PM.
Reply With Quote
  #5  
Old 21st May 2011, 07:33 PM
flyingfsck Online
Registered User
 
Join Date: Aug 2010
Location: Al Ain, UAE
Posts: 1,870
linuxfirefox
Re: Hard disks only spin down for a few seconds

Howdy,

You have to stop the syslog daemon if you want the hard disk to spin down.
Reply With Quote
  #6  
Old 21st May 2011, 07:40 PM
stevea Offline
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,836
linuxfedorafirefox
Re: Hard disks only spin down for a few seconds

Quote:
Originally Posted by flyingfsck View Post
Howdy,

You have to stop the syslog daemon if you want the hard disk to spin down.
Well - you need get /var/log and maybe /tmp OFF the hard disk. Try mounting a tmpfs for these (F15 does this automatically IIRC).

I haven't tried in a few months but the kflush daemon at that time ignored the dirty_writeback_centisecs.
Setting vm.swappiness to 100 isn't a good value and is only effective IF you ae swapping - and generally you shouldn't be on an end-user system.
__________________
None are more hopelessly enslaved than those who falsely believe they are free.
Johann Wolfgang von Goethe
Reply With Quote
Reply

Tags
disks, hard, seconds, spin

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hard disk install error for a Custom spin of Fedora 11 kalabharath Installation, Upgrades and Live Media 0 31st July 2009 03:12 AM
Spin down disks in software raid array and otherwise? shadowwyvern Hardware & Laptops 1 21st September 2006 03:30 PM
Spin down idle hard disk staehler Hardware & Laptops 0 6th September 2005 08:04 PM
Spin Down a USB2.0 External IDE Hard disk BjBlaster Hardware & Laptops 1 3rd February 2005 03:57 PM


Current GMT-time: 16:01 (Saturday, 20-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat