Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Using Fedora
FedoraForum Search

Forgot Password? Join Us!

Using Fedora General support for current versions. Ask questions about Fedora and it's software that do not belong in any other forum.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 10th May 2011, 11:10 AM
andyhorton Offline
Registered User
 
Join Date: Feb 2011
Posts: 20
windows_7chrome
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

Hello,

My Fedora 14 box is no longer starting. I am getting a message at startup - "Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)".

Unfortunately, I don't know what I did before I got the message. I mean, I have made various installations, including some kernel drivers (such as a wifi card and a sound card). Also I did need to update the kernel-devel package as a requirement for some install or other. I know that is not very helpful, but let's get to the important bit...

What does the message "Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)" mean? What has broken?

And how does on recover from it? I have been reading around, and of course I am able to boot the machine from a live CD, but I am not sure what I should do with grub.conf, what I should rebuild, how to do it and so on.

Any ideas? Starters for ten (http://en.wikipedia.org/wiki/Starter_for_Ten)?

Andy
Reply With Quote
  #2  
Old 23rd May 2011, 10:30 AM
andyhorton Offline
Registered User
 
Join Date: Feb 2011
Posts: 20
windows_7chrome
Re: Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

OK, I "solved" this myself. Let me explain...

1. So, downloaded and burned a full install image (not the live image) as this has rescue mode.

2. Booted from that and chose rescue mode from the boot menu (of course).

3. It mounts the old file system on /mnt/sysimage

4. Went to my boot volume (at /mnt/sysimage/boot/grub) and edited grub.conf so that (A) I would see the menu and (B) it would give me a few seconds to choose and option:

timeout=10
#hiddenmenu

5. Rebooted (from the hard disk this time).

6. Chose the second kernel (not the most recent broken one).

7. It worked - after some "SELinux relabelling" - had to wait a while for that to complete.

8. So, then I went back to grub (now at /etc/grub.conf - or /boot/grub/grub.conf) and edited it to remove the lines relating to the broken kernel.

Da da!

There was a little more to it than that. I was doing this with a monitor attached to a normally headless server, and I thought it was not starting as the console hung on the "F" splash screen. However, I tried attaching via SSH over the network, or indeed one of the VNC sessions that is always running, and they were fine. So, it turns out the console has been broken for a while, but I had not noticed as I don't use it.

Have changed /etc/inittab to default to 3 now. Who needs an X session on the console on a headless server?

Hope this report helps someone.

Andy
Reply With Quote
  #3  
Old 18th August 2011, 09:51 PM
feimingchen Offline
Registered User
 
Join Date: Mar 2011
Posts: 11
linuxfedorafirefox
Smile Re: Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

I have the same problem as yours. I have a Fedora 15 Linux. I did not do anything particular except for running "yum update" once. Somehow the new kernel does not work afterwards.

Thanks to your post, I was able to fix this problem along the same lines:

1. Get/burn an installation CD with a linux system.

2. Booted from this CD (may need to press F12 (or other key) to choose
boot option).

3. Mount the old file system on, I use:

Code:
$ mount -t ext4 /dev/sda1 /mnt
4. In ROOT account, went to my boot volume (at /mnt/boot/grub) and
edited "grub.conf" so that (A) I would see the menu and (B) it would
give me a few seconds to choose and option:

Code:
timeout=10
#hiddenmenu
5. Rebooted (from the hard disk this time).

6. Chose the second kernel (not the most recent broken one).

7. It worked!

8. So, then I went back to grub (now at "/etc/grub.conf", which is
soft linked to "/boot/grub/grub.conf") and edited it to comment out
(or remove) the lines relating to the broken kernel:

Code:
# title Fedora (2.6.40-4.fc15.i686)
#        root (hd0,0)
#        kernel /vmlinuz-2.6.40-4. ......
I noticed this stanza does not have "initrd ..." line. Maybe that's why it
couldn't boot.

Further information for fixing this error is located here:

http://fedoraproject.org/wiki/Common..._.2Fdev.2Froot
Reply With Quote
  #4  
Old 18th August 2011, 11:02 PM
zardoz Offline
Registered User
 
Join Date: May 2007
Posts: 21
linuxchrome
Re: Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

This has also caught me out on a number of F15 yum updates. Definitely a serious bug.
An easy solution is to reboot off the old kernel and do a forced reinstall of the failed kernel using rpm, over the top of the existing RPM.

eg. rpm -ivh --force <kernel RPM>

Worked for me each time.

Z.
Reply With Quote
  #5  
Old 12th September 2011, 10:27 PM
todd_dsm Offline
Registered User
 
Join Date: Oct 2008
Posts: 5
linuxfirefox
Re: Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

The same thing just happened to me after some f15 updates. PANIC!

I had a USB flash drive in the slot. I pulled it and the box fired right up; Crisis Averted

Just thought I'd share in case some of the newbs panic easily.

TT
Reply With Quote
  #6  
Old 29th September 2011, 07:09 AM
greg.harvey Offline
Registered User
 
Join Date: May 2009
Location: Uzès, France
Posts: 104
linuxchrome
Re: Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

Hmm, I just got this on a Fedora *upgrade*, so I'm screwed. I can't roll back to the previous kernel, all the packages have been updated. Trying to push through it. The initrd line was completely missing from GRUB, so added that, now it doesn't give me a kernel panic, but it doesn't boot either. What next?
__________________
http://drupaler.drupalgardens.com
Reply With Quote
  #7  
Old 23rd January 2012, 05:05 AM
Tuxavant Offline
Registered User
 
Join Date: Jan 2012
Location: Las Vegas, NV
Posts: 5
linuxfirefox
Re: Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

Just had this same problem. Just wanted to let you guys know, if you have timeout=0 in your grub, you can access the menu (to choose a different kernel) by holding down the CTRL key.

This combined with the tip from Zardoz to reinstall the kernel rpm package worked quickly and effectively.

Additionally, you can use yumdownloader to grab the kernel rpm file.
Reply With Quote
  #8  
Old 18th September 2012, 08:02 PM
tuxox Offline
Registered User
 
Join Date: Sep 2012
Location: Syria
Posts: 4
linuxfirefox
Re: Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

F17-Another quick solution: i had it when my laptop battery went off during finalizing an update that include a kernel update. i booted through the F17 DVD and choose (the normal) install > upgrade existing > upgrade boot loader > the installation started for few seconds > cngrats > successful boot maintaining all the previous updates as well.
Reply With Quote
  #9  
Old 7th February 2013, 03:02 PM
msz85 Offline
Registered User
 
Join Date: Jan 2013
Location: Spain
Posts: 1
linuxchrome
Re: Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

I have this problem with Fedora 18, can you help me please?I put this image from the problem

Last edited by msz85; 7th February 2013 at 03:10 PM.
Reply With Quote
  #10  
Old 3rd April 2014, 08:30 PM
burnie Offline
Registered User
 
Join Date: Jan 2005
Location: Half Moon Bay, CA
Age: 75
Posts: 134
linuxfirefox
Re: Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

I have this same problem with Fedora 20.

As background (hopefully irrelevant) information, during the last three weeks I have dealt with bumblebee and nvidia and finally got everything working with the 3.13.6-200 kernel.

Since the 3.13.7-200 kernel was installed, the "Unable to mount root fs on unknown block (0.0)" panic occurs. So I return to 3.13.6-200.

I say (as root):
Quote:
# yum reinstall kernel-3.13.7-200.fc20.x86_64
I get:
Quote:
Installed package kernel-3.13.7-200.fc20.x86_64 not available.
I say:
Quote:
# rpm -q kernel
I get:
Quote:
kernel-3.11.10-301.fc20.x86_64
kernel-3.13.6-200.fc20.x86_64
kernel-3.13.7-200.fc20.x86_64
I say:
Quote:
# yum install kernel-3.13.7-200.fc20.x86_64
I get:
Quote:
Nothing to do
How do I move forward from here - anybody?
Reply With Quote
  #11  
Old 4th April 2014, 03:36 AM
burnie Offline
Registered User
 
Join Date: Jan 2005
Location: Half Moon Bay, CA
Age: 75
Posts: 134
linuxfirefox
Re: Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

Others have solved similar problems by copying the initrd line from earlier kernels in the menu entries cited by the command line in grub.cfg. This might seem reasonable, except that the source of grub.cfg (/sbin/grub2-mkconfig) together with its input files /etc/default/grub and and /etc/grub.d all antedate the March 24 installation date of the 3.13.7-200 kernel. 3.13.6-200 was installed on March 16, and it works fine (as I noted above).

Here are the relevant creation dates of the subject files.

Quote:
# ls -l /sbin/grub2-mkconfig
-rwxr-xr-x. 1 root root 7019 Aug 10 2013 /sbin/grub2-mkconfig
Quote:
# ls -l /etc/default/grub
-rw-r--r--. 1 root root 402 Mar 16 10:03 /etc/default/grub
Quote:
# ls -l /etc/grub.d
total 60
-rwxr-xr-x. 1 root root 7762 Aug 10 2013 00_header
-rwxr-xr-x. 1 root root 9481 Aug 10 2013 10_linux
-rwxr-xr-x. 1 root root 10353 Aug 10 2013 20_linux_xen
-rwxr-xr-x. 1 root root 2564 Aug 10 2013 20_ppc_terminfo
-rwxr-xr-x. 1 root root 9926 Aug 10 2013 30_os-prober
-rwxr-xr-x. 1 root root 214 Aug 10 2013 40_custom
-rwxr-xr-x. 1 root root 216 Aug 10 2013 41_custom
-rw-r--r--. 1 root root 483 Aug 10 2013 README
Quote:
# ls -l grub.cfg
-rw-------. 1 root root 6024 Apr 1 16:27 grub.cfg
And here is the resulting grub.cfg file. In the following I ----skip---- a bunch of lines and ##trunc## several long lines in the menu text for clarity.

Note that there is no initrd /initramfs line in the top menu entry. (I assure you it was NOT ##trunc##ed out.) This seems to me logically impossible, given that /etc/grub.d and /etc/default/grub antedate the March 24 installation of the current kernel.
Quote:
[root@localhost grub2]# more grub.cfg
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub2-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
----skip----
### BEGIN /etc/grub.d/10_linux ###
menuentry 'Fedora (3.13.7-200.fc20.x86_64) 20 (Heisenbug)'##trunc##
{
load_video
set gfxpayload=keep
insmod gzio
insmod part_msdos
insmod ext2
set root='hd0,msdos2'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-e##trunc##
else
search --no-floppy --fs-uuid --set=root 86119960##trunc##
fi
linux /vmlinuz-3.13.7-200.fc20.x86_64 root=/dev/##trunc##
}
menuentry 'Fedora (3.13.6-200.fc20.x86_64) 20 (Heisenbug)'##trunc##
{
load_video
set gfxpayload=keep
insmod gzio
insmod part_msdos
insmod ext2
set root='hd0,msdos2'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-b##trunc##
else
search --no-floppy --fs-uuid --set=root 86119960##trunc##
fi
linux /vmlinuz-3.13.6-200.fc20.x86_64 root=/dev/##trunc##
initrd /initramfs-3.13.6-200.fc20.x86_64.img
}
menuentry 'Fedora, with Linux 3.11.10-301.fc20.x86_64' --c##trunc##
{
load_video
set gfxpayload=keep
insmod gzio
insmod part_msdos
insmod ext2
set root='hd0,msdos2'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-b##trunc##
else
search --no-floppy --fs-uuid --set=root 86119960##trunc##
fi
linux /vmlinuz-3.11.10-301.fc20.x86_64 root=/dev##trunc##
initrd /initramfs-3.11.10-301.fc20.x86_64.img
}
Reply With Quote
  #12  
Old 4th April 2014, 04:13 AM
stevea Offline
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,553
linuxfirefox
Re: Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

If you are going to post content from indented files - then put it in a CODE not QUOTED section. Your post above is unreadable.


The yum man page states clearly ....
Code:
       reinstall
              Will  reinstall  the  identically versioned package as is cur‐
              rently installed.  This does not work for "installonly"  pack‐
              ages,  like Kernels. reinstall operates on groups, files, pro‐
              vides and filelists just like the "install" command.

So try to erase then install the kernel. Of course you shouldn't remove the kernel you are booted from (tho' it can work if ....).
__________________
None are more hopelessly enslaved than those who falsely believe they are free.
Johann Wolfgang von Goethe
Reply With Quote
  #13  
Old 4th April 2014, 04:52 AM
burnie Offline
Registered User
 
Join Date: Jan 2005
Location: Half Moon Bay, CA
Age: 75
Posts: 134
linuxfirefox
Re: Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

Thank you, stevea. That worked fine.

The main reason for my bulky post was to try to understand how the creation of the grub.cfg file managed to drop the initrd line - since apparently that had happened multiple times from F15 and up (and possibly down as well).
Reply With Quote
Reply

Tags
not syncing, root fs, unable to mount

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel panic - not syncing :VFS: unable to mount root fs on unknown block (0,0) agentblue Using Fedora 5 18th September 2012 08:28 PM
raid1 Kernel panic - not syncing: VFS Unable to mount root fs on unknown-block(0,0) heals1ic Using Fedora 1 14th December 2010 09:00 PM
kernel panic - not syncing :VFS: unable to mount root fs on unknown block (0,0) agentblue Using Fedora 19 30th November 2009 12:44 AM
F10 "Kernel panic - not syncing: VFS Unable to mount root fs on unknown-block(0,0) rcocchiararo Installation, Upgrades and Live Media 17 13th December 2008 12:41 AM
kernel panic - not syncing :VFS: unable to mount root fs on unknown block (0,0) agentblue Using Fedora 12 12th December 2005 12:45 AM


Current GMT-time: 14:18 (Thursday, 24-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat