Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora Resources > Guides & Solutions (Not For Questions)
FedoraForum Search

Forgot Password? Join Us!

Guides & Solutions (Not For Questions) Post your guides here (No links to Blogs accepted). You can also append your comments/questions to a guide, but don't start a new thread to ask a question. Use another forum for that.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 12th April 2011, 09:39 PM
CronoCloud Offline
Registered User
 
Join Date: May 2010
Location: Midwest USA
Age: 50
Posts: 513
linuxfedorafirefox
Nvidia HDMI out and Analog audio out combined!

Suppose you have not so good eyes like me, and your nice Nvidia cards HDMI video out looks nicer and is easier to read than the VGA out, but you're having problems getting the sound to work. Not only that but if you use the HDMI audio out, you lose sound to your headset jack in front. Sure since my monitor is a small HDTV I could just run a short extension cable from my TV's headphone jack to reach to the plug on my headset leaving the mic jack plugged in as normal, but that's annoying.

Well here's a solution:

First lets get your Nvidia audio out working, this helped a lot since I have a GT220:

http://wiki.xbmc.org/index.php?title...T220,_or_GT240

I did what it says to edit /etc/modprobe.d/sound.conf in my case it's a single lin
e:

options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2

then edit /etc/pulse/default.pa

after the section that says this and a bunch of commented out stuff:

### Load audio drivers statically (it's probably better to not load
### these drivers manually, but instead use module-hal-detect --
### see below -- for doing this automatically)

then add this:

load-module module-alsa-sink device=hw:1,3

and then if you want output to BOTH HDMI and Analog add a:

load-module module-combine
set-default-sink combined

at the end.

reboot, unmute card 1 in alsamixer or alsamixergui (it's muted by default!) and select simultaneous audio out in pulseaudio, if it isn't already.

Hope this helps someone down the line:

Ron Rogers Jr. (CronoCloud)
Reply With Quote
  #2  
Old 12th April 2011, 10:06 PM
leigh123linux
Guest
 
Posts: n/a
linuxredhatfirefox
Re: Nvidia HDMI out and Analog audio out combined!

Here's another good link

ftp://download.nvidia.com/XFree86/gp...dmi-audio.html
Reply With Quote
  #3  
Old 20th October 2011, 06:48 AM
Seve Offline
Retired Community Manager
 
Join Date: Oct 2004
Location: The GTA, Ontario, Canada
Age: 59
Posts: 12,371
linuxfirefox
Re: Nvidia HDMI out and Analog audio out combined!

Quote:
Originally Posted by CronoCloud View Post
Suppose you have not so good eyes like me, and your nice Nvidia cards HDMI video out looks nicer and is easier to read than the VGA out, but you're having problems getting the sound to work. Not only that but if you use the HDMI audio out, you lose sound to your headset jack in front. Sure since my monitor is a small HDTV I could just run a short extension cable from my TV's headphone jack to reach to the plug on my headset leaving the mic jack plugged in as normal, but that's annoying.

Well here's a solution:

First lets get your Nvidia audio out working, this helped a lot since I have a GT220:

http://wiki.xbmc.org/index.php?title...T220,_or_GT240

I did what it says to edit /etc/modprobe.d/sound.conf in my case it's a single lin
e:

options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2

then edit /etc/pulse/default.pa

after the section that says this and a bunch of commented out stuff:

### Load audio drivers statically (it's probably better to not load
### these drivers manually, but instead use module-hal-detect --
### see below -- for doing this automatically)

then add this:

load-module module-alsa-sink device=hw:1,3

and then if you want output to BOTH HDMI and Analog add a:

load-module module-combine
set-default-sink combined

at the end.

reboot, unmute card 1 in alsamixer or alsamixergui (it's muted by default!) and select simultaneous audio out in pulseaudio, if it isn't already.

Hope this helps someone down the line:

Ron Rogers Jr. (CronoCloud)
Just a note of thanks, as I was able to use this to get a GT220 HDMI connection to work as advertised.
__________________
Registered Linux User: #384977
.................................................. ............
See the Links below for more Help and those much wanted extras ... :)
Reply With Quote
  #4  
Old 26th December 2011, 07:02 AM
CronoCloud Offline
Registered User
 
Join Date: May 2010
Location: Midwest USA
Age: 50
Posts: 513
linuxfirefox
Re: Nvidia HDMI out and Analog audio out combined!

One problem with F16, loading the combined sink module makes Pulseaudio unstable and causes it to almost immediately crash upon use. (just reinstalled my GT220 since I finally got another upgraded power supply)

CronoCloud
Reply With Quote
Reply

Tags
analog, audio, combined, hdmi, nvidia

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HDMI Audio on NVidia GT218 [ION] schplat Hardware & Laptops 0 8th December 2010 02:33 AM
[SOLVED] Nvidia HDMI audio/sound jtang613 Hardware & Laptops 6 23rd September 2010 07:19 PM
HDMI or spdif audio F10 kupo Hardware & Laptops 2 28th July 2009 04:27 PM
no analog cd audio necrosoft Using Fedora 2 7th February 2005 11:49 PM


Current GMT-time: 20:34 (Thursday, 20-07-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat