Fedora Linux Support Community & Resources Center
  #1  
Old 20th March 2011, 01:23 AM
hakufox Offline
Registered User
 
Join Date: Mar 2011
Posts: 5
windows_xp_2003chrome
Not moving the mouse pauses the screen...?

Hi, I am using Fedora 14 and the startup/loading screen when I turn on my Netbook only moves along when I waggle my mouse. This is fine, but I have the same problem when it comes to videos as well.
If I am watching a movie on SMPlayer, the movie only continues when I move my cursor on the screen. The second I stop moving my cursor, the video stops playing. If I move it again, the video starts.

When I don't move my mouse, my screen pauses and stops doing anything. I constantly have to move my mouse to refresh what is on the screen. I am really confused as to what is causing this and help would be greatly appreciated! It is really frustrating!!

Thank you very much!
Reply With Quote
  #2  
Old 20th March 2011, 01:58 AM
bob Offline
Administrator (yeah, back again)
 
Join Date: Jul 2004
Location: Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
Age: 69
Posts: 22,125
linuxfedorafirefox
Re: Not moving the mouse pauses the screen...?

moved to General Support.
__________________
Linux & Beer - That TOTALLY Computes!
Registered Linux User #362651


Don't use any of my solutions on working computers or near small children.
Reply With Quote
  #3  
Old 20th March 2011, 02:00 AM
hakufox Offline
Registered User
 
Join Date: Mar 2011
Posts: 5
windows_xp_2003chrome
Re: Not moving the mouse pauses the screen...?

:/ That doesn't help me at all.
Reply With Quote
  #4  
Old 20th March 2011, 02:07 AM
bob Offline
Administrator (yeah, back again)
 
Join Date: Jul 2004
Location: Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
Age: 69
Posts: 22,125
linuxfedorafirefox
Re: Not moving the mouse pauses the screen...?

This is not about helping you on the problem. There's others who will jump into the thread to do that. This is about you not following the Posting Rules by starting a second thread on the same topic. If you look at that one, you'll see my comments.


BTW, have you checked your power management settings?
__________________
Linux & Beer - That TOTALLY Computes!
Registered Linux User #362651


Don't use any of my solutions on working computers or near small children.
Reply With Quote
  #5  
Old 20th March 2011, 03:00 AM
hakufox Offline
Registered User
 
Join Date: Mar 2011
Posts: 5
windows_xp_2003chrome
Re: Not moving the mouse pauses the screen...?

I am right now but now the video isn't playing at all. :/ I'm not sure what the settings should be or how to configure this.
Reply With Quote
  #6  
Old 20th March 2011, 11:04 AM
bob Offline
Administrator (yeah, back again)
 
Join Date: Jul 2004
Location: Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
Age: 69
Posts: 22,125
linuxfedorafirefox
Re: Not moving the mouse pauses the screen...?

My thought was that perhaps you'd adjusted something there that was causing the laptop to suspend after a few seconds to preserve battery life. Since I don't have a laptop operating Fedora, I'm not going to try and tell you what your settings should be.

Are you certain that your netbook is compatible with Fedora? Have you checked the Search for others with the same netbook?
__________________
Linux & Beer - That TOTALLY Computes!
Registered Linux User #362651


Don't use any of my solutions on working computers or near small children.
Reply With Quote
  #7  
Old 20th March 2011, 05:04 PM
hakufox Offline
Registered User
 
Join Date: Mar 2011
Posts: 5
windows_xp_2003chrome
Re: Not moving the mouse pauses the screen...?

I only see posts regarding Fedora 11 on my netbook. I think I am just going to switch to Ubuntu or Ubuntu Netbook Remix. Thank you very much for your help.
Reply With Quote
  #8  
Old 22nd March 2011, 09:34 AM
Lx_rules Offline
Registered User
 
Join Date: Mar 2009
Posts: 77
windows_xp_2003firefox
Re: Not moving the mouse pauses the screen...?

Quote:
Originally Posted by hakufox View Post
Hi, I am using Fedora 14 and the startup/loading screen when I turn on my Netbook only moves along when I waggle my mouse. This is fine, but I have the same problem when it comes to videos as well.
If I am watching a movie on SMPlayer, the movie only continues when I move my cursor on the screen. The second I stop moving my cursor, the video stops playing. If I move it again, the video starts.

When I don't move my mouse, my screen pauses and stops doing anything. I constantly have to move my mouse to refresh what is on the screen. I am really confused as to what is causing this and help would be greatly appreciated! It is really frustrating!!

Thank you very much!


I have this problem since FC13 on my laptop fujitsu amilo (my other mivvy laptop works fine, no problems here). Couldn't find anything on the net about this. I disabled screen saver, checked all settings in the power management. Nothing helps. Regardless what I do, disable, it will keep on going into black screen after 5-10 minutes (it's very annoying while watching a movie or you tube). I had another topic about this and no one had any idea. I had this problem on FC13 and just installed freshly FC14. It seems that this problem appear in this release also If anyone has any idea on how to fix this, please let me know. Thanks in advance.
__________________
Fujitsu Amilo Li 3910 and Mivvy L310 running FC14
Reply With Quote
  #9  
Old 22nd March 2011, 03:31 PM
bob Offline
Administrator (yeah, back again)
 
Join Date: Jul 2004
Location: Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
Age: 69
Posts: 22,125
linuxfedorafirefox
Re: Not moving the mouse pauses the screen...?

Hakufox may have the solution. Not every distro is right for every machine. Use what works.
__________________
Linux & Beer - That TOTALLY Computes!
Registered Linux User #362651


Don't use any of my solutions on working computers or near small children.
Reply With Quote
  #10  
Old 22nd March 2011, 03:52 PM
Lx_rules Offline
Registered User
 
Join Date: Mar 2009
Posts: 77
windows_xp_2003firefox
Re: Not moving the mouse pauses the screen...?

Well..it used to work up to release 13, never had this issue before. I like fedora and want to remain with fedora, but I'm a bit disappointed, since I have some other things that were working on FC13 and now they don't anymore. Also I was hoping that this problem with the screen saver would be fixed in FC 14.
__________________
Fujitsu Amilo Li 3910 and Mivvy L310 running FC14
Reply With Quote
  #11  
Old 22nd March 2011, 04:20 PM
bob Offline
Administrator (yeah, back again)
 
Join Date: Jul 2004
Location: Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
Age: 69
Posts: 22,125
linuxfedorafirefox
Re: Not moving the mouse pauses the screen...?

Well then, the best option is to check Bugzilla for the problem and/or file it there. You may find a solution.
__________________
Linux & Beer - That TOTALLY Computes!
Registered Linux User #362651


Don't use any of my solutions on working computers or near small children.
Reply With Quote
  #12  
Old 26th April 2011, 07:27 PM
hallux Offline
Registered User
 
Join Date: Apr 2011
Posts: 2
windows_7firefox
Post Re: Not moving the mouse pauses the screen...? (SOLVED)

Tried F14 on a Toshiba NB-205, had the same problem with the whole OS seeming to pause and only a wiggle of the mouse or pressing a button over and over again would keep things moving. I tried the 'add kernel param "nohz=off" to the end of the "kernel /vmlinuz" line' that I found in

http://forums.fedoraforum.org/showthread.php?t=247153

and it WORKED!!!

For anyone having this problem still, all I can say is this worked like a charm, no more having to jiggle or move the mouse, and pauses are eliminated! THANKS! Now I don't have to use WinWhatever on my netbook, freeing me in a number of ways.

To do this edit (on a standard F14 install, for anyone who doesn't know how to do this already, and I hope I'm not going to offend or annoy anyone posting this here, if you already know this, please feel free to ignore my post... this is for very new-to-Linux people, who maybe don't know how this whole CLI thing works, and need a little hand-holding. If this helps even just ONE user to get free of the Redmond/Cupertino Duopoly, I HAVE DONE MY DUTY. This may annoy Linux purists, but I have had too many friends see my Linux install, marvel at it, wiggling windows and all, (Desktop Effects) then refuse to try it themselves because of its rep. as unfriendly, too hard, and having too many community members who instead of helping just shout "RTFM!!!"

So for the uninitiated, here it is: Open a terminal window, OR Ctrl-Alt-F2, etc. out of X (the GUI) to a different vTTY, login as root, and skip to "you are now root" below.

Type "su" followed by Enter/Return. Enter your system's root password.

If successful, you are now "root". If you don't know the password, find someone who does, i.e., the person who installed Linux for you, etc... If you still can't figure it out, then helping you is, I'm afraid, beyond the scope of this increasingly novel-like post. You're going to need to log-in as- or 'su' to- root to do this.)

Type "cd /etc" and press Enter. Type "vi grub.conf" and press Enter. (If you don't already know how to use 'vi', now'd be a great time to learn it. Otherwise, follow these instructions to the letter and you'll be okay.)

Use your down-arrow key to move the cursor to the beginning of the kernel line, under "title Fedora (2.6." etc. " , under "root (hd0,0)" and may be indented. (The numbers on your computer may be slightly different, but the kernel /vmlinuz line should be basically the same.)

Position the cursor at the start of the kernel line. Press "a", (and you should see "-- INSERT --" appear at the bottom left of the terminal window) and use the right arrow to advance to the end of the line. After the last word, add a space and the expression- "nohz=off" (without the quotes, and ALL lowercase.) Press the Esc. button, hold shift and hit the [ ; / : ] key (to get ":") and press "x", then hit the Enter key. If anything goes wrong, type Esc., followed by ":q!" (again without quotes) to abort the edit, then try again. It's important to get this right because, you'll be editing a system-startup file, and you'll be doing it as root, which means you BETTER DO IT RIGHT, or your system may not be able to boot. If you screw it up, and you save it, (the "Esc. : x" key sequence) the system has you logged in as root, and it is presumed therefore, that you know what you're doing, and the system won't even try to stop you from doing something dumb, and you could easily demolish your entire system. A famous way of doing that is trying to rename the root directory or your directory structure with the "rm" command (remove, actually, not rename) and a couple switches I won't, for safety sake, mention here.

After completing these steps, type "exit" and hit Enter, (you may have to do this twice,) or just close the terminal window with the "x" icon, and reboot. If you had the same problem I did, it should be gone now, HOORAY! For anyone who went through this, and didn't know vi, try the command "man vi" from the prompt, or "info vi" which has lots of good info on using this ancient, venerated editing program from the good-ol' days.


(Yes, I know my personal 'cat' function has a bug in it... I do not support the -verbose=NO!!!_STOP_STOP_SSSTTTOPPP!!! flag... sorry, no patch/bugfix is available.)

I sincerely hope this helped anyone who was having this same, very annoying problem with Fedora (or other distros) Linux seeming to freeze for no reason unless the mouse is moved, during anytime file-I/O is occurring, such as boot or shutdown. Thanks for reading!

Last edited by hallux; 28th April 2011 at 12:41 AM.
Reply With Quote
  #13  
Old 27th April 2011, 05:42 AM
JamesNZ Offline
Registered User
 
Join Date: Aug 2010
Location: Wellington, New Zealand
Age: 17
Posts: 907
windows_7chrome
Re: Not moving the mouse pauses the screen...?

Good tutorial (I assume it works). Why not make a guide out of it?
__________________
"For what is a man profited if he gains the whole world, but loses his own soul?"

- Jesus
Reply With Quote
  #14  
Old 28th April 2011, 12:39 AM
hallux Offline
Registered User
 
Join Date: Apr 2011
Posts: 2
windows_7firefox
Re: Not moving the mouse pauses the screen...?

Not sure how to make this "guide" of which you speak. Anyway, I just remember my first experience with vi, and how imposing it could be, kind of the way Hunter S. Thompson described a person on an ether binge... you give your computer commands you expect to work the same way they do in most-any modern screen-editor, and the computer seems to think you meant something else completely, often with destructive results... (like if you hit 'd' in the wrong mode... and try to move the cursor around and ...whoops, uh oh...my TEXT IS GONE!!!)

I wrote the instructions, then followed them myself, step by step, and they worked, so... unless I overlooked something, they should help those unfamiliar with vi. I feel vi is important because it is ubiquitous on Linux/Unix based systems, and has some handy features, which are great once you come to grips with the idea that the software was originally conceived to be run on a dumb-terminal, with little more than [A-Z][a-z][0-9] capabilities, and to allow you to command the computer to do anything OTHER than type characters, it HAD to be modal. :/
Reply With Quote
  #15  
Old 28th April 2011, 02:19 AM
JamesNZ Offline
Registered User
 
Join Date: Aug 2010
Location: Wellington, New Zealand
Age: 17
Posts: 907
windows_7chrome
Re: Not moving the mouse pauses the screen...?

Quote:
Originally Posted by hallux View Post
Not sure how to make this "guide" of which you speak.
Make a thread here with the instructions
__________________
"For what is a man profited if he gains the whole world, but loses his own soul?"

- Jesus
Reply With Quote
Reply

Tags
freeze, glitch, mouse, pause

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Arrange windows by moving mouse to the top right corner prkos Using Fedora 8 13th January 2011 03:00 PM
F10 Mouse Clicks while moving with nipple mouse cory0023 Using Fedora 1 11th March 2009 01:45 AM
Mouse moving and clickikng by itself Grizzil Using Fedora 2 24th July 2007 09:01 PM
NIC only works with USB mouse plugged in and moving Miker Hardware & Laptops 4 19th June 2005 11:20 AM
network stalls when mouse is not moving kwaanens Hardware & Laptops 1 19th June 2005 11:19 AM


Current GMT-time: 07:01 (Tuesday, 02-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat