Fedora Linux Support Community & Resources Center
  #1  
Old 9th March 2011, 05:16 AM
eyesee Offline
Registered User
 
Join Date: Mar 2011
Posts: 17
linuxfedorafirefox
How do you stop X server?

I'm new to linux and am trying to install Nvidia drivers on my system. The install says to :-

1. install Binutils (which i've managed to do)
2.stop the X service from running (here I'm having problems)

I've tried "X -terminate" but I just get an error message. Can anyone tell me or point to how I can terminate the service.

Yours eyesee.
Reply With Quote
  #2  
Old 9th March 2011, 05:21 AM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,320
linuxfedorafirefox
Re: How do you stop X server?

unless there is some reason for you to be compiling the drivers from nvidia, there is an easier way to get the nvidia drivers installed on your system

They have compiled rpm files over in the rpmfusion repo

follow Leigh123linux's excellent guide for installing the nvidia drivers here:

http://forums.fedoraforum.org/showthread.php?t=204752
Reply With Quote
  #3  
Old 9th March 2011, 05:36 AM
eyesee Offline
Registered User
 
Join Date: Mar 2011
Posts: 17
linuxfedorafirefox
Re: How do you stop X server?

I'Ve just had a go at using your suggested site but get the error message
"rpmfusion-free-release >= 14 is needed by (installed) rpmfusion-nonfree-release-14.0.4.noarch"
Reply With Quote
  #4  
Old 9th March 2011, 06:35 AM
flyingfsck Online
Registered User
 
Join Date: Aug 2010
Location: Al Ain, UAE
Posts: 1,826
linuxfedorafirefox
Re: How do you stop X server?

You change run level to 3:
$ su -
password
# init 3

That will stop X.

To get back to normal with a GUI, change to runlevel 5:
# init 5
Reply With Quote
  #5  
Old 9th March 2011, 06:57 AM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,320
linuxfedorafirefox
Re: How do you stop X server?

Quote:
Originally Posted by eyesee View Post
I'Ve just had a go at using your suggested site but get the error message
"rpmfusion-free-release >= 14 is needed by (installed) rpmfusion-nonfree-release-14.0.4.noarch"
You get that even when trying to install both of them?

Code:
su -
rpm -Uvh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
Maybe it would be better to install them with yum.

Code:
su -
yum localinstall --nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
Reply With Quote
  #6  
Old 9th March 2011, 12:22 PM
eyesee Offline
Registered User
 
Join Date: Mar 2011
Posts: 17
linuxfedorafirefox
Re: How do you stop X server?

Just had a go at using YUM and received the following message :-
"/var/tmp/yum-root-7unzQh/rpmfusion-free-release-stable.noarch.rpm: does not update installed package"
and the same for the nonfree release.

---------- Post added at 12:22 PM ---------- Previous post was at 12:21 PM ----------

Had a go at INIT 3 but doesn't seem to have any effect. There's no change in my display.
Reply With Quote
  #7  
Old 9th March 2011, 04:09 PM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,320
linuxfedorafirefox
Re: How do you stop X server?

hmm.. Those error messages are saying that the rpmfusion repos are already installed on your system. Maybe they got installed with rpm even though it gave an error.

see if they are installed:
Code:
yum repolist
If you see the rpmfusion-free, rpmfusion-free-updates, rpmfusion-nonfree, and rpmfusion-nonfree-updates repos in your list, then they got installed and you can continue with the guide for installing the nvidia drivers.
Reply With Quote
  #8  
Old 9th March 2011, 05:13 PM
eyesee Offline
Registered User
 
Join Date: Mar 2011
Posts: 17
linuxfedorafirefox
Re: How do you stop X server?

Got the following from REPOLIST :-

[root@zaphod IanC]# yum repolist
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
rpmfusion-free-updates | 3.3 kB 00:00
rpmfusion-nonfree-updates | 3.3 kB 00:00
updates/metalink | 28 kB 00:00
repo id repo name status
fedora Fedora 14 - i386 17,883
rpmfusion-free RPM Fusion for Fedora 14 - Free 364
rpmfusion-free-updates RPM Fusion for Fedora 14 - Free - Updates 436
rpmfusion-nonfree RPM Fusion for Fedora 14 - Nonfree 176
rpmfusion-nonfree-updates RPM Fusion for Fedora 14 - Nonfree - Updates 226
updates Fedora 14 - i386 - Updates 5,432
repolist: 24,517
[root@zaphod IanC]#

---------- Post added at 05:01 PM ---------- Previous post was at 04:51 PM ----------

your analysis about rpmfusion was correct and I've successfully run the yum install.
Many thanks

---------- Post added at 05:13 PM ---------- Previous post was at 05:01 PM ----------

Blender works much better now with the Nvidia drivers installed. My only problem now is it's not recognising my second monitor
Reply With Quote
  #9  
Old 9th March 2011, 05:13 PM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,320
linuxfedorafirefox
Re: How do you stop X server?

One other thing, I recommend using the akmod package for the nvidia driver instead of the kmod. (it's a matter of preference, really)

My reasons are that the akmod package will automatically build a new nvidia kernel module whenever the kernel is updated so I don't have to wait until the built kernel module is available from rpmfusion. (sometimes it takes a day or so for them to get the kmod updated.) If by chance the kernel module isn't available from rpmfusion when you update your kernel (and you are using the kmod pagkage), you will boot to a black screen (Xserver won't start). You can just boot to your previous kernel by selecting it in your grub menu, and wait until the kmod is available and run a yum update again.

The drawback to using the akmod package is that you have to keep the kernel-devel package installed on your system so it has the source needed to build the kernel module at the cost of a little disk space.

Edit:
second monitors can sometimes be a little tricky.

install the nvidia-xsettings package and you should be able to configure it from there.

Code:
yum install nvidia-xsettings nvidia-settings
Then you can configure it by going to System-->Administration-->Nvidia Xserver Settings

Last edited by DBelton; 9th March 2011 at 05:18 PM.
Reply With Quote
  #10  
Old 9th March 2011, 05:37 PM
eyesee Offline
Registered User
 
Join Date: Mar 2011
Posts: 17
linuxfedorafirefox
Re: How do you stop X server?

Your right again, I can switch the second monitor on from the NVIDIA Xserver settings, but it says I have to be logged in as root. I thought my account was the root user in the GUI as i'm the only user set up? Can anyone tell me how to log in to the root user in the gnome desktop?

Last edited by eyesee; 9th March 2011 at 08:28 PM.
Reply With Quote
  #11  
Old 10th March 2011, 09:10 AM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,320
linuxfedorafirefox
Re: How do you stop X server?

that's interesting. I just tried it on mine and get the same error. It used to ask for the root password, but now it doesn't, it just errors out.

open a terminal window then:

Code:
su -
(root password)

nvidia-settings
This will let you run it as root user and save your settings to /etc/X11/xorg.conf
Reply With Quote
  #12  
Old 10th March 2011, 11:58 PM
eyesee Offline
Registered User
 
Join Date: Mar 2011
Posts: 17
linuxfedorafirefox
Thumbs up Re: How do you stop X server?

Your good at this linux stuff arn't you. That did the trick I now have a second screen up and running.
Thanks to your help.

Ian C
Reply With Quote
  #13  
Old 11th March 2011, 04:14 AM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,320
linuxfedorafirefox
Re: How do you stop X server?

most of what I know, I have learned by experimenting and trying things out. Yes, I have broken a lot of things doing that, but I have learned quite a lot from each experience.

One thing I learned a long time ago.... Have backups of important files
Reply With Quote
Reply

Tags
server, stop

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to stop X server and gdm in Fedora 13 pilotgi Fedora 13 Development Branch 15 21st May 2010 05:14 AM
How do I stop x-window/server? bakachankun Using Fedora 1 25th June 2009 12:31 PM
Samba server stop working!!!need help bizar Using Fedora 5 4th April 2009 04:59 AM
How to stop DHCP server from giving IP to second NIC? Mighty_Ferguson Servers & Networking 6 10th September 2008 11:43 AM
Stop X Server giantforaday Servers & Networking 4 17th June 2005 05:01 PM


Current GMT-time: 21:40 (Thursday, 31-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat