Fedora Linux Support Community & Resources Center
  #1  
Old 24th February 2011, 10:58 PM
lroberts Offline
Registered User
 
Join Date: Jan 2011
Posts: 6
windows_7ie
Thumbs down Plymouth no longer showing after ATI F14

Hello im looking for help with a problem im having and just cant seem to solve. After installing proprietary ATI drivers successfully all my desktop effects etc. etc. are working brilliantly. but now my plymouth boot splash no longer shows. it only shows a progress bar that says fedora 14 beside it. Ive tried adding vga=791 at the end of the kernel line in the grub.conf but now it just locks me out of my system. ive also removed rhgb quiet and tried fresh installing my OS. still everytime this happens.

I hope i havent put this in the wrong place im new to these forums ive been looking everywhere for an answer and havent found one if this has already been solved in these forums please point me to it. its such a small...but annoying problem lol



thanks in advance
Reply With Quote
  #2  
Old 25th February 2011, 04:02 PM
SiliconSlick Offline
Registered User
 
Join Date: Aug 2009
Location: College Station, TX
Posts: 501
linuxfedorafirefox
Re: Plymouth no longer showing after ATI F14

Has ATI added kernel modesetting to its driver? Without kernel modeset support you get no Plymouth. Be happy with your eye-candy once you log in.

SS
Reply With Quote
  #3  
Old 25th February 2011, 05:29 PM
lroberts Offline
Registered User
 
Join Date: Jan 2011
Posts: 6
windows_7ie
Re: Plymouth no longer showing after ATI F14

well to get the driver fully functioning i had to add nomodset to the kernel line in grub.conf otherwise the desktop effects were a bit grundgy and most wouldnt function properly. So now that i think about it, that may be the problem lol. But i've read that ATI cards are some of the best for plymouth? or at least were with F10

---------- Post added at 11:29 AM ---------- Previous post was at 10:24 AM ----------

I should also mention this is an integrated ATI 4250 in a toshiba laptop
Reply With Quote
  #4  
Old 25th February 2011, 06:07 PM
SiliconSlick Offline
Registered User
 
Join Date: Aug 2009
Location: College Station, TX
Posts: 501
linuxfedorafirefox
Re: Plymouth no longer showing after ATI F14

Quote:
Originally Posted by lroberts View Post
But i've read that ATI cards are some of the best for plymouth? or at least were with F10[COLOR="Silver"]
Perhaps with the open-source radeon driver but I don't know if that is the case with the proprietary one.

SS
Reply With Quote
  #5  
Old 27th February 2011, 09:11 AM
CSchwangler Offline
Registered User
 
Join Date: Feb 2009
Posts: 2,535
linuxsafari
Re: Plymouth no longer showing after ATI F14

My understanding is that ATI's proprietary driver doesn't support KMS and thats why Plymouth doesn't work.
Reply With Quote
  #6  
Old 27th February 2011, 09:38 PM
lroberts Offline
Registered User
 
Join Date: Jan 2011
Posts: 6
linuxfedorafirefox
Re: Plymouth no longer showing after ATI F14

Really? I've read before that with kernel 2.6.35 the fglrx drivers should work with KMS. Also, isn't KMS supposed to operate before drivers are loaded? shouldn't it be using VESA or something?
Reply With Quote
  #7  
Old 28th February 2011, 07:37 PM
droidhacker Offline
Registered User
 
Join Date: Oct 2009
Posts: 827
linuxfedorafirefox
Re: Plymouth no longer showing after ATI F14

KMS ***IS*** the driver.
You can't load more than one driver for the same hardware.

If you use fglrx, you do NOT use the radion driver, and thus you do NOT get KMS.

Why are you using fglrx? This is NOT WONDOZE, you do NOT need to install blob drivers to make your hardware work!
Reply With Quote
  #8  
Old 28th February 2011, 10:44 PM
lroberts Offline
Registered User
 
Join Date: Jan 2011
Posts: 6
windows_7ie
Exclamation Re: Plymouth no longer showing after ATI F14

When using the radeon open source driver i was getting a whack of problems. Once i setup the fglrx drivers everything worked much much smoother... despite my lack of "wondoze" and my question was that i read plymouth operates before any driver (whether it be "wondoze" friendly or not) is loaded because if that is the case fglrx or open source drivers shouldn't have an effect, no?

---------- Post added at 03:40 PM ---------- Previous post was at 01:49 PM ----------

so after removing fglrx and reinstalling it i get plymouth on shutdown but not on startup what a tease

---------- Post added at 04:44 PM ---------- Previous post was at 03:40 PM ----------

soollvveeedddd

I removed plymouth and reinstalled it through kpackage

I then installed spinfinity:
yum install plymouth-theme-spinfinity

then as root:

plymouth-set-default-theme spinfinity
/usr/libexec/plymouth/plymouth-update-initrd


Thanks to this article

http://tuxicity.wordpress.com/2010/1...-in-fedora-14/
Reply With Quote
Reply

Tags
ati, f14, longer, plymouth, showing

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Plymouth in F11 freakLick Using Fedora 2 22nd October 2009 10:36 PM
Plymouth no longer gets to GDM screen, F10 sej7278 Using Fedora 0 19th September 2009 11:32 AM
USB drives no longer showing up in panel... edszr Using Fedora 1 24th June 2009 08:45 PM
F11 Plymouth PCessna Using Fedora 27 12th June 2009 09:21 PM
Plymouth sourabindu Using Fedora 4 17th December 2008 04:46 PM


Current GMT-time: 22:22 (Sunday, 23-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Privolzhsk Instagram Photos - Omura Photos - Zwijndrecht