Fedora Linux Support Community & Resources Center
  #1  
Old 29th November 2010, 05:13 PM
FFUser Offline
Registered User
 
Join Date: May 2009
Posts: 49
linuxfedorafirefox
[SOLVED] Avoid LVM/ LUKS mounts in rc.sysinit

Hi -
I have a system with multiple LVM and LUKS volumes. The system also has a customized initrd that unlocks one LUKS volume, activates one LVM (the root partition), and mounts the LVM to perform the switch_root. I do not want to mount the remaining LVM/ LUKS volumes at boot. I have edited /etc/crypttab to comment out all LUKS volumes other than the aforementioned volume used for the root partition. I have also edited /etc/fstab to comment out those LVMs that do not require mount at the time of boot. However, rc.sysinit fails upon an e2fsck check error on one of the LVMs that I do not want to mount at boot. This specific LVM is encrypted using LUKS. (the drives are relatively new and I re-ran fsck manually to double-check the filesystem integrity, so the error is a false-positive) Are there other configuration steps that I am missing to get rc.sysinit to ignore these LVM/ LUKS volumes?

Also - Is there a way to avoid the udevadm messaging flood upon startup? The message flood appeared after performing a recent system update. Presumably, this results from dracut, but I have not been able to identify any kernel boot parameters to silence the udevadm messages.

Thanks -
Will

kernel: 2.6.34.7-61.fc13.x86_64

Last edited by FFUser; 30th November 2010 at 03:35 PM. Reason: Changed thread to SOLVED status
Reply With Quote
  #2  
Old 29th November 2010, 06:56 PM
aesir Offline
Registered User
 
Join Date: Nov 2008
Location: ~
Age: 28
Posts: 175
linuxfedorafirefox
Re: Avoid LVM/ LUKS mounts in rc.sysinit

I don't understand if your LUKS partitions are being wrongly mounted at the initrd stage of after that.
If it's dracut try rd_NO_LUKS rd_NO_LVM as kernel parameters, but I'm not sure since you are using a custom initrd.
If it's rc.sysinit you'll need to edit it. If your partition are already mounted you can comment out the whole init_crypto

For the fsck problem maybe those partitions are flagged in /etc/fstab: the last parameter should be 0 if you don't want that partition to be checked.
Reply With Quote
  #3  
Old 29th November 2010, 09:01 PM
FFUser Offline
Registered User
 
Join Date: May 2009
Posts: 49
linuxfedorafirefox
Re: Avoid LVM/ LUKS mounts in rc.sysinit

Quote:
I don't understand if your LUKS partitions are being wrongly mounted at the initrd stage of after that.
Apologies - the issue arises after the initrd stage. I believe the issue arises during rc.sysinit script (but the udevadm logging messages obfuscate the system output).

Quote:
If it's dracut try rd_NO_LUKS rd_NO_LVM as kernel parameters, but I'm not sure since you are using a custom initrd.
Thanks -- I had tried the above flags when I thought the error originated during the initrd stage, but no joy.

Quote:
If it's rc.sysinit you'll need to edit it. If your partition are already mounted you can comment out the whole init_crypto.
I'll give it a shot tonight and see what happens -- wanted to try to avoid altering system scripts in case I forget to add back anything. I'll scan the body of the init_crypto function and make sure the function doesn't make any persistent system modifications.

Quote:
For the fsck problem maybe those partitions are flagged in /etc/fstab: the last parameter should be 0 if you don't want that partition to be checked.
I had commented out the entire entry in fstab, but will go inspect the file to see if it was originally flagged.

Thanks for the help, and I'll post what I find.
Reply With Quote
  #4  
Old 30th November 2010, 03:34 PM
FFUser Offline
Registered User
 
Join Date: May 2009
Posts: 49
linuxfedorafirefox
Re: Avoid LVM/ LUKS mounts in rc.sysinit

D'Oh - the fstab file was not properly commented out, so the system was attempting to mount one of the still-encrypted LVM volumes. After properly commenting both the fstab and crypttab files, the boot works as expected. Thanks for the help.
Reply With Quote
Reply

Tags
luks, lvm, rc.sysinit

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
rc.sysinit v2k Installation, Upgrades and Live Media 2 22nd March 2008 12:38 PM
rc.sysinit segfault Rien Using Fedora 2 13th March 2007 05:30 PM
nothing mounts on boot nor auto mounts earobinson111 Using Fedora 7 16th December 2004 10:04 PM
2.6.1 rc.sysinit script feenixx Fedora Core 2 Test Releases 2 6th February 2004 12:34 PM


Current GMT-time: 10:14 (Saturday, 22-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Balsas Travel Photos on Instagram - Jahanian Shah Instagram Photos - Suriname