Fedora Linux Support Community & Resources Center
  #1  
Old 26th November 2010, 05:51 PM
andrigtmiller Offline
Registered User
 
Join Date: Nov 2008
Posts: 10
linuxfedorafirefox
Fedora 14 and Evergreen GPU's (HD 5850)

I upgraded to Fedora 14 with the expectation that the ATI driver would support my GPU for 2D and 3D hardware acceleration. I have an HP Envy 17" laptop with an ATI Mobility HD 5850 with 1GB of RAM.

Well, the driver loads, but no hardware acceleration.

I get the following lines in the Xorg log:

[ 1683.845] (II) RADEON(0): MC_AGP_LOCATION : 0x003f0000
[ 1683.855] (==) RADEON(0): Backing store disabled
[ 1683.855] (WW) RADEON(0): Direct rendering disabled

I don't have an xorg.conf file, and based on everything I read I was expecting acceleration support. I also installed the MESA experimental driver package to see if that would change anything, but no joy.

I also have the following in the log:

[ 1683.560] (II) Loading extension DRI2
[ 1683.560] (==) Matched ati as autoconfigured driver 0
[ 1683.560] (==) Matched vesa as autoconfigured driver 1
[ 1683.560] (==) Matched fbdev as autoconfigured driver 2
[ 1683.560] (==) Assigned the driver to the xf86ConfigLayout
[ 1683.560] (II) LoadModule: "ati"
[ 1683.560] (II) Loading /usr/lib64/xorg/modules/drivers/ati_drv.so
[ 1683.561] (II) Module ati: vendor="X.Org Foundation"
[ 1683.561] compiled for 1.8.99.906, module version = 6.13.99
[ 1683.561] Module class: X.Org Video Driver
[ 1683.561] ABI class: X.Org Video Driver, version 8.0
[ 1683.561] (II) LoadModule: "radeon"
[ 1683.561] (II) Loading /usr/lib64/xorg/modules/drivers/radeon_drv.so
[ 1683.561] (II) Module radeon: vendor="X.Org Foundation"
[ 1683.561] compiled for 1.8.99.906, module version = 6.13.99
[ 1683.562] Module class: X.Org Video Driver
[ 1683.562] ABI class: X.Org Video Driver, version 8.0
[ 1683.562] (II) LoadModule: "vesa"
[ 1683.562] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[ 1683.562] (II) Module vesa: vendor="X.Org Foundation"
[ 1683.562] compiled for 1.8.99.904, module version = 2.3.0
[ 1683.562] Module class: X.Org Video Driver
[ 1683.562] ABI class: X.Org Video Driver, version 8.0
[ 1683.562] (II) LoadModule: "fbdev"
[ 1683.562] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
[ 1683.563] (II) Module fbdev: vendor="X.Org Foundation"
[ 1683.563] compiled for 1.8.99.904, module version = 0.4.1
[ 1683.563] ABI class: X.Org Video Driver, version 8.0

What I'm wondering about, is why if the autoconfigured driver is "ati" do I get the ati_drv and radeon_drv as well? Is that right?

With the other messages all labeled "RADEON", it makes me wonder if something is wrong, and I'm not getting the correct driver loaded.

Any pointers would be greatly appreciated.
Reply With Quote
  #2  
Old 26th November 2010, 06:52 PM
Fenrin Offline
Registered User
 
Join Date: Apr 2010
Location: Earth
Posts: 892
linuxfedorafirefox
Re: Fedora 14 and Evergreen GPU's (HD 5850)

you could try the drivers from the rawhide repo. Here I described how a Fedora13 user would install it. You as F14 user should skip the points one, two and five.

Or alternatively you could try the Catalyst 10.11 driver. If you want to try the catalyst 10.11 driver you should do it before you update your kernel to 2.6.36 or before you update the xorg stuff. Without patch Catalyst 10.11 will probably not work with 2.6.36 kernel and I'm not sure if the xorg-version from the rawhide repo is supported by catalyst.

If you want to try Catalyst you should install kernel-devel and kernel-headers before.

Last edited by Fenrin; 26th November 2010 at 06:56 PM.
Reply With Quote
  #3  
Old 27th November 2010, 03:08 PM
andrigtmiller Offline
Registered User
 
Join Date: Nov 2008
Posts: 10
linuxfedorafirefox
Re: Fedora 14 and Evergreen GPU's (HD 5850)

Quote:
Originally Posted by Fenrin View Post
you could try the drivers from the rawhide repo. Here I described how a Fedora13 user would install it. You as F14 user should skip the points one, two and five.

Or alternatively you could try the Catalyst 10.11 driver. If you want to try the catalyst 10.11 driver you should do it before you update your kernel to 2.6.36 or before you update the xorg stuff. Without patch Catalyst 10.11 will probably not work with 2.6.36 kernel and I'm not sure if the xorg-version from the rawhide repo is supported by catalyst.

If you want to try Catalyst you should install kernel-devel and kernel-headers before.
I'll try the rawhide repo. I had the Catalyst drivers installed and working, but they stopped working with the recent bug fix release of the X server, and I had to go back to the open source drivers. Thanks for the pointers.
Reply With Quote
  #4  
Old 30th November 2010, 06:21 PM
andrigtmiller Offline
Registered User
 
Join Date: Nov 2008
Posts: 10
linuxfedorafirefox
Re: Fedora 14 and Evergreen GPU's (HD 5850)

I manually downloaded the newer xorg-x11-drv-ati* package from a Fedora Rawhide mirror along with mesa packages, which installed just fine on F14 without any other changes, and I have 2D and 3D acceleration working! It isn't perfect, and the performance isn't as good as the proprietary drivers, but it seems good enough at the moment.
Reply With Quote
  #5  
Old 1st December 2010, 10:17 AM
consolation Offline
Registered User
 
Join Date: Oct 2010
Posts: 18
linuxsafari
Re: Fedora 14 and Evergreen GPU's (HD 5850)

I got the catalyst drivers working stable with no crashes. Using proprietary drivers from ATI and testing repo. Details here.
Reply With Quote
Reply

Tags
5850, evergreen, fedora, gpu

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HD Radeon 5770 or 5850 for F12 or 13? pedora Hardware & Laptops 5 19th May 2010 08:16 PM
How to install HP deskjet printer 5850? hl.tintuc Installation, Upgrades and Live Media 3 8th April 2006 07:43 PM


Current GMT-time: 09:49 (Friday, 01-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat