Fedora Linux Support Community & Resources Center
  #1  
Old 14th November 2010, 02:41 AM
OralDeckard Offline
Registered User
 
Join Date: Nov 2006
Posts: 474
linuxfedorafirefox
Question How do you stop gtk-recordmydesktop ?

Recordmydesktop sounds great. I installed it in F14 with both the gtk and the qt gui. Both of them start the recorder, but I can't find any way to stop it.

I really thought something like this would have some reasonable controls, like a time I could set for it to stop, on some way to stop it manually, but the only way I can find to stop it is to kill the process. If this were true then it would be junk, so surely there is some way to control it.

Has anyone used this, and how do you stop it?
Reply With Quote
  #2  
Old 14th November 2010, 10:06 AM
CSchwangler Offline
Registered User
 
Join Date: Feb 2009
Posts: 2,535
linuxfedorafirefox
Re: How do you stop gtk-recordmydesktop ?

Haven't used this application, but from the documentation it seems that it is operated by clicking on the tray icon.

http://recordmydesktop.sourceforge.net/rug/p1_1b.php
Reply With Quote
  #3  
Old 14th November 2010, 11:49 AM
bonedome Offline
Registered User
 
Join Date: Apr 2010
Location: uk
Posts: 727
linuxfirefox
Re: How do you stop gtk-recordmydesktop ?

Hello
you can also use ffmpeg to record your desktop, like this
Code:
ffmpeg -f x11grab -s 1024x768 -r 30 -i :0.0 ~/out.mpg
adjust the -s 1024x768 to your screen size and -r 30 is the maximum 30 fps.
add :0.0+200,150 (no of x and y pixels)and adjust the -s to save only a small portion of the screen, and just press q to stop recording
__________________
fedora 14 fluxbox and gnome2 hp compaq nx9030 laptop 2Gb ram, helicopter landing pad, jacuzzi, mini fridge, gateway to alternative dimension
Reply With Quote
  #4  
Old 14th November 2010, 03:49 PM
OralDeckard Offline
Registered User
 
Join Date: Nov 2006
Posts: 474
linuxfedorafirefox
Re: How do you stop gtk-recordmydesktop ?

Quote:
Originally Posted by CSchwangler View Post
Haven't used this application, but from the documentation it seems that it is operated by clicking on the tray icon.]
It produced a tray icon as a circle with a red dot in it. When I click on Record (which has the same icon in the Record button) the try icon turns from red to black. But when I click the tray ion, instead of stopping, it pops up a message that I should wait while my recording is being encoded. It also says WARNING!, and tells me that if I click cancel my recording will be lost.

Well after 5 minutes of encoding a 2 second recording, and still saying it is 0% complete I finally gave up and clicked Cancel. That did nothing. It still shows 50% CPU usage in the system monitor. Again, the only way to stop it is by killing the process, and finding no file produced.

So again it looks wonderful, but acts like crapware.

Thank you very much for your effort. I'll work with it a little more. It would be great if it would actually work.

---------- Post added at 09:49 AM GMT ---------- Previous post was at 08:33 AM GMT ----------

Quote:
Originally Posted by bonedome View Post
Hello
you can also use ffmpeg to record your desktop, like this
Code:
ffmpeg -f x11grab -s 1024x768 -r 30 -i :0.0 ~/out.mpg
Thank you Bone Dome! That workd great. And being command line I can easily include it in scripts.

I'd still like to have a convenient graphical solution, but what works trumps what doesn't any day.

Last edited by OralDeckard; 14th November 2010 at 02:37 PM.
Reply With Quote
  #5  
Old 14th November 2010, 04:45 PM
ryptyde Offline
Registered User
 
Join Date: May 2005
Location: Tragic City, Michigan USA
Posts: 1,671
linuxfedorafirefox
Re: How do you stop gtk-recordmydesktop ?

Using recordMyDesktop on a F13 desktop 64 bit worked here and also on a F14 laptop 32 bit. I chose to record from the panel icon and in the "advanced" menu under "Performance" chose "Encode ON the Fly" then closed the advanced menu then selected the area to record in the preview window. Clicked the record button and recorded for about a minute then clicked the panel icon to stop. Opened my home directory and there was the out.ogv file ready to be viewed.

This probably doesn't help in your situation but just a heads-up that it does work properly on two of my installs.

phil
Reply With Quote
  #6  
Old 14th November 2010, 07:52 PM
OralDeckard Offline
Registered User
 
Join Date: Nov 2006
Posts: 474
linuxfedorafirefox
Re: How do you stop gtk-recordmydesktop ?

Thank you Ryptide. Trying it on another install makes a lot of sense. And knowing it works for somewone makes me feel a lot better about it.

So I installed it on my F13 and tried it again.
This time there was no icon in the system tray, either before or after I started it.
I had to kill the process, and did not get a file.

Since it works on some installs I will try it on others until I find one where it works, then find out what the difference is.
Reply With Quote
  #7  
Old 14th November 2010, 09:02 PM
ryptyde Offline
Registered User
 
Join Date: May 2005
Location: Tragic City, Michigan USA
Posts: 1,671
linuxfedorafirefox
Re: How do you stop gtk-recordmydesktop ?

Quote:
Originally Posted by OralDeckard View Post
Thank you Ryptide. Trying it on another install makes a lot of sense. And knowing it works for somewone makes me feel a lot better about it.

So I installed it on my F13 and tried it again.
This time there was no icon in the system tray, either before or after I started it.
I had to kill the process, and did not get a file.

Since it works on some installs I will try it on others until I find one where it works, then find out what the difference is.
Happened to give it a go on an Acer Aspire One that has F14 installed too and it worked as mentioned in my other post and also included sound from the vlc mediaplayer that was tuned in to an icecast station "Amiga Paradise" at the time.

phil
Reply With Quote
  #8  
Old 16th November 2010, 02:08 AM
OralDeckard Offline
Registered User
 
Join Date: Nov 2006
Posts: 474
linuxfedorafirefox
Re: How do you stop gtk-recordmydesktop ?

I installed in on a Fedora 8 virtual machine and it did the same thing.

I went to work today and installed it on an F13. It did the same thing.

I installed it on an F14. It did the same thing.

So far you are batting a thousand and I am batting zero.

That means there is something you are doing right that I am not.

I believe I am following the procedure you said you did, but just in case, here is what I do.

I select gtk-recordmydeskttop from the launcher menu.
It opens a dialog window. I click advanced, then the Performance tab, then check Encode On the Fly.
Then I click on the red circle icon in the system tray.
I let it run for about 30 seconds, then click the now black circle icon in the system tray.
Instead of stopping and leaving a file, it tells me that it is converting, and warns that if I click cancel I will lose it.
I give it several minutes to convert, then give up, because that is ridiculous.
Clicking Cancel does nothing at all.
I check my processes with the system monitor and find that recordmydesktop is using about 50% of the CPU. I kill the process.

Could you please review my procedure and tell me what I may be leaving out?
Reply With Quote
  #9  
Old 16th November 2010, 01:28 PM
ryptyde Offline
Registered User
 
Join Date: May 2005
Location: Tragic City, Michigan USA
Posts: 1,671
linuxfedorafirefox
Re: How do you stop gtk-recordmydesktop ?

I followed your procedure and when I click the panel icon it quits
and there is no delay and when I open the directory where I have
saved it there it is. I initially used the "save as" button and it uses
the Video directory in my home to save the output.

I wonder if it has anything to do with having eg ffmpeg or mencoder
installed. I do have most Video packages installed from Fedora repos
and from rpmfusion repos. Most was gotten using Dangermouse's AutoTen.

phil

---------- Post added 2010-11-16 at 07:28 AM GMT ---------- Previous post was 2010-11-15 at 10:49 PM GMT ----------

OK for a test I took a 4GB usb flash device and used Fedora's LiveUSB Creator and
installed a fresh Fedora-14-i686-Live-Desktop.iso to it. The liveusb has a 2047MB
persistent overlay that will retain settings or any newly installed packages. So as far
as I could tell there wasn't a package to record your desktop installed as default so
using yum I installed "gtk-recordmydesktop" .

From the desktop Application>Sound& Video>gtk-recordMyDesktop. Then the "recordMyDesktop"
window opens then clicked the "Save As" button and chose to save to the Video directory in
liveuser's home and called the file "testrecord" and exited that window. Clicked the "Advanced"
button >Performance>Encode On the Fly and exited that window. Then clicked the red record panel
icon to start recording then clicked the panel icon to stop recording. The file was saved in the
directory chosen without any waiting for it to be encoded.

So my conclusion is that you don't have to have any extra repos enabled but only the
"gtk-recordMyDesktop" package installed for it to work.

phil
Reply With Quote
  #10  
Old 17th November 2010, 05:19 PM
OralDeckard Offline
Registered User
 
Join Date: Nov 2006
Posts: 474
linuxfedorafirefox
Re: How do you stop gtk-recordmydesktop ?

Thank you very much for such a great effort you have gone to to help me solve this. Unfortunately we appear no closer, and it now gets even more mysterious. I tried installing Istanbul, and got the same thing on every machine. I have no doubt that if you installed it you would find it working fine on every one of your machines.

I installed the drivers you mentioned and it did no good. Actually I already had ffmpeg installed, and it works great. I suspect I can write a script to get ffmpeg to do all I want it to do, and from the menu or an icon. But that leaves programs that should work forever not working, with a mysterious cause that may show up elsewhere.

This may be unresolvable. I certainly do thank you for your effort.
Reply With Quote
  #11  
Old 18th November 2010, 06:21 PM
PatMcLJr Offline
Registered User
 
Join Date: Apr 2005
Location: earth
Posts: 1,193
linuxfedoramozilla
Re: How do you stop gtk-recordmydesktop ?

I had a go with byzanz-applet from the gnome applets

seems to select the encoding from the file ext. If you don't put anything it creates a gif when I tried to record my desktop with gif the playback would crash my system chocking every bit of memory it would. ogv worked but the file size was much bigger. I did try the gif format again and when I viewed the gif with seamonkey it didn't chock up system out so that was better.

It very basic but seems like it might work OK for what I might need it for.

Pat Jr.

the file that gets recorded will stop my computer too so I have to avoid the file when I start it, I'm guessing it has something to do with the thumbnailer? dolphin has no problems
I tested the gif on a web page and it seemed to work great, the whole picture didn't fit in one window but it did work
__________________
x--x--x
http://www.gnu.org/philosophy/free-sw.html
Freedom is never Free.
Pat Jr.

Last edited by PatMcLJr; 18th November 2010 at 06:58 PM.
Reply With Quote
  #12  
Old 18th November 2010, 10:29 PM
ryptyde Offline
Registered User
 
Join Date: May 2005
Location: Tragic City, Michigan USA
Posts: 1,671
linuxfedorafirefox
Re: How do you stop gtk-recordmydesktop ?

Quote:
Originally Posted by PatMcLJr View Post
I had a go with byzanz-applet from the gnome applets

seems to select the encoding from the file ext. If you don't put anything it creates a gif when I tried to record my desktop with gif the playback would crash my system chocking every bit of memory it would. ogv worked but the file size was much bigger. I did try the gif format again and when I viewed the gif with seamonkey it didn't chock up system out so that was better.

It very basic but seems like it might work OK for what I might need it for.

Pat Jr.

the file that gets recorded will stop my computer too so I have to avoid the file when I start it, I'm guessing it has something to do with the thumbnailer? dolphin has no problems
I tested the gif on a web page and it seemed to work great, the whole picture didn't fit in one window but it did work
The byzanz from the panel applet locked up on me for several minutes so won't be using that again.
Trying istanbul would not work.
Gtk-recordMyDesktop works fine for me and produces an .ogv file on the fly.

phil
Reply With Quote
Reply

Tags
gtk-recordmydesktop, qt-recordmydesktop, recordmydesktop

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Gnome Shell + recordmydesktop mh3rn4nd3z3 Using Fedora 14 5th June 2013 04:40 PM
recordmydesktop not recording full screen dth4h Using Fedora 0 24th August 2010 05:59 AM
Problem with gtk-recordmydesktop in Fedora12 GeekyLink Using Fedora 4 24th February 2010 12:16 AM
Recordmydesktop? knownchild Using Fedora 1 5th February 2008 05:08 AM
How can i stop pop ups Dangermouse Using Fedora 7 30th December 2007 09:16 PM


Current GMT-time: 18:15 (Friday, 19-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Creek Side - Stockholm-Arlanda Airport (ARN) Travel Photos on Instagram - Marina of Koper Travel Photos - Te Whiti Park Instagram Photos - Texas State Fair Photos on Instagram