Fedora Linux Support Community & Resources Center
  #1  
Old 7th November 2010, 09:35 PM
peterparks Offline
Registered User
 
Join Date: Nov 2010
Posts: 2
windows_vistafirefox
How to disable IPv6 in Fedora 14?

I've just done a fresh install of Fedora 14. All networking seems really slow in KDE. I've read on some other sites that this could be caused by IPv6 - how can I disable this for Fedora 14?

Of course, it might not be IPv6, but I didn't have this problem with Fedora 11, and Vista is fine. Pretty sure it's a networking issue rather than Internet because it takes ages for me to log into my router.

Can I just use the same instructions as posted here:

http://forums.opensuse.org/english/g...-11-2-a-2.html

Thanks,
Peter
Reply With Quote
  #2  
Old 7th November 2010, 09:44 PM
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 6,050
linuxfedorafirefox
Re: How to disable IPv6 in Fedora 14?

Quote:
Originally Posted by peterparks View Post
I've just done a fresh install of Fedora 14. All networking seems really slow in KDE. I've read on some other sites that this could be caused by IPv6 - how can I disable this for Fedora 14?

Of course, it might not be IPv6, but I didn't have this problem with Fedora 11, and Vista is fine. Pretty sure it's a networking issue rather than Internet because it takes ages for me to log into my router.

Can I just use the same instructions as posted here:

http://forums.opensuse.org/english/g...-11-2-a-2.html

Thanks,
Peter
You can fire up the system-config-network util and uncheck the
"Enable ipv6 configuration for this interface" checkbox and save/exit.

see:
http://fedorasolved.org/Members/MrHa...config-network

But if by slow networking you especially mean Firefox, see the forum by searching "about:config" and "network.dns.disableIPv6". Firefox constantly tries to use ipv6 DNS because under Fedora it thinks the existence of that Ipv6 interface (which Fedora puts in by default) really means ipv6 works. But 99% of users don't have ipv6 support actually working. So there's an annoying ipv6 dns -> fail -> ipv4 address obtain loop going on each time. Tell Firefox to quit that via using the about:config page to set the network.dns.disableIPv6 to 'true'
Reply With Quote
  #3  
Old 7th November 2010, 09:44 PM
assen Offline
Registered User
 
Join Date: Oct 2008
Posts: 492
linuxfedorafirefox
Re: How to disable IPv6 in Fedora 14?

Hi,

Try "rmmod ipv6"; you might have to stop the firewall first. If this helps, blacklist the module. There used to be an entry in /etc/sysconfig/network to toggle IPv6, but might have been moved somewhere else.

WWell,
Reply With Quote
  #4  
Old 7th November 2010, 10:08 PM
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 6,050
linuxfedorafirefox
Re: How to disable IPv6 in Fedora 14?

Another way,
put in your /etc/sysctl.conf file:

net.ipv6.conf.all.disable_ipv6=1

That would only take affect after next boot, you can start now without reboot by also doing:

sysctl -w net.ipv6.conf.all.disable_ipv6=1

Last edited by marko; 7th November 2010 at 10:12 PM.
Reply With Quote
  #5  
Old 7th November 2010, 10:11 PM
peterparks Offline
Registered User
 
Join Date: Nov 2010
Posts: 2
linuxfedorafirefox
Re: How to disable IPv6 in Fedora 14?

Quote:
Originally Posted by marko View Post
Another way,
put in your /etc/sysctl.conf file:

net.ipv6.conf.all.disable_ipv6 = 1
hmm, doesn't seem to have worked. lsmod still gives me:

ipv6 229420 34 ip6t_REJECT,nf_conntrack_ipv6

i can't run rmmod because the module is in use - even if I stop iptables.

i've disable the setting in firefox, but system-config-network says that my wireless card doesn't have ipv6 anyway.

maybe my problem is just due to my own net connection or flash - youtube keeps dropping out.

i'll see how it is tomorrow unless anyone's got any other suggestions. it does seem faster now than it was a few hours ago (except youtube).

thanks for your suggestions so far
Reply With Quote
  #6  
Old 7th November 2010, 10:14 PM
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 6,050
unknownkonqueror
Re: How to disable IPv6 in Fedora 14?

Quote:
Originally Posted by peterparks View Post
hmm, doesn't seem to have worked. lsmod still gives me:

ipv6 229420 34 ip6t_REJECT,nf_conntrack_ipv6

i can't run rmmod because the module is in use - even if I stop iptables.

i've disable the setting in firefox, but system-config-network says that my wireless card doesn't have ipv6 anyway.

maybe my problem is just due to my own net connection or flash - youtube keeps dropping out.

i'll see how it is tomorrow unless anyone's got any other suggestions. it does seem faster now than it was a few hours ago (except youtube).

thanks for your suggestions so far

Yes, see my statement that sysctl via the file only takes affect at boot time, to do that now, use the -w option. Also I don't think kicking ipv6 out of the kernel would flush out those modules... maybe after a reboot...
Probably the best way is a combination of system-config-network (turn off ipv6 on the interface) and blacklisting the ipv6
Reply With Quote
  #7  
Old 28th May 2011, 09:14 PM
tazmad78 Offline
Registered User
 
Join Date: May 2011
Posts: 2
linuxchrome
Re: How to disable IPv6 in Fedora 14?

Hi there,

Was just wondering if you ever did manage to get this working i.e disable IPv6 on FC 14 - I seem to be having the same problems with doing this as you had, I have:

"NETWORKING_IPV6=no" in /etc/sysconfig/network

"net.ipv6.conf.all.disable_ipv6 = 1" in /etc/sysctl.conf

"blacklist ipv6" in /etc/modprobe.d/blacklist.conf

I've also removed the ip6tables rpms and i am still seeing:

[root@box1 ~]# lsmod | grep ipv6
ipv6 286354 62

Running out of ideas here...

Thanks
Reply With Quote
  #8  
Old 28th May 2011, 09:41 PM
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 6,050
linuxfirefox
Re: How to disable IPv6 in Fedora 14?

Quote:
Originally Posted by tazmad78 View Post
Hi there,

Was just wondering if you ever did manage to get this working i.e disable IPv6 on FC 14 - I seem to be having the same problems with doing this as you had, I have:

"NETWORKING_IPV6=no" in /etc/sysconfig/network

"net.ipv6.conf.all.disable_ipv6 = 1" in /etc/sysctl.conf

"blacklist ipv6" in /etc/modprobe.d/blacklist.conf

I've also removed the ip6tables rpms and i am still seeing:

[root@box1 ~]# lsmod | grep ipv6
ipv6 286354 62

Running out of ideas here...

Thanks
Try having your change in /etc/modprobe.d/blacklist.conf look like this:
Quote:
blacklist ipv6
install ipv6 /bin/true
Just having a module blacklisted can be circumvented, the "install" line prevents the ipv6 being installed no matter what. Basically /bin/true is a command line function which does nothing but return a success code (there's also a partner function called /bin/false which does the opposite). The above code lies to the install function that ipv6 was installed when it really isn't.

REF:
http://www.g-loaded.eu/2008/05/12/ho...ra-and-centos/

Note that REF is a bit old but it should be generally correct for Fedora

Last edited by marko; 28th May 2011 at 09:45 PM.
Reply With Quote
  #9  
Old 28th May 2011, 10:01 PM
tazmad78 Offline
Registered User
 
Join Date: May 2011
Posts: 2
linuxchrome
Re: How to disable IPv6 in Fedora 14?

Quote:
Originally Posted by marko View Post
Try having your change in /etc/modprobe.d/blacklist.conf look like this:


Just having a module blacklisted can be circumvented, the "install" line prevents the ipv6 being installed no matter what. Basically /bin/true is a command line function which does nothing but return a success code (there's also a partner function called /bin/false which does the opposite). The above code lies to the install function that ipv6 was installed when it really isn't.

REF:
http://www.g-loaded.eu/2008/05/12/ho...ra-and-centos/

Note that REF is a bit old but it should be generally correct for Fedora
Hi Marko,

Many thanks for that - it seems to have done the trick!
Reply With Quote
  #10  
Old 18th June 2011, 03:30 AM
COKEDUDE Offline
Registered User
 
Join Date: Jan 2011
Posts: 351
linuxfirefox
Re: How to disable IPv6 in Fedora 14?

Quote:
Originally Posted by marko View Post
You can fire up the system-config-network util and uncheck the
"Enable ipv6 configuration for this interface" checkbox and save/exit.

see:
http://fedorasolved.org/Members/MrHa...config-network

But if by slow networking you especially mean Firefox, see the forum by searching "about:config" and "network.dns.disableIPv6". Firefox constantly tries to use ipv6 DNS because under Fedora it thinks the existence of that Ipv6 interface (which Fedora puts in by default) really means ipv6 works. But 99% of users don't have ipv6 support actually working. So there's an annoying ipv6 dns -> fail -> ipv4 address obtain loop going on each time. Tell Firefox to quit that via using the about:config page to set the network.dns.disableIPv6 to 'true'
Thx for the firefox tip. That helped me.
Reply With Quote
Reply

Tags
disable, fedora, ipv6

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to disable ipv6? xample Servers & Networking 6 6th November 2009 07:14 PM
Can i disable IPV6 in FC 9? amfpg Servers & Networking 6 21st August 2008 05:40 AM
Disable IPv6 in Fedora 8 Lukast Servers & Networking 3 29th December 2007 05:15 PM
Disable IPv6 steve941 Servers & Networking 4 19th July 2007 12:24 AM


Current GMT-time: 20:08 (Sunday, 21-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat