Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Using Fedora
FedoraForum Search

Forgot Password? Join Us!

Using Fedora General support for current versions. Ask questions about Fedora and it's software that do not belong in any other forum.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 7th November 2010, 06:45 PM
startover Offline
Banned
 
Join Date: May 2010
Posts: 33
linuxfedorafirefox
How to enable automatic login in Fedora 14 Gnome desktop?

I have tried editing
Code:
/etc/gdm/custom.conf
by adding
Code:
[daemon]
AutomaticLogin=myusername
AutomaticLoginEnable=true
but this causes the login take for ever without actually ever logging in

I tried
Code:
[daemon]
TimedLoginEnable=true
TimedLogin=your_username
TimedLoginDelay=0
but then I can never log out because automatically I get logged in right after I log out.

Does anyone here has a working solution?

Last edited by startover; 7th November 2010 at 07:38 PM.
Reply With Quote
  #2  
Old 7th November 2010, 08:02 PM
dchriscoe Offline
Registered User
 
Join Date: Jul 2010
Posts: 5
linuxfedorafirefox
Re: How to enable automatic login in Fedora 14 Gnome desktop?

Startover,

Reverse the order under your [Daemon] statement:

AutomaticLoginEnable=true
AutomaticLogin=username

See if it works for you.
Reply With Quote
  #3  
Old 7th November 2010, 10:39 PM
ssivil Offline
Registered User
 
Join Date: Nov 2008
Posts: 30
linuxubuntufirefox
Re: How to enable automatic login in Fedora 14 Gnome desktop?

Is there a way to allow more than one person a way to login without a password? In Ubuntu, with "Users and Groups" you can select an option "Not asked on Login" on a user by use basis.
Reply With Quote
  #4  
Old 8th November 2010, 09:18 PM
assen Offline
Registered User
 
Join Date: Oct 2008
Posts: 492
linuxfedorafirefox
Re: How to enable automatic login in Fedora 14 Gnome desktop?

Hi,

"autologin" and "logging on without a password" are different things. The former is only possible for one account, obviously; the later should be trivial for as many accounts as needed, just remove the password string from /etc/shadow.

WWell,
Reply With Quote
  #5  
Old 8th November 2010, 09:43 PM
Dangermouse Offline
Administrator - (On Leave)
 
Join Date: Aug 2007
Location: London Postbox (the red one)
Age: 48
Posts: 3,864
linuxfedorafirefox
Re: How to enable automatic login in Fedora 14 Gnome desktop?

Quote:
Is there a way to allow more than one person a way to login without a password? In Ubuntu, with "Users and Groups" you can select an option "Not asked on Login" on a user by use basis.
Use below to login without password but wouldnt recomend using with autologin, change logname to the user you want password less login
Quote:
su
passwd -d -f logname
also if you use timedlogin instaed of autologin then you can log out and change user.
Reply With Quote
  #6  
Old 9th November 2010, 12:25 AM
startover Offline
Banned
 
Join Date: May 2010
Posts: 33
linuxfedorafirefox
Re: How to enable automatic login in Fedora 14 Gnome desktop?

Quote:
Originally Posted by Dangermouse View Post
Use below to login without password but wouldnt recomend using with autologin, change logname to the user you want password less login

also if you use timedlogin instaed of autologin then you can log out and change user.

I need autologin not an account without password

---------- Post added at 07:25 PM GMT ---------- Previous post was at 07:21 PM GMT ----------

Quote:
Originally Posted by dchriscoe View Post
Startover,

Reverse the order under your [Daemon] statement:

AutomaticLoginEnable=true
AutomaticLogin=username

See if it works for you.
the reverse order works in terms of automatic logging when I turn on my laptop but I cannot log out anymore, if I try to log out it will automatically login again just after loging out

Last edited by startover; 9th November 2010 at 10:51 PM.
Reply With Quote
  #7  
Old 9th November 2010, 10:53 PM
startover Offline
Banned
 
Join Date: May 2010
Posts: 33
linuxfedorafirefox
Re: How to enable automatic login in Fedora 14 Gnome desktop?

Quote:
Originally Posted by dchriscoe View Post
Startover,

Reverse the order under your [Daemon] statement:

AutomaticLoginEnable=true
AutomaticLogin=username

See if it works for you.
the reverse order works in terms of automatic logging when I turn on my laptop but I cannot log out anymore, if I try to log out it will automatically login again just after loging out
Reply With Quote
  #8  
Old 9th November 2010, 11:33 PM
jpollard Offline
Registered User
 
Join Date: Aug 2009
Location: Waldorf, Maryland
Posts: 6,815
linuxfedorafirefox
Re: How to enable automatic login in Fedora 14 Gnome desktop?

Well, what did you think autologin means?

Either you want it to autologin or not. If you want more than one
account, then you want accounts that have no password - otherwise
you will not be able to logout - as you will be autmatically logged in
again.

You can TRY the screensaver and switch user... But I don't think that
will work very well either.
Reply With Quote
  #9  
Old 9th November 2010, 11:44 PM
startover Offline
Banned
 
Join Date: May 2010
Posts: 33
linuxfedorafirefox
Re: How to enable automatic login in Fedora 14 Gnome desktop?

Quote:
Originally Posted by jpollard View Post
Well, what did you think autologin means?
dude, if you do not know any solution you do not have to reply. And in any case you better watch your tune

when I used to work with ubuntu, I could configure the OS to automatically login into my account when I turn on my laptop, but I still were able to logout to the login screen

I want to have above in Fedora, nothing is sophisticated or complicated in here

I do NOT want auto-login for more than one user, and I do NOT want to remove password of any user.
Reply With Quote
  #10  
Old 10th November 2010, 12:40 PM
jpollard Offline
Registered User
 
Join Date: Aug 2009
Location: Waldorf, Maryland
Posts: 6,815
linuxfedorafirefox
Re: How to enable automatic login in Fedora 14 Gnome desktop?

Take a hint - autologin IS removing a password - it just doesn't bother to
check.

If you want to use passwords, then get rid of autologin.

It is the most insecure environment. It is intended for use as a kiosk where anyone can use that account.

Be secure - or give it up.
Reply With Quote
  #11  
Old 10th November 2010, 11:02 PM
ssivil Offline
Registered User
 
Join Date: Nov 2008
Posts: 30
linuxfedorafirefox
Re: How to enable automatic login in Fedora 14 Gnome desktop?

Quote:
Originally Posted by assen View Post
Hi,

"autologin" and "logging on without a password" are different things. The former is only possible for one account, obviously; the later should be trivial for as many accounts as needed, just remove the password string from /etc/shadow.

WWell,
Thanks for responding; however, I can't figure out just what the password sting is. Here is the line in etc/shadow:

ssivil:$6$5rGsOYbro7qJyz1A$dMwuPTKnywQRdDf/kbeK83julpQBxW7wRvtwNrL99PBMP6pWnN8CK7u3k1PpyJk569 mx1jtznNcKohKhqm0EO.:14923:0:99999:7:::

Thank you!
Reply With Quote
  #12  
Old 10th November 2010, 11:15 PM
jpollard Offline
Registered User
 
Join Date: Aug 2009
Location: Waldorf, Maryland
Posts: 6,815
linuxfedorafirefox
Re: How to enable automatic login in Fedora 14 Gnome desktop?

It is the second field. See "man 5 shadow".

It is well documented.
Reply With Quote
  #13  
Old 16th November 2010, 08:34 PM
Alexbba Offline
Registered User
 
Join Date: Nov 2010
Posts: 7
linuxfedorafirefox
Re: How to enable automatic login in Fedora 14 Gnome desktop?

Quote:
Originally Posted by startover View Post
editing
Code:
/etc/gdm/custom.conf
by adding
Code:
[daemon]
AutomaticLoginEnable=true
AutomaticLogin=myusername
...
Code:
[daemon]
TimedLoginEnable=true
TimedLogin=your_username
TimedLoginDelay=0
but then I can never log out because automatically I get logged in right after I log out.
I'm a relative newbie here. I'd like to enable automatic login. Where would I enter the above codes that were found to work?

Any help would be appreciated.
Reply With Quote
  #14  
Old 17th November 2010, 02:42 AM
startover Offline
Banned
 
Join Date: May 2010
Posts: 33
linuxfedorafirefox
Re: How to enable automatic login in Fedora 14 Gnome desktop?

Quote:
Originally Posted by Alexbba View Post
I'm a relative newbie here. I'd like to enable automatic login. Where would I enter the above codes that were found to work?

Any help would be appreciated.
Code:
su -c 'nano /etc/gdm/custom.conf'
then add
Code:
AutomaticLoginEnable=true
AutomaticLogin=yourUserName
under
Code:
[daemon]
then press Ctr+X to save the file and exit.
Reply With Quote
  #15  
Old 17th November 2010, 11:17 AM
Alexbba Offline
Registered User
 
Join Date: Nov 2010
Posts: 7
linuxfedorafirefox
Re: How to enable automatic login in Fedora 14 Gnome desktop?

Quote:
Originally Posted by startover View Post
Code:
su -c 'nano /etc/gdm/custom.conf'
Where would I paste/insert this (if not in a terminal or nautilus's location field)?
Reply With Quote
Reply

Tags
gdm

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 13...Automatic Login... HMSS013 Using Fedora 17 31st January 2011 04:46 PM
Fedora Core 10: Login Window to enable automatic login bghayad Using Fedora 1 8th June 2009 04:27 PM
Automatic Login GUI(GNOME) abmpro Using Fedora 5 3rd May 2009 09:06 AM
how do you enable the gnome gui login for root in fc10a? tctc Alpha, Beta & Snapshots Discussions (Fedora 10 Only) 7 24th September 2008 01:55 PM


Current GMT-time: 03:34 (Saturday, 23-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat