Fedora Linux Support Community & Resources Center
  #1  
Old 3rd November 2010, 02:40 PM
shengouki Offline
Registered User
 
Join Date: Nov 2010
Posts: 3
linuxchrome
Unhappy Problem with ATI Mobility X600 (RV380 based) after preupgrade FC13 --> FC14

Hi folks,

I really need your help with one problem I have with the Videocard of one of my laptops. This laptop has a Mobility Radeon X600 card (RV380 based). I always had 3D hardware acceleration with mesa (at least in Fedora 12 and 13), but now it doesn't work. Boot seems normal, but reviewing the logs, I see this in the Xorg.0.log (after loading the radeon modues):

[ 28.749] (EE) AIGLX error: Calling driver entry point failed
[ 28.749] (EE) AIGLX: reverting to software rendering
[ 28.749] (II) AIGLX: Screen 0 is not DRI capable
[ 28.816] (II) AIGLX: Loaded and initialized /usr/lib/dri/swrast_dri.so

So GLxInfo gives me this string:


OpenGL vendor string: Mesa Project
OpenGL renderer string: Software Rasterizer
OpenGL version string: 2.1 Mesa 7.9

I don't have hardware acceleration, so no compositing and no gnome-shell

I tried with both 7.9.1 and 7.9.2 versions of mesa-dri-driver (and its libs). The xorg-x11-drv-ati version is 6.13.1-0.3.20100705git37b348059.fc14

any ideas?


Thanks in advanced and sorry for my english
Reply With Quote
  #2  
Old 3rd November 2010, 09:42 PM
AdamW Offline
Fedora QA Community Monkey
 
Join Date: Dec 2008
Location: Vancouver, BC
Posts: 4,176
linuxfedorafirefox
Re: Problem with ATI Mobility X600 (RV380 based) after preupgrade FC13 --> FC14

Can you post the full /var/log/Xorg.0.log to http://fpaste.org ? Thanks!
__________________
Adam Williamson | awilliam AT redhat DOT com
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
http://www.happyassassin.net
Reply With Quote
  #3  
Old 3rd November 2010, 10:45 PM
shengouki Offline
Registered User
 
Join Date: Nov 2010
Posts: 3
linuxchrome
Re: Problem with ATI Mobility X600 (RV380 based) after preupgrade FC13 --> FC14

Thank you for you fast response!! Here it is

http://fpaste.org/H2Dn/

This paste is with mesa driver 9.7.1

Last edited by shengouki; 3rd November 2010 at 10:55 PM.
Reply With Quote
  #4  
Old 5th November 2010, 10:01 PM
jackhowarth Offline
Registered User
 
Join Date: Nov 2010
Posts: 1
linuxfedorafirefox
Re: Problem with ATI Mobility X600 (RV380 based) after preupgrade FC13 --> FC14

I saw the same issue with a simple yum upgrade using...

yum update yum
yum --releasever=14 update --skip-broken

on a Dell Latitude D810 with X600 graphics. The only solution which worked was to download the files...

mesa-dri-drivers-7.10-0.6.fc15.i686.rpm
mesa-dri-drivers-experimental-7.10-0.6.fc15.i686.rpm
mesa-libGL-7.10-0.6.fc15.i686.rpm
mesa-libGLU-7.10-0.6.fc15.i686.rpm

from rawhide and install them with 'yum --nogpgcheck localiinstall'. After that /var/log/Xorg.0.log reports...

[ 30.765] (II) SELinux: Disabled by boolean
[ 30.925] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[ 30.925] (II) AIGLX: enabled GLX_INTEL_swap_event
[ 30.925] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[ 30.925] (II) AIGLX: enabled GLX_SGI_make_current_read
[ 30.925] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[ 30.926] (II) AIGLX: Loaded and initialized /usr/lib/dri/r300_dri.so
[ 30.926] (II) GLX: Initialized DRI2 GL provider for screen 0

and pymol executed on the command line shows...

OpenGL graphics engine:
GL_VENDOR: DRI R300 Project
GL_RENDERER: Mesa DRI R300 (RV380 3150) 20090101 TCL DRI2
GL_VERSION: 1.5 Mesa 7.10-devel

Oddly 'glxgears -info' seems to report a slower frame rate than the software render.
Reply With Quote
  #5  
Old 6th November 2010, 12:21 AM
AdamW Offline
Fedora QA Community Monkey
 
Join Date: Dec 2008
Location: Vancouver, BC
Posts: 4,176
linuxfedorafirefox
Re: Problem with ATI Mobility X600 (RV380 based) after preupgrade FC13 --> FC14

uf, don't see anything obviously wrong from the logs :/ can you file a bug on this at bugzilla.redhat.com and include all the logs and stuff mentioned at https://fedoraproject.org/wiki/How_t..._Xorg_problems ? thanks!
__________________
Adam Williamson | awilliam AT redhat DOT com
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
http://www.happyassassin.net
Reply With Quote
  #6  
Old 6th November 2010, 12:22 AM
AdamW Offline
Fedora QA Community Monkey
 
Join Date: Dec 2008
Location: Vancouver, BC
Posts: 4,176
linuxfedorafirefox
Re: Problem with ATI Mobility X600 (RV380 based) after preupgrade FC13 --> FC14

oh, component xorg-x11-drv-ati .
__________________
Adam Williamson | awilliam AT redhat DOT com
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
http://www.happyassassin.net
Reply With Quote
  #7  
Old 10th November 2010, 06:00 PM
shengouki Offline
Registered User
 
Join Date: Nov 2010
Posts: 3
linuxchrome
Re: Problem with ATI Mobility X600 (RV380 based) after preupgrade FC13 --> FC14

I have just filed the bug

https://bugzilla.redhat.com/show_bug.cgi?id=651972

@AdamW

Thank you so much for your help and support
Reply With Quote
Reply

Tags
>, ati, based, fc13, fc14, mobility, preupgrade, problem, rv380, x600

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
installation problem with preupgrade fc13 kkshethin Installation, Upgrades and Live Media 3 22nd June 2010 05:47 PM
RV380 [Radeon X600] Dr_Metal Hardware & Laptops 4 16th January 2008 06:01 PM
Problem with ATI Mobility X600 driver - fglrx will not turn on childofasuka Hardware & Laptops 5 18th May 2007 10:32 AM
TV-Out at my Acer TravelMate 4602WLMi / ATI MOBILITY RADEON x600 need help. bravo_elf Hardware & Laptops 0 4th November 2006 03:41 PM
FC4: ATI MOBILITY RADEON X600 driver mnisay Hardware & Laptops 1 14th January 2006 02:16 PM


Current GMT-time: 10:32 (Wednesday, 23-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat