Fedora Linux Support Community & Resources Center
  #1  
Old 20th October 2010, 07:12 AM
geolab Offline
Registered User
 
Join Date: Nov 2008
Posts: 119
linuxchrome
how to enable the nvidia driver in f14?

now that f14 kernel is stable, how to enable the nvidia driver? I tried the instruction guide in f13 but it doesn't work
  #2  
Old 20th October 2010, 10:30 AM
leigh123linux Online
Retired Administrator
 
Join Date: Oct 2006
Posts: 22,375
linuxfedorafirefox
Re: how to enable the nvidia driver in f14?

Code:
yum install akmod-nvidia

reboot
  #3  
Old 20th October 2010, 12:24 PM
geolab Offline
Registered User
 
Join Date: Nov 2008
Posts: 119
linuxchrome
Re: how to enable the nvidia driver in f14?

it's not needed to work on grub as in f13?
and by the way... I did as root a nvidia-xconfig and now it works even if it gives me a error during boot related to livnaconfigdisplay.
is it possible to disable livnaconfig during boot?
is it possible to have the fedora logo i see using nouveau during boot instead of the ugly running lines i get with nvidia driver?
  #4  
Old 20th October 2010, 09:13 PM
AdamW Offline
Fedora QA Community Monkey
 
Join Date: Dec 2008
Location: Vancouver, BC
Posts: 4,176
linuxfedorafirefox
Re: how to enable the nvidia driver in f14?

add vga=788 or vga=791 as a boot parameter.
__________________
Adam Williamson | awilliam AT redhat DOT com
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
http://www.happyassassin.net
  #5  
Old 21st October 2010, 06:27 AM
geolab Offline
Registered User
 
Join Date: Nov 2008
Posts: 119
linuxchrome
Re: how to enable the nvidia driver in f14?

thanks! it works!
  #6  
Old 24th October 2010, 01:05 AM
Lebenskuenstler Offline
Registered User
 
Join Date: May 2008
Posts: 57
linuxfedorafirefox
Re: how to enable the nvidia driver in f14?

Hi,

driver does not load:

[root@hobbes ~]# /etc/init.d/nvidia start
Checking for module nvidia.ko: [ OK ]
Enabling the nvidia driver: Traceback (most recent call last):
File "/usr/sbin/nvidia-config-display", line 28, in <module>
import livnaConfigDisplay.ConfigDisplay
File "/usr/lib/python2.7/site-packages/livnaConfigDisplay/ConfigDisplay.py", line 29, in <module>
import xf86config
File "/usr/lib64/python2.7/site-packages/xf86config.py", line 1, in <module>
import ixf86config
ImportError: /usr/lib64/python2.7/site-packages/ixf86configmodule.so: undefined symbol: xstrtokenize
[FEHLGESCHLAGEN]
[root@hobbes ~]# uname -r
2.6.35.6-45.fc14.x86_64

---------- Post added 2010-10-24 at 02:05 AM GMT ---------- Previous post was 2010-10-23 at 11:14 PM GMT ----------

Running as root nvidia-xconfig did help, although after 2nd try. Do not know, why first one failed.

Last edited by Lebenskuenstler; 24th October 2010 at 03:27 AM.
  #7  
Old 25th October 2010, 07:01 AM
hellork Offline
Registered User
 
Join Date: Dec 2007
Posts: 244
linuxfedorafirefox
Re: how to enable the nvidia driver in f14?

It's a bug
https://bugzilla.redhat.com/show_bug.cgi?id=623742
__________________
Data, Information Processing, Secure Hosting, and Internet Technology (D.I.P.S.H.I.T.)
  #8  
Old 25th October 2010, 12:38 PM
NickLee Offline
Registered User
 
Join Date: Oct 2009
Location: Europe
Posts: 24
windows_xp_2003opera
Re: how to enable the nvidia driver in f14?

F14-64bit GeForce 310M
For me not work. I get:
Code:
[   111.489] (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
[   111.490] (EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
[   111.490] (EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
[   111.490] (EE) NVIDIA(0):     you continue to encounter problems, Please try
[   111.490] (EE) NVIDIA(0):     reinstalling the NVIDIA driver.
But with NVIDIA-Linux-x86_64-260.19.12.run works fine.
  #9  
Old 25th October 2010, 03:16 PM
geolab Offline
Registered User
 
Join Date: Nov 2008
Posts: 119
linuxchrome
Re: how to enable the nvidia driver in f14?

I disabled the nvidia service to get rid of the error during boot time. in any case (enabled or not) the nvidia driver seems to be very heavy tothe system: gnome shell and all the programs are very slow on startup and very slow in responding...
  #10  
Old 25th October 2010, 03:37 PM
Dangermouse Offline
Administrator - (On Leave)
 
Join Date: Aug 2007
Location: London Postbox (the red one)
Age: 48
Posts: 3,864
linuxfedorafirefox
Re: how to enable the nvidia driver in f14?

I installed the one straight from nvidia works fine the rpmfusion one was useless, theres a guide in here somewhere on how to install it.
  #11  
Old 25th October 2010, 10:22 PM
AdamW Offline
Fedora QA Community Monkey
 
Join Date: Dec 2008
Location: Vancouver, BC
Posts: 4,176
linuxfedorafirefox
Re: how to enable the nvidia driver in f14?

the problem is that nvidia-config-display actually does useful stuff (it's not just there for fun), so since it fails to run, the configuration steps it should perform don't happen, and you wind up with a misconfigured driver. If you manually do the stuff nvidia-config-display is supposed to do, it ought to work; I haven't checked exactly what that is, though (part of it will be to write a /etc/X11/xorg.conf that specifies the nvidia driver).
__________________
Adam Williamson | awilliam AT redhat DOT com
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
http://www.happyassassin.net
  #12  
Old 26th October 2010, 10:53 AM
NickLee Offline
Registered User
 
Join Date: Oct 2009
Location: Europe
Posts: 24
windows_xp_2003opera
Re: how to enable the nvidia driver in f14?

Quote:
Originally Posted by geolab View Post
I disabled the nvidia service to get rid of the error during boot time. in any case (enabled or not) the nvidia driver seems to be very heavy tothe system: gnome shell and all the programs are very slow on startup and very slow in responding...
You realy have 3D?

I have works very slow 2D, works VDPAU, but 3D not work.

glxinfo?
  #13  
Old 26th October 2010, 12:10 PM
ah7013 Offline
Registered "Cashew" User
 
Join Date: May 2010
Location: Adelaide, Australia
Age: 20
Posts: 671
linuxsusefirefox
Re: how to enable the nvidia driver in f14?

I have nvidia driver working in F14 RC1 by adding the RPMFusion repo and installing akmod-nvidia then run nvidia-xconfig. Graphics card is Nvidia GTX 260. 2D is soooo sloowwww so reverting back to nouveau

Last edited by ah7013; 26th October 2010 at 12:15 PM.
  #14  
Old 26th October 2010, 01:35 PM
NickLee Offline
Registered User
 
Join Date: Oct 2009
Location: Europe
Posts: 24
windows_vistaopera
Re: how to enable the nvidia driver in f14?

Quote:
Originally Posted by ah7013 View Post
I have nvidia driver working in F14 RC1 by adding the RPMFusion repo and installing akmod-nvidia then run nvidia-xconfig. Graphics card is Nvidia GTX 260. 2D is soooo sloowwww so reverting back to nouveau
I mean nvidia driver from rpmfusion works not properly. Try nvidia driver from nvidia site. Works fine for me.
  #15  
Old 26th October 2010, 05:39 PM
geolab Offline
Registered User
 
Join Date: Nov 2008
Posts: 119
linuxchrome
Re: how to enable the nvidia driver in f14?

but in case, how to disable the driver from nvidia site once the rpmfusion is working right?
 

Tags
driver, enable, f14, nvidia

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Should we enable nouveau back after installing NVIDIA driver? kimsieng Installation, Upgrades and Live Media 2 17th October 2010 04:05 PM
nouveau nvidia display how to enable it james2b Using Fedora 5 17th October 2010 05:00 AM
Nvidia Geforce Go 7400 cannot enable on fedora 12 giusemc Using Fedora 4 8th March 2010 08:25 PM
How do I re-enable the nouveau driver? dth4h Using Fedora 0 11th December 2009 04:41 PM
COuldn't enable desktop effects in Fc10 after NVIDIA driver install karthas Using Fedora 0 28th November 2008 04:21 AM


Current GMT-time: 22:53 (Tuesday, 29-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat